SimpleScreenRecording lack of codecs [solved]

error message

I installed SimpleScreenRecording, a nice software to take screen record but recording don’t start because of lack of codecs. I get this error message.
Which packages I have to install?

PageRecord::StartPage] Starting page …
[PageRecord::StartPage] Started page.
[PageRecord::StartOutput] Starting output …
[Muxer::Init] Using format mp4 (MP4 (MPEG-4 Part 14)).
[Muxer::AddStream] Using codec libx264 (libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10).
[BaseEncoder::Init] Error: Can’t open codec!
[PageRecord::StartOutput] Error: Something went wrong during initialization.

OpenMandriva 2014.2 64 bit

are lib64x264 installed?

already installed lib64x264_142 only

After installing also

the error message don’t change.

in cooker

LC_ALL=C urpmi simplescreenrecorder A requested package cannot be installed: simplescreenrecorder-0.3.1-3-omv2015.0.x86_64 (due to unsatisfied Continue installation anyway? (Y/n)
Is it the same ?

No. I installed SimpleScreenRecording in two different pc.
In my notebook it works perfectly.
In a desktop it install, opens but don’t start recording giving error message reported.

maybe try ldd which SimpleScreenRecording

for to know if you have all libraries required

  • change the name is the binary is not this

I can’t write single quote, use the path

are you using the same video/audio codecs in ssr settings on both pcs?

Just tested in 2014.2 x86_64 (1)
There are a lot of codecs available: x264, VP8, theora …
Some work well: VP8, theora, yuv4, ffv1 for example. I didn’t test all codecs.
Giorgio, you might use them.

x264 gives this error:

[libx264 @ 0x20b8b60] cannot open shared object file: No such file or directory is missing, x264 support will be disabled

lib64x264_142 is installed. So, it seems that SSR has not been compiled with the same version of x264 library.

(1): btw, both urpmi and drakrpm refused to install SSR.
The first did nothing without any message, the second only said that the package cannot be installed. I had to download it and to use rpm to install it.

i’ve updated it to 0.3.6, try urpmi ssr instead. the old version was built against an old ffmpeg which was looking for an old x264.

Perfect! Thanks crisb :slight_smile:

Wonderful. Updating to new version solve all problems. Now Simple Screen Recorder works perfectly. And it’s very easy to use and powerful.
Thanks to all of you for help.

By the way I tried ** ldd /usr/bin/simplescreenrecorder** but I get a long list of dependencies.