Realtek RTL8723BE wireless card

In my notebook wireless card RTL8723BE don’t works correctly. This wireless card has three antenna connections and if wrong antenna is chosen the sensitivity is very low and wireless works only if signal is very strong.
I found a workaround, using these command as root in konsole I choose right antenna connection:

modprobe -r rtl8723be
modprobe rtl8723be ant_sel=1

but I’ve to repeat this operation after any boot.
Is there a way this settings become permanent?

  • OpenMandriva Lx version: 3.0
  • Desktop environment: KDE

I’d say you can see on the /etc/modprobe* side or /etc/rc.d/rc.local (to be created, eventually).

Infos: /etc/rc.d/rc.local is a bash script and must be executable in order to be launched by the systemd rc-local.service

Let me check if I understand. In my system I don’t have /etc/rc.d/rc.local then I’ve to make a file with my two commands inside, I call it “rc.local” and i save it in /etc/rc.d/. Is it correct?

That’s it. Don’t forget to add this line at the beginning of the script:


rc.local don’t works.
I’ve a script that works if executed in konsole as root.
I saved as rc.local and checked permission: it’s still executable and give read and write permission to all but after boot settings are wrong. The same script executed in konsole set correctly antenna.

It’s strange, because it should work.

Retry (step by step procedure):

create a file


modprobe -r rtl8723be ; modprobe rtl8723be ant_sel=1

name the file as rc.local

save it in /etc/rc.d :


make it executable.


Giorgio, double check the commands, as I merely copy-pasted from yours.

I (double) checked and removing all unnecessary now it works.
Probably the main difference was “sudo modprobe -r rtl8723be” in script executed in konsole and “modprobe -r rtl8723be” in rc.local.

Then, just to be clear my rc.local is

modprobe -r rtl8723be
modprobe rtl8723be ant_sel=1

of course my antenna connected to input 1.

After reading some documentation I think I found something useful. Unloading and re-loading the module with the option works but is not as fast as load the module with the right option just once, so putting a configuration file into /etc/modprobe.d/ could be a better solution. The name of the file is at your wish (but must end with .conf) and content is just the following line:

options rtl8723be antsel=1

In this case every time you load the module (and not just at start) the option will be apply. For mode info just type man modprobe.d.

1 Like

It seems not working.
This is my *.conf file

$ cat /etc/modprobe.d/rtl8723be.conf 
options rtl8723be antsel=1

but sensitivity is low.
Executing in konsole

sudo modprobe -r rtl8723be 
sudo modprobe rtl8723be ant_sel=1

reestablish normal sensitivity.

1 Like

You’re right, I missed the underscore (I took this from the post above) so the right content of the file should be:

options rtl8723be ant_sel=1
1 Like

I’m happy something got resolved.

1 Like