Problemi con Update

rpm
Tags: #<Tag:0x00007ff2b77a5510>

(Lorenzo) #1

Ciao a tutti,

ogn giorno accendo il computer e faccio l’update (non da riga di comando, ma dal centro di controllo).

Da tre giorni però il messaggio che mi viene presentato, quando lancio il programma di aggiornamento è:
“Si è verificato un errore fatale: coudn’t open RPM DB () : at usr/lib/perl5/vendor_perl/5.20.3/Rpmdrake/opendb.pm line 74”

cos’è successo? e soprattutto, come posso rimerdiare?

Ho l’ultima versione di OM aggiornata proprio il giorno prima. Non sono espertissimo, ditemi se avete bisogno di log o altre informazioni.

Grazie


(Ben Bullard) #2

Benvenuti in OpenMandriva lbattisti80. Spero vi piaccia questo forum e la distribuzione.

Mi chiedo come qualcuno possa arrivare fino in fondo senza sapere quali pacchetti sono stati aggiornati.
Possiamo anche supporre che questo sia in OM Lx 3? In altre parole, se qualcuno ti aiuta, devi aiutarci con più informazioni. Per favore leggi e segui [questo] (How to get better results when posting about problems) e [this.] (Https: / /forum.openmandriva.org/t/useless-posts-update-broke-my-system-or-since-updates-foo-doesnt-work/1473) Se non capisci l’inglese usa un traduttore come faccio io per rispondere in italiano e altri forum.

E per favore non esitare a fare domande su ciò che non capisci o con cui non ti senti a tuo agio. Qualcuno proverà a guidarti attraverso qualunque cosa tu possa aver bisogno di aiuto.

Welcome to OpenMandriva lbattisti80. Hope you enjoy this Forum and distribution.

Wondering how anyone could get to the bottom of this without knowing what packages were updated.
Also can we assume this is in OM Lx 3? In other words for anyone to help you you need to help us with more information. Please read and follow this and this. If you don’t understand English use a translator like I do to respond to Italian and other forums.

And please don’t hesitate to ask questions about any of this you don’t understand or aren’t comfortable with. Someone will try to walk you through whatever you might need help with.


(Ben Bullard) #3

FWIW: Rpmdrake sta funzionando bene qui in OM Lx 3. Il gui “ufficiale” per l’aggiornamento dei sistemi in Lx 3 è Scopri ora non Rpmdrake.

FWIW: Rpmdrake is working just fine here in OM Lx 3. The “official” gui for updating systems in Lx 3 is Discover now not Rpmdrake.


#4

Puoi provare a ricostruile il database dei pacchetti come descritto qui.


(Lorenzo) #5

sono riuscito. Grazie per il consiglio!