Problem with GCC when compiling the nvidia driver

when trying to install the script of the nvidia driver says: ERROR: Unable to find the development tool cc in your path; please make sure that you have the package ‘gcc’ installed. If gcc is installed on your system, then please check that cc is in your PATH.

when trying to install the nvidia 340 driver from rpmdrake, says: file /etc/ from install of x11-driver-video-nvidia340-340.96-2.x86_64 conflicts with file from package x11-server-common-1.18.3-4.x86_64

from configure your hardware (Control Center) nothing changes. I am not sure I have my video well installed.

after an advice on the irc i wrote as root

cd /usr/bin && ln -s gcc cc

and now when executing the script says

ERROR: Unable to find the kernel source tree for the currently
running kernel. Please make sure you have installed the
kernel source files for your kernel and that they are
properly configured; on Red Hat Linux systems, for example,
be sure you have the ‘kernel-source’ or ‘kernel-devel’ RPM
installed. If you know the correct kernel source files are
installed, you may specify the kernel source path with the
‘–kernel-source-path’ command line option.

For info, related bugzilla ticket.

I hope it’ll be fixed soon :frowning:

From Crispin Boylan on OM Cooker ML:

GLdispatch is in:


so the file is not missing it was just an autodep failure of rpm.

fixed now in 367.44-1