PCManFM-QT 'Places' menu broken can't navigate

Tags: #<Tag:0x00007fe31870a898>

Hello,

Post-edit: The purpose of this thread is to get PCManFM-QT fixed.

Bug Report here.

  • OpenMandriva Lx version: Lx 3 all

  • Desktop environment (KDE, LXQT…): LXQt several versions since at least Aug. 2017.

  • Description of the issue (screenshots if relevant): PCManFM-qt Left Panel ‘Places’ menu does not work, is not usable. Note in the main window Documents is showing even though Computer is selected and should be showing. What happens is that in ‘Places’ on the left panel it will go to the first window I try and then it will not move, will not go anywhere else. If I change to Directory tree same issue. Curiously in the tool bar menu if I select either ‘Go’ or ‘Bookmarks’ I can navigate so it is the left panel ‘Places’ (or ‘Directory tree’) that is broken. Anyway if Y’all spend a minute or two in this application you’ll quickly get the jist of what I’m seeing.

Also what should be the mouse cursor is showing a clock going round and round like something is downloading or something. The clock/mouse cursor does not show up in screen shot for some reason. I set a time delay so that was visible to me when picture was taken so no idea why it did not show up in screen shot unless it is a “Vampire” clock/mouse cursor.

  • Relevant informations (hardware involved, software version, logs or output…): Current package version is:

    $ rpm -qa pcmanfm-qt
    pcmanfm-qt-0.12.0-3-omv2015.0.x86_64

I have tried using both openbox and kwin-x11 window managers.

Off Topic Question for my own training and education.@Workshop Moderators I tried to have lxqt and qt5 flags for this thread for a reason, or several reasons but they don’t show. Wondering why they don’t show as they are keys to this issue. :confused:

Post-Edit: I want to tag this with 3 tags lxqt omlx-3.03 qt5. qt5 might be a major factor in this issue.

Using kwin-X11 WM this is ‘journalctl -mxe’:

journalctl-mxe.txt (108.5 KB)

I have only quickly scanned this and don’t see anything relevant yet plus there may be a better way to get logs for this or different/better logs. If someone will advise how to or what to do I’ll do it.

Post-edit: Just to be thorough here’s decompressed omv-bug-report.log:

omv-bug-report.log.txt (630.9 KB)

And a skimpy xorg.session.log:

xorg-session.log.txt (266 Bytes)

:see_no_evil: :hear_no_evil: :speak_no_evil:

Off Topic: I too am experiencing some trouble. The issue is that I cannot add more than 1 tag. <— this is the current issue
Postedit: and after a while, it doesn’t show up as well :thinking:
Postedit2: I have a suspect on why it happens. Need further investigation.

1 Like

resolved in 0.12.0-4omv, culprit was lto, disabling makes it work fine.

4 Likes

Verified fixed here. Thanks @crisb. I was not expecting that to be fixed so fast!