OpenMandriva LX3 Beta 1 will not co-exist with Linux Mint

Hi, I am new to this so hope it is in order. I used Mandriva about 10years ago but fell out with it & have been mainly using Mint since then. Saw your new Beta on Distrowatch and thought I would give it another try. It downloaded and installed just fine, and my old Brother printer scanner set up really easily. What I saw I liked but with it being a Beta I was not going to use it as my main OS. I logged off and tried to open my Linux Mint OS but it came up with a message "$HOME/.dmrc file has incorrect permissions and is being ignored. … file sould be " “owned by user and have 644 permissions. .”. I Googled and found how to sort that and got Mint up and running again, then went to retry Mandriva but it went past the boot screen and then froze. I rechecked Mint but that was fine.

I decided to totally reinstall Mandriva and once again it all went well and it worked fine, printer worked etc. Once again I went to restart Linux Mint and got the same message as before. I reset the permissions for my Home folder again, and Mint was back up & running. I later went to have another look a Mandriva, and once again it freezes. It was at this point that I realized that is must be something in the Mandriva set-up that is changing the ownership of my home folder files. It has never happened to me before and I do quite frequently try different Linux OSs.

hi and welcome

if I well understand you have a shared /home (if not, take no account of the following)

just an idea, maybe it’s a GID,UID problem. try in your home with OMV and MINT : ls -ln like this

drwxr-xr-x 2 1001 1005 4096 avril 7 14:49 Bureau
drwxr-xr-x 3 1001 1005 4096 avril 9 19:59 Documents
drwxr-xr-x 3 1001 1005 4096 avril 8 10:03 Images
drwxrwxr-x 2 1001 1005 4096 avril 7 07:47 logs
drwxr-xr-x 2 1001 1005 4096 avril 7 07:29 Modèles
drwxr-xr-x 2 1001 1005 4096 avril 7 07:29 Musique
drwxrwxr-x 2 1001 1005 4096 avril 9 19:58 omlx3_three
-rw-rw-r-- 1 1001 1005 755999 mars 30 05:12 omlx3_three-5X4.png
-rw-rw-r-- 1 1001 1005 7076367 mars 30 05:14

I think user,group must have the same name but also the same number. try with new user it’s safer

jojodu34 has it right…we made a change to the starting uuid and guids for users to start at 1000 which is now pretty much the standard. I expectt that Mint is still using the old standard which starts at 500.
The best thing to do would be to change your Mint guid and gid to match that of the OpenMandriva this is the safest way.

Thank you jojodu34 and Colin.

I have as suggested used ls -ln and and all the folders in my Home folder are shown with the prefix drwxr-xr-x then a number followed by 1000 1006 4096 (one folder has a greater number), and then the date & folder name. This has only been done in Mint as I cannot get OMV to start.

If I try to start OMV the system just freezes, no reaction to key strokes or the mouse, so I have shutdown with the power switch. If I start with OMV Recovery Mode, as the system scrolls through it shows a FAILED to start Show Plymouth Boot Screen
See ‘systemctl status plymouth-start.service’ for details.

I entered this when it finished scrolling and it came up with
'plymouth-start.service - Show Plymouth Boot Screen
Loaded: loaded (/lib/systemd/system/plymouth-start.service; static; vendor preset: disabled)
Active : failed (Result: core-dump) since Thu 2016-04-14 11:50:01 BST: 1min 53s ago
Process: 1843 ExecStartPost=/bin/plymouth show-splash (code=exited, status=1/FAILURE)
Process: 1838 SxecStart=/sbin/plymouth --mode=boot --pid-file=/run/plymouth/pid --attach-to-sessi
Main PID: 1840 (code=dumped, signal=SEGU)

Unfortunately none of this means anything to me, if I do not have clear step by step instructions I am totally lost as to what to do. Normally I would simply give up with a distro at this point but I really want to give OMV a proper try, but it does need to operate alongside my existing distro.