OpenMandriva Lx 3.0 Beta2 released

OpenMandriva Lx 3.0 Beta2 released
Announced at our blog:

It was worth waiting for it, we promise! OpenMandriva Lx 3.0 Beta2 is now ready!
Here, check out why:

This second beta has concentrated on improved stability and performance and now, for the first time, has accommodation for the Chinese and Japanese languages using fcitx to support their input methods.

OpenMandriva is a cutting edge distribution compiled with LLVM/clang. Combined with the high level of optimisation used for both code and linking (by enabling LTO) used in its building, this gives the OpenMandriva desktop an unbelievably crisp response to operations on the KDE Plasma5 desktop which makes it a pleasure to use.
The latest release of all the KDE apps is there to support the desktop and help give you a consistent feel.

A selection of media players are available including the popular mpv and VLC. Plasma Media Center is provided for those whose interest is media center usage.

An alternative full screen application launcher is provided for those who prefer this new approach

For those wishing to use a lightweight desktop environment we also provide LXQt, which brings with it Qupzilla a new and very fast browser based on the QtWebEngine, and the lightweight file manager PCmanFM.

The CD/DVD burning application K3b previously only available in KDE4 is now available under Plasma5.
The ISO building program omdv-build-iso now features improved support for creating personalised compilations.

We are amongst the first distributions daring to switch from python 2.x to 3.x. In Beta2 the om-welcome app has been rewritten in C++ so it’s no longer necessary to bloat the install with the whole python2 compat stack.

OpenMandriva build system (12 servers and 4 arches) uses docker (V1.1x) at its core.
For this our OpenMandriva docker HAS to be THE best
It helps us to be more flexible and run build nodes on any hardware in one click.

Most noticeable change:

KDE Plasma 5.6.5
KDE Frameworks 5.23.0
KDE Apps 16.04.2
Kernel 4.6.2
Systemd 230
Xorg 1.18.3
Mesa 12.0-rc4
F2FS support – A filesystem for SSD

Detailed information about this release can be found in OpenMandriva Lx 3.0 Release Notes
All issues should be addressed at our Bugzilla Issue Tracker
Our sources can be found on Github OpenMandrivaAssociation

Download links:

It’s far much easier to upload the iso to source forge or to make it as torrent then to download on my own laptop …
Anyway, I tried the installation on vbox and on 2 real laptops with ssd.

1. vbox:
– as already said, the direct install doesn’t work: calamares “segment faults” and reboots.
– from the live mode with efi enabled (1), that works fine, the installation stops just before installing grub

I had to install grub from the cli, with:

grub2-install --boot-directory=/tmp/calamares-root-xxxxx/boot --efi-directory=/tmp/calamares-root-xxxxx/boot/efi

Edit: I used the manual partitioning. According to zuzu21 that the automatic partitioning works.

2. asus ux31e
– live mode ok, but install fails because of an error about unpacking the squashfs. I tried several times with 2 different keys.
I launched calamares in cli and I got this log.
I had to overwrite the preceding installation (2014) because I have only a small ssd and there was no separate boot partition. So, grub was broken. Trying to install it with cli failed. Finally I had to reinstall 2014.2 in non efi mode.

3. asus gl752vw
The iso boots and I can start the live mode but I cannot go very far because the fan, suddenly, starts to run at full speed and after short time the computer stops (2)

(1) Btw, with efi enabled, the installer gives no choice for grub installation

(2) This computer runs 2014.2 with the kernel 4.1.15-nrjQL-desktop-1omv. More recent kernels are either unstable on this machine or, worth, make the CPU frequency outside of the limit, according to gkrellm for example.
Therefore, the fan runs at full speed and the computer stops after about one minute. Setting the governor to low frequency doesn’t change anything. This is annoying because the kernel 4.1.15 doesn’t manage the screen light and the the touchpad. This situation seems to be specific to this machine and I might get some clues here.