OpenMandriva 4.3 on VMware


I’m actually trying out various Linux and other systems on VMware Workstation 16. OpenMandriva LX 4.3 is one of the rare ones that don’t work. Booting the DVD gives the first screen, as described at, but trying to launch the live cd fails: black screen with BIOS boot, black screen with a flower with UEFI boot. There actually is a simple workaround: Using the first option in Troubleshooting (basic graphics mode), the live cd starts up. Installation works fine, just as described in the tutorial mentioned before. However, when trying to boot the system, nothing happens, i.e. same problem as with the DVD. I suppose that the desktop used on OMA Lx 4.3 does not work with VMware, or that I have to do some special settings in VMware and/or the OMA startup files to make it work. Is there, please, anyone who can help me?

Welcome to OpenMandriva Community @anon61792315.

OpenMandriva is a direct descendant of Mandrake/Mandriva Linux. We are a very small, all unpaid, all volunteer group.

Can you try boot to cli mode and then run command: startplasma-wayland

1 Like

This has been reported by one or more VMware users like Old Mate Backyard Tech. I would like to see this get fixed. But this may be difficult as I do not recall anyone in OM contributor group that uses VMware where either VirtualBox or quemu are used as far as I know. (I use VirtualBox.)

The suggestion from @AngryPenguin is a good place to start trouble shooting this.

Also you might consider working directly with developers/contributors on OpenMandriva IRC. The OpenMandriva channel is the user channel and the OpenMandriva Cooker channel is where developers and contributors work.

Edit: Other commands that might work from cli: startplasma-x11, startx, or maybe systemctl start sddm. And even if any of the commands do not work the error messages may lead to a solution or workaround.

Thanks for answering.
Not really sure, what you mean by “cli”. There is a such entry in the DVD boot menu, but after installation on the harddisk and booting from there, this is no longer available. I tried CTRL+ALT+t at the black screen, that appears and stays after running any of the HDD boot options (in fact, in my case, it’s a black screen with a flower and there is no mouse pointer), but nothing happened.
Supposing that solving the problem would take more effort and time, that I’m willing to spent, I decided yesterday to delete the VM and pass to trying some other Linux distribution. Maybe I’ll try with OMA Lx 4.2 or older one day, or perhaps try to find an original Mandrake (one of the best known Linux distributions years ago). Thanks anyway…

1 Like

I actually did try out version 4.2. Sorry guys, to say this: OMA Lx is, after trying a dozen of Linux distributions, the worst experience imaginable! Version 4.2 did install without any problems and booted fine, but (the first time this happened to me with a modern OS) no possibility to resize the display (being at 1024x768). I could have accepted this, but after updating the system, same situation as with version 4.3: a black screen with a flower, and that’s it! Even though you can say that your system has not been developped for VMware, considering that Ubuntu, Mint, Fedora, openSuse, Slackware… work fine, I just can call this disappointing!

1 Like

Help us find a developer to fix this.

Edit: Right now all of our handful of developers and contributors are working on other things. In fact we are buried. We do not have enough resources to do everything distros like Ubuntu, Mint, Fedora, openSuse, Slackware are able to do. Over time we may get this sorted out. If we can work with whatever license that VMware uses. I think there may be a problem there.

I would also wonder if all of this is done only by people at Ubuntu, Mint, Fedora, openSuse, Slackware or if there is not some collaboration between VMware developers and those distros?

Unfortunatelly, I have completelly the same experience as you described with LX 4.3 in Oracle VirtualBox. It looks that problem is not in the host part.

No promises but a few people are looking at this issue. Keep in mind that the entire contributor/developer group consists of only a few part-time, volunteer people.

For @vladuna and @anon61792315 the solution appears to be this. To do this:

  1. At the grub2 login screen scroll down to “Trouble shooting”

  2. Select to boot to cli

  3. When you get to cli type “live” to login

  4. Type “startplasma-wayland”

  5. Enjoy OMLx

For use on OM Lx host system I do not and will not recommend for OM Lx users to install this software. My comments apply to the free version 16.2.3 on VMware website installed for use in OMLx Rolling and Rock systems. It is not opensouce at all. Also it appears to be written for kernel 4.x or older which if true is just bizarre. Anyway after installing the software from VMware website when you start VMware it is supposed to install the kernel modules, but it doesn’t. Getting those installed is tricky. This means this software will be like nvida proprietary software drivers and it will break for every new kernel.

Anyone that installs VMware on your OMLx system just remember that like any 3rd party non-free sofware you install and use at your own risk. Does not mean we won’t try to help with problems, as I have done here, but any problem within the software itself we can not touch. Legally we can’t even read their code. Same crap as with nVidia proprietary drivers.

The free version so far to me seems very klunky, as in a bit of a pain in the rear end to use. But this is all very new to me.

The VMware Pro version at the cheapest cost € 141, or $ 149 and then another € 75, or $ 79 to upgrade to next new version. (I converted the € prices from $ so don’t know if that includes the VAT in your country.)

Edit: Note: The problem with VMware not installing kernel modules is not an OpenMandriva issue. You can find numerous posts about this on distros like Ubunu, Fedora, CentOS and more. The issue is it does not work out of the box on modern Linux kernel. I found a solution originally posted for Debian Sid on Github that worked for me.

I installed Rock in VMware and predictably it won’t boot normally. But a bigger problem is that VMware seems like it will only restart the VM where it stopped. Huh? How does one problem solve if you can not start the OS at the beginning? I am not sure I have the patience to sort this. This means for every problemm solving step I will have to install the OS from scratch.

Figured that out, there is a way to send Ctrl>Alt>Del. So far Rock installed system won’t boot in cli or recovery mode. There is not much I can do to problem solve this. Edit: That really means we would need someone that knows more than I do to problem solve this issue.

The vmware logs:

vmware.log.txt (217.9 KB)

vmware-0.log.txt (269.8 KB)

vmware-1.log.txt (149.9 KB)

vmware-2.log.txt (155.6 KB)

Need someone more knowledgeable to look at these. I do see this in all of the logs:

2022-06-27T20:04:32.396Z In(05) vmx ConfigDB: Failed to load ~/.vmware/config

2022-06-27T19:09:11.764Z In(05) vmx DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.

Neither of those are present on host system.

Now I am confused.
I joined this thread because I had the same problem as @anon61792315.
He uses VMWare, me VirtualBox.
But both of us have problem with OML as a guest.

Many thanx, it seems to be working, just installing now, happy.
Mandrake and SuSE were my first Linuxes.
Now going back to deal with Linux due to networking tasks and issues.
Once again, thanx.
Note: installed, booted, loaded GUI, frozen. But at least, I moved one step ahead.
Now I will install it again watching what is exactly happening.
Otherwise, the machine itself is running. Found by IP scanner.

Then I missed that in your post, apologies for that.

And I am happy that you got it working.