Nvidia vendor driver: blank screen at Xorg loading

I need a help ASAP.

I installed latest updates and installed the latest kernel. But system does not boot. So I used previous kernel in OMA 3 x86
I log in to the system and open MCC boot and saved. (No changers were done)
Then I changed the Grub2 using KDE settings to automatically boot the last boot option. I saved. an error came saying can not save.
but system saved the settings. I rebooted the system.
now GUI login screen is not displaying. Instead CLI is showing. How do I change this to GUI.

VGA card: ASUS GForce 210
Resolution: 1600 x 900
Monitor: LG LED 20M35

I changed the Display settings in MCC using the shell. but no GUI Login.

Please help.


Pujitha Dimuthu

Login as root

# systemctl enable sddm
# systemctl start sddm

Thanks, now black screen mouse pointer shows. nothing…

Sorry, I only know that MCC/boot disable sddm.service(obviously an issue).
That is why was showing cli.

just an idea: you might have to remove/rename the Xorg config file if it exists. As root:
mv /etc/X11/xorg.conf /etc/xorg.conf.back
Then as user:

Thanks. yes it worked.
I done
mv /etc/X11/xorg.conf /etc/xorg.conf.back
init 6

@pujithadimuthu Please edit your title into a meaningful new one


Choose a meaningful subject title (ex, no: “Help me!”, Booooh!, etc.)

You may want to read also

If your problem is solved, please mark which reply solved the problem

Thank you.


Again I got this problem. I tried to put the VGA setting I only select the VGA card. Then save. no login.
I tried the previous instructions but they do not work. I need your help. This time OMA 3 has lot of bugs.

Please Help me.

I can edit xorg.conf file using another Linux distro.

Did you use XFdrake? To do so use OM-Welcome>Configure>Configure the video driver and do exactly what it says and only what it says. Then let me know what results you get.

Edit: An alternative would be to try OpenMandriva 2014 and see if that doesn’t work better on your hardware. If it does that could help us problem solve the issue in OM Lx 3.0. 2014 may prove more stable and bug free for you as well.

yes. I tried XFdrake in MCC GUI. previously I used OMA 2014.2 works fine. Mageia 5 is already installed in my pc. it’s driver also working fine.

OM-Welcome crash. now MCC CLI does not work.

Anyone knows how to enable mcc services at the startup. I think I can bring up the system again.

Seems it is not working.

Do you have virtual konsoles? ie. >CTRL>ALT>F2, or F3, F4. F5, F6? and run drakconf (same as mcc) there or XFdrake if it is only video card needing configuring.

Can you use Live media to mount installed system and chroot into it?

Used recovery mode in the Grub.
used XFdrake.
Configure the Free Driver Gforce 8100 to GForce 415 (not the property driver)
Start with X…



But the driver used is nouveau right? Not nvidia?

I do not know that system will ask property driver has more features I apply no. default I think installing.

What does the command inxi -G gives you?

[pujitha@dimuthu-pc ~]$ inxi -G
Graphics: Card: NVIDIA GT218 [GeForce 210]
Display Server: OpenMandriva X.org 118.4 driver: nouveau Resolution: 1600x900@60.00hz
GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 12.0.3
[pujitha@dimuthu-pc ~]$

1 Like

The same as mine :slight_smile: Great I can change the statutes of bugzilla ticket to “confimed”