New iso 1115 available

After a load of work I think this iso will probably do the job. Calamares install should be fixed, kdenlive starts works and saves files but still crashes on exit but it does actually work. nVidia340 and 378 are available from the non–free repos.
Bero’s new kernel has fixed the too small window for calamares when run in VirtualBox. I am unable to build an i586 iso on abf so I will build one locally and put it up somewhere so I can be downloaded and tested.
Please let me know if there are any more issues.

Hi Colin,

about Calamares patch by upstream could be used too so it will work on all OS.

Hi Mandian
Yes I saw that they had done something. I guess we will push that in 3.03 which won’t be too long off.

1 Like

Thanks, I’ll test it soon.

I’ve pushed this patch. ISO rebuild is needed when fixed calamres will be ready.


I would have been more than happy to report that build 1115 fixed the calamares issue 2175, sadly it does not work for me.
Sorry, just reporting.

I still believe more testers’ feedback is needed.

Rugyada, Please describe exactly what happens as I cannot now reproduce the bug. If you can take pictures of the screen with your phone then so much the better. Try switching to another vritual console. What do you see? Can you login as root. Anything you can glean from your box will be helpful. How are you burning your mem stick.
If you are not using dd then try “sudo if=‘iso name’ of=/dev/sd? bs=4M”
Where dev/sd? is the device you see at the end when you run dmesg after you have plugged in your usb stick.
In order to fix this we need more info.

There isn’t much to say.
At the ISO menu

  • if I select Start OM in live mode: everything is ok. Plymouth ok, Plasma desktop ok, LXQt desktop ok. Everything works (apart the small graphical glitches)
  • if I select Install OM: plymouth ok iirc, then calamares appears for a short while and soon after disappears (without me doing anything). After a few seconds the system reboots by its own.

ATM I don’t remember if I tried to switch to VT. Will launch install another time and will see.

I have always written my USB pendrive by mean of ROSA Image Writer in my ROSA Desktop system.
It has always worked and still working.

ruru@ruru-pc ~ $ dmesg
[13269.272124] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[13269.517125] usb 3-1: New USB device found, idVendor=058f, idProduct=6387
[13269.517130] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13269.517133] usb 3-1: Product: Mass Storage
[13269.517135] usb 3-1: Manufacturer: Generic
[13269.517137] usb 3-1: SerialNumber: 6AFD11B0
[13269.578861] usb-storage 3-1:1.0: USB Mass Storage device detected
[13269.579044] scsi host8: usb-storage 3-1:1.0
[13269.579162] usbcore: registered new interface driver usb-storage
[13269.585400] usbcore: registered new interface driver uas
[13270.582445] scsi 8:0:0:0: Direct-Access     Generic  Flash Disk       8.00 PQ: 0 ANSI: 4
[13270.583398] sd 8:0:0:0: [sdc] 15597568 512-byte logical blocks: (7.99 GB/7.44 GiB)
[13270.584120] sd 8:0:0:0: [sdc] Write Protect is off
[13270.584126] sd 8:0:0:0: [sdc] Mode Sense: 23 00 00 00
[13270.584821] sd 8:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[13270.601842]  sdc: sdc1 sdc2
[13270.604004] sd 8:0:0:0: [sdc] Attached SCSI removable disk
ruru@ruru-pc ~ $

Switching to VT while/after Calamares disappears, I read these 2 lines:

calamares-install-start [some numbers I did not have the time to copy] AIGLX - Suspending AIGLX clients for VT switch

watchdog - watchdog did not stop

I cannot login nor do anything.
System reboots.

Maybe it’s just my own problem, for some unknown reasons.
That’s why it cannot be a blocker or such for everybody, unless more folks confirm that’s happening also to them.

Thanks Cristina,
It’s a clue; I have not seen that message before. That message does not come fron the startup scripts so now the issue seems to be Clamares itself.
There will be another iso soon as I made an error in the systemd service file for calmares on this one. I don’t think it would have made any difference to your problem since it seems to work reliably on other hardware.

It would be useful to know when it started to happen. Since when ‘Install’ menu stopped to work.
Anyone kept trace of it?
@ben79 @christopher_tanner ?

While fixing the latest bits, ISO 1115 would be perfect for a 3.02 Beta release.