New installation not booting

Tags: #<Tag:0x00007f37329572f0>

Hello,

  • OpenMandriva Lx version:
    OM 4

  • Desktop environment (KDE, LXQT…):
    KDE

  • Description of the issue (screenshots if relevant):
    I wiped my disk, used GPartEd to create Swap and Primary partitions, installed OM4 to the Primary partition. Installation went smoothly. Rebooted. No Grub menu, no boot.

  • Relevant informations (hardware involved, software version, logs or output…):
    Lenovo IdeaPas 110acl-80tj

I am presently using SuperBoot2 on a CD to boot. I haven’t yet figured out how to get it to WRITE boot, but I can boot to the OM4 installation. More help is needed.

More information is needed. Is system multi-boot? We need to know if system is UEFI boot or Legacy (MBR) boot? Does your system have multiple storage drives? What partition table is in use by storage drives gpt or mbr? Post here the entire files:

  1. /var/log/calamares-installation.log
  2. /boot/grub2/grub.cfg
  3. In Konsole run command:
    sudo fdisk -l > fdisk.txt (That is -l for list not the number 1.)
    and post the created file ‘fdisk.txt’ here.
1 Like

$ sudo grub2-install /dev/sdX

Where /dev/sdX is the location of the drive you want to boot from like /dev/sda or /dev/nvme0n1.

I know I’m a multibooter by habit, but this system is now single-boot.

I have just run the command you gave me for writing Grub2. I am going to reboot and hope it works. I’ll let you know.

System is Legacy boot. Single boot. I just tried writing Grub2 as suggested, it changed something but did not write boot correctly.

I have used this machine with a lot of distros. I never have a problem with Mint or other Ubuntu- or Debian-based distros, and had no trouble with Sabayon, but it has been a bear to work with using anything Arch, Mandriva, or Suse based.

I did have an issue on this machine a week ago. I was writing a distro to it on battery power and the battery died as I was scrambling for the power supply. I had to completely restructure the disk, using GPartEd, and I set it with sda1 being a small swap disk and sda2 being the rest of the disk, formatted ext4. This was the first distro I succeeded in installing since then.

The machine is a Lenovo IdeaPad 110acl-80tj, with an AMD 6 chip for processor and some kind of AMD graphics. 500 Gb hard drive, 4 Gb RAM. Rather low spec. I’m trying to save up for another machine.

I can’t be specific about actual cause of any problem without more information especially the /boot/grub2/grub.cfg file. Also the output of grub2-install command can tell us something if there is an error. Edit: Either command will tell us something if there is any error.

But maybe I know enough to try to help again. How grub2 works is pretty much the same regardless of distro. This command will write the file /boot/grub2/grub.cfg:

  1. This is probably familiar:

    $ sudo update-grub2

  2. Next we need to write that file to MBR (Legacy boot) and we know you have the one drive so most likely it is /dev/sda:

    $ sudo grub2-install /dev/sda

So possibly running those two commands in that order will straighten things out.

This post is general information about partitioning in Calamares installer for all users.

Just a tip if helpful to you or any user. You can do something like this in Calamares installer by selecting Partitioning>Erase Disk>Swap No Hibernate like this:

I used 50GB disk as example and it made a 45GB / and 5 GB swap. But this uses an algorithm to set swap size. I use this all the time with VBox systems of 15GB and that nets 13.2GB / (there is a .3GB /boot/efi for EFI boot) and 1.5GB swap.

You can use Manual Partitioning to set / and a /home if desired and whatever swap size you want.

Note: The box at the bottom for “boot loader location” normally for MBR booting you want the first in the list “Master Boot Record” or “MBR” as we call it. MBR booting is also known as Legacy boot. This is the default if user does not select anything here.

check with

sudo parted -l
  1. if MBR option boot should appears
    sudo grub2-install /dev/sda is ok

  2. if GPT option boot,esp should appears ( unless you forget to add this option on mountpoints intall),
    also required to do chroot to get GOOD /boot/efi from disk , Not form USB install
    < missing chroot >
    grub2-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=openmandriva --recheck --verbose

check also if EFI boot entry is present

sudo efibootmgr

I wound up using a method you would probably not recommend. I installed Linux Mint as a dual boot. Worked like a charm. Got both boots, and used Grub Customizer to put OM4 first in the boot sequence.

I may not have tried everything suggested first. But at the time, I was impatient, not all the suggestions had come in yet. I did try to write grub2 to sda, and it didn’t work.

In this thread we have a user asking for help but there is not anything anywhere that anyone could work on. You don’t give us any way to help you. How many times do we need to tell people we can’t fix “it’s broken”. We need something we can work on. And if there is a legitimate issue we have no way to correct it for other users.

What exactly did not work? How do you know that? Why won’t you post output or screenshots of commands that fail? How can we fix anything? This is very, extremely frustrating to people trying to help.

And apologies for letting my frustration get the best of me in this moment.

see my previous message
reboot on USB openmandriva stick
open a terminal an returns info

sudo parted -l
sudo efibootmgr
inxi -Fxxxza

I know I tyed the commands offered to write grub2. I know that I still did not have a boot sequence at startup. So I know I fixed it with another distro. I’m sorry that I didn’t wait for everyone to weigh in on the subject, but the idea is to GET MY SYSTEM WORKING.

@zaivala So your problem is solved. Great.
We can close this topic.