Network Printer Canon MG5753 don't work after upgrade from 4.2 to 4.3

Hello, My network printer Canon MG5753 don’t work after upgrade from 4.2 to 4.3 the system seems like find the printer

but when i try to print the printer says 'unable to locate printer"
I have follow all the steps from here OMA Wiki | OpenMandriva wiki and here How to configure printer in OMLx without any luck, any one can help?

  • _OpenMandriva Lx version:_omlx-4.3

  • Desktop environment (KDE, LXQT…): KDE

  • _Description of the issue (screenshots if relevant):_Printer problem

  • _Relevant informations (hardware involved, software version, logs or output…):_Operating System: OpenMandriva Lx 4.3
    KDE Plasma Version: 5.23.5
    KDE Frameworks Version: 5.90.0
    Qt Version: 5.15.3
    Kernel Version: 5.16.13-desktop-1omv4003 (64-bit)
    Graphics Platform: X11
    Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
    Memory: 7.7 GiB of RAM
    Graphics Processor: Mesa Intel® UHD Graphics 620

Some things to check.

  1. Be sure cups.service is running.

    $ systemctl status cups.service

    If cups is not started try to start it with this command:

    $ systemctl start cups.service

  2. Try some of the other drivers like:

  1. If you do not find anything that helps file a bug report here.

Hey ben79, thanks for the quick reply unfortunately my issue is still here, the cups service is running and i have tested all the available drivers for my printer without any luck… A last question, what must i post on the bug report?

Hi @thanasis_65 have you already tried to remove the printer after the upgrade then reinstall it?

Hi mandian, yes i have did it many times, every time who i tested a driver i removed first the printer and add it again. I also tested it with the usb cable and works fine using all the available drivers but when i try to use the network interface seems like it send the test print page until 23%
and then i get that message
here is the output of the systemctl status cups.service
● cups.service - CUPS Scheduler
Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2022-05-01 13:12:01 EEST; 9h ago
TriggeredBy: ● cups.socket
● cups.path
Docs: man:cupsd(8)
Main PID: 906 (cupsd)
Status: “Scheduler is running…”
Tasks: 2 (limit: 9308)
Memory: 133.2M
CGroup: /system.slice/cups.service
├─ 906 /usr/sbin/cupsd -l
└─7900 /usr/lib/cups/notifier/dbus dbus:// “”

I have a HP Photosmart 6520 printer. To set it up wifi I had to select the ‘AppSocket/>something<’ and manually enter the URL on my printer.

I think some printers would need something else in that 'Other Network Printers" list like IPP, IPPS, or HTTPS and manually enter the url of the wifi printer.

Hello again, finally i resolved my issue, i started to configure my printer not of the System Settings but from menu Settings > Printing Settings, clicked on the field ‘find network printer’ and in the right part of the window i entered the IP of my printer

when i clicked on the find button on the right part it brought me 88 results !

Then on the right part i clicked the button detection, and then the Forward, on the next step i chose the driver and that’s it.
I used this process in the past every time who i updated my system, or i did a fresh install, but on all previous releases when I was putting the ip of my printer it brought me only one choice, never never 88!
After i upgraded my system and goes to start setup my printer, i tried this way but when i saw the 88 results i don’t knew who one to choice, and I decided to setup the printer via System settings without any luck… After ben79’s advice i decided to try again and i solved my issue.

1 Like