Mythtv on OpenMandrivalx 4.1

Tags: #<Tag:0x00007ff27dc90af0>

Hello,
Thanks to all for their support in my boot issues, now I’ve had a bit of a look around OM I am starting to get to grips with the wrinkles of dnf.

I have done a few searches and it doesn’t look as though anyone is using OM for their HTPC using Mythtv. In fact mythtv brings no response from this forum’s search.

If anyone has any experience with Mythtv on OM I would be grateful for their ideas on the best way of installing before I jump in and start compiling mythtv from scratch.

I confess to really missing the ease and versatility of the apt-get command in kubuntu…

Here is my system specs: lshwgb.txt (24.5 KB)

Cheers, Tony.

Mythtv is not in OM repositories currently. FWIW a search for mythtv in Rolling would look like this:

$ dnf search myth
OpenMandriva Rolling - x86_64                                                                                                                                503 kB/s |  12 MB     00:24    
OpenMandriva Rolling - Unsupported - x86_64                                                                                                                  1.2 MB/s | 5.2 MB     00:04    
OpenMandriva Rolling - Restricted - x86_64                                                                                                                   5.7 kB/s |  97 kB     00:17    
OpenMandriva Rolling - Non-free - x86_64                                                                                                                      27 kB/s |  38 kB     00:01    
=============================================================================== Name & Summary Matched: myth ================================================================================
lib64cppmyth1.x86_64 : cppmyth library
lib64mythes1.2_0.x86_64 : Libraries for mythes
lib64cppmyth-devel.x86_64 : Development files for cppmyth
lib64mythes-devel.x86_64 : Files for developing with mythes
perl-Net-DAAP-Server-MythTV.noarch : Publish MythTV videos to DAAP clients like Apple's Front Row

If you have problems compiling this you will most likely get faster answers talking directly to developers on IRC (Freenode) @ #openmandriva or #openmandriva-cooker. #openmandriva-cooker is where devs work and communicate but people do post there for help with really technical issues like this.

Thank you Ben for your ideas, I’ll give it a shot compiling Myth then when I get into difficulties I’ll yell for more help from the devs.

Another thing I find rather strange is the lack of some KDE staples. I have used Kaffeine for many years for testing DVB cards, it seems that although it is a KDE application, it is not in the repos. What is the standard dvb application people use in OM? I can use VLC but it is a real pain to use with DVB cards, you need to know the exact frequencies of each channel, their bandwidth spacing and other parameters. Kaffeine just does it’s own scans and the channels are all populated, it is really simple to use.

Thanks again, Tony.

Why do people keep telling us we don’t have packages in our repos when they are there?

Maybe because they are not. You have obviously enabled repositories that are not standard.

Can you tell me which ones to enable please? EDIT: Just enabled all x64 repos and it is there. Cheers.

Thanks again Tony.

@barfly Release Plan and Repositories are explained here. You can change them with this tool:

Generally for a Rock system with everything enabled would look like this in Konsole:

$ dnf repolist
repo id                                                                              repo name
rock-updates-x86_64                                                                  OpenMandriva Rock - x86_64 - Updates
rock-updates-x86_64-non-free                                                         OpenMandriva Rock - Non-free - x86_64 - Updates
rock-updates-x86_64-restricted                                                       OpenMandriva Rock - Restricted - x86_64 - Updates
rock-updates-x86_64-unsupported                                                      OpenMandriva Rock - Unsupported - x86_64 - Updates
rock-x86_64                                                                          OpenMandriva Rock - x86_64
rock-x86_64-non-free                                                                 OpenMandriva Rock - Non-free - x86_64
rock-x86_64-restricted                                                               OpenMandriva Rock - Restricted - x86_64
rock-x86_64-unsupported                                                              OpenMandriva Rock - Unsupported - x86_64

Note: Packages in Restricted repository may be illegal in some countries. This is not a joke in those countries.
Packages in Non-free are closed source so if there is a problem with the code we can not fix them. This includes things like nVidia proprietary drivers, ect. Legally we can not ever read the code in these.

Thanks Ben, totally different way of doing things from my fading memories of my Mandrake days.
It looks as though I will have to attempt a compile of Mythtv from source. Are all the things necessary for a proper build environment already in the OM builds as in Ubuntu? Stuff like build-essential, csh, tcsh, gcc qt environment and linux headers?

Or will I have to go back to installing all that stuff manually again?

There are some really old dead links from 2007 ish which have guides for installing Mythtv on Mandrake/Mandriva but nothing more recent than 2010. All the info on the Mythtv wiki sites and Mythtv forums is also way out of date with all dead and 404 links.
It looks like I am a pioneer here, very uncomfortable with that prospect as my programming skills were honed on DBase3 and Fortran in the early 1980’s. I did go back to uni in 1998 for 3 years full-time study when I was 50. Managed a diploma in networking and system administration one of 12 out of an enrollment of 125.

Cheers Tony

Post edited after more research.

I do know all the packages needed to do that exist in repositories. Remember OM is a RPM distro not deb so some things will be different. Also Github is the “Official Repository” of MythTV and OpenMandriva uses Github.

Post-edit: I just found some activity in Github and ABF. So the bits are in our build system already it is just a question of getting the packages to build.

Thank Ben, I shall regard this as a long-term project and will document the stages as best I can so others can benefit too. It looks to be a long-haul effort so I will treat it as such and work on it on the rainy days throughout the Spring. Github here I come!

Thanks for your time and patience. Tony.

Mythtv updated to 31.0. You can try install it.

Package available in Cooker and Rolling/unsupported/testing repo.

Thanks AP will attempt it soon, plenty of time now! I’m still using 0.29 Mythtv it’s the most stable. Myth 3.0 has problems, not even seen 3.1 yet!

It looks as though I’ll have to junk my present system and install the cooker one as well.

Thanks, Tony.

I had another attempt at Mythtv on OM and have come unstuck (again).
These are my install notes:

blank microsd 16gb card with GPT not formatted.
burn with dd this command:

dd if=/media/data/os_isos/OpenMandrivaLx.4.0-plasma.x86_64.iso of=/dev/sdh1 bs=4M status=progress

install as per installer
change to rolling in “sources”
install kerebos devs
run dnf --force dist-sync # as root
reboot

Install kaffeine–see if tuner cards are working - ok

install git

go to mythtv install from sources page follow instructions for ansible see this website: Build from Source - MythTV Official Wiki.

Ansible clones ok but when I try to run it, it fails miserably, see file:ansible_attempt.txt

Tried without ansible, no result see file: mythtv_enviroment_attempt.txt

Tried cloning mythtv failed with this see file: mythtv_clone_attempt.txt

ansible_attempt.txt (123 Bytes) mythtv_clone_attempt.txt (522 Bytes) mythtv_enviroment_attempt.txt (11.7 KB)

Tried the Mythtv install from a cooker system, but it did not work.
There is no way to install a master backend as the files are just not there.
I will try to do from source with rolling version and report back.

edit I should have written this first!