Mounting XFS with execution rights


  • OpenMandriva Lx version: LX4 / Cooker

  • Desktop environment (KDE, LXQT…): Plasma

  • Description of the issue (screenshots if relevant):

My Steam library is on an XFS formatted hard drive. To get Steam to work I need to mount it with exec option set in /etc/fstab. With openSUSE this line always worked:

/dev/sdb1 /storage xfs defaults,user,exec 0 0

OM mounts the drive flawlessly as well but somehow it misses out the exec option:

[vinz@calvin ~]$ mount | grep sdb1
/dev/sdb1 on /storage type xfs (rw,nosuid,nodev,relatime,attr2,inode64,noquota,user)

System is up to day, Kernel version/release is 5.2.0-desktop-1omv4000.

Am I missing something? Or is this eventually even a bug?

Probably a bug.

Unless it is something that might work with kernel 5.1? But I doubt that is the case.

version kernel 5.2 is very new , you should stay on kernel 5.1

I found the solution. Or more to say: the real reason for Steam complaining about missing executable rights.

The respective folder was created with openSUSE and therefore had myusername:1000 set as owner and group. Running chmod -R <myusername:mygroupname> on that folder fixed it.

Maybe that’s helpful for someone else!

1 Like