Most recent development .iso build # 14378 - THIS ISN'T THE BETA RELEASE


This is my first attempt at doing something like this. Thought this would be helpful for testers until building of new .iso’s resumes. See more about that in post about TC meeting #57.

Here’s Dropbox link to most recent OM Lx 3 development .iso which is build # 14378:

Let me know if this does or doesn’t work.

Known issue: If I remember correctly this does have the grub2 error where it only creates a bootable entry for itself. If anyone installs it on dual/multi-boot hardware after installing they’ll need to update grub2 and grub2-efi and it will fix problems and other systems and/or Windows should again be bootable.

Edit 3/4/16: In file names removed beta and replaced with dev-rel
dev-rel=development release
Reason: This is not a Beta release.


Links for md5sum and sha1sum:

Tested myself. Downloaded from Dropbox links to my /home/ben79/Downloads in OpenMandriva 2014 fully updated. I prefer to burn .iso’s in a stable system not in an Alpha or Beta system or Cooker. The times you get for any of this will be different and are very much hardware dependent.

[ben79@localhost ~]$ cd Downloads

[ben79@localhost Downloads]$ ls

iso download here took about 4 minutes. Checksum downloads are virtually instantaneous.

Checked checksums:

[ben79@localhost Downloads]$
md5sum -c OpenMandrivaLx.2015.0-dev-rel-PLASMA.x86_64.iso.md5sum
OpenMandrivaLx.2015.0-dev-rel-PLASMA.x86_64.iso: OK
[ben79@localhost Downloads]$ 
sha1sum -c OpenMandrivaLx.2015.0-dev-rel-PLASMA.x86_64.iso.sha1sum
OpenMandrivaLx.2015.0-dev-rel-PLASMA.x86_64.iso: OK

Burned to Memorex 16GB USB 3.0 Flash drive using ‘dd’ command:

[ben79@localhost Downloads]$ 
sudo dd if=OpenMandrivaLx.2015.0-dev-rel-PLASMA.x86_64.iso of=/dev/sdd bs=4M
[sudo] password for ben79: 
395+1 records in
395+1 records out
1659621376 bytes (1.7 GB) copied, 256.059 s, 6.5 MB/s

Where of=/dev/sd* is location of USB Flash drive. For a lot of people it will be /dev/sdb in my case it’s /dev/sdd. Burning Flash drive took about 4 1/2 minutes.

Then I boot it selecting the UEFI version to boot then select ‘Install OpenMandriva Lx’ and follow the steps to install. My install took about 4 1/2 minutes. Next reboot.
Here’s first problem. This is a Linux multi-boot machine and none of the previously existing systems have a bootable entry. So boot in to the newly installed system.
Open Konsole and run:

# remove-unused-packages

# urpme --auto-orphans

The 2 commands above are optional and I run them to remove unneeded software.

# urpmi --auto-update

The above will be using the repos that come with the default install which is the mirror list. In my case there are 63 packages to update. Among the packages updating are grub2-efi and grub2. During update one of them runs a script that updates /boot/grub2/grub.cfg and now the other previously existing systems will boot. That problem is SOLVED.

Enjoy. YMMV.

Note: Obviously in this example I’m not testing Live environment on .iso in fact I’m not even using it. In this example I’m testing an install to hardware only.

Edit 3/4/16: In file names removed beta and replaced with dev-rel.
Reason: This is not a Beta release.

Thank you Ben.

I’ve started my crusade (:stuck_out_tongue:) here some time ago

The topic has been brought to the attention of devs at TC meeting.
Unfortunately I had to miss the meeting this time, I was not there to push the request so it has not been discussed that much. More a reminder.

In my opinion it’s just a matter of common sense.
Also, it may avoid misinterpretation/misunderstanding (as actually happened)
You all are welcome to support it, if you agree :wink:

1 Like

Should have had presence of mind to change file names in beginning of this but didn’t.

So today changed the file names at Dropbox site and edited this thread accordingly.

Can hope that others pick up on this and follow through in kind.

Also credit for actually making the .iso goes to Tomasz Gajc aka TPG.
Thanks Tomasz for this and all your work.

1 Like

In such a case imho it might be useful also the build number (eg 14378) - meaning iso downloads from places out of where you can see it.
Just to everybody have a kind of reference.

At any rate, it has been a good improvement. Thank you Ben.

I concur your thanks to TPG and all our devs.

Yes we should in future put build ID # in file name. Perhaps that could be done instead of ‘dev-rel’? Or maybe like


Or something similar.

This should be topic in next TC meeting.

I’d say

or for better reading

I’d avoid whatever definition (alpha/beta/etc.) at all in development releases filename.
People do know that are dev-rel and in which development stage we are :wink: