Mises à jour cycliques suites aux dépendances


#1

via "urpmi --auto-update

warning: BOUCLE:
warning: e nlever lib64fm4-1.2.4-1.x86_64 "Requires: lib64fm4 = 1.2.4-1:2015.0" à partir des relations tsort.
warning: not removing lib64fm-extra4-1.2.4-1.x86_64 "Requires(auto): libfm-extra.so.4()(64bit)" from tsort relations.
warning: e nlever menu-cache-1.0.1-6.x86_64 "Requires: menu-cache >= 1.0.1-6" à partir des relations tsort.
warning: not removing lib64menu-cache3-1.0.1-6.x86_64 "Requires(auto): libmenu-cache.so.3()(64bit)" from tsort relations.
warning: e nlever libfm-1.2.4-1.x86_64 "Requires: libfm = 1.2.4-1" à partir des relations tsort.
Préparation...                   ################################################################
L'installation a échoué :       fichier /usr/share/locale/pl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pl-3.0-1.noarch
        fichier /usr/share/locale/nb/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-warning: BOUCLE:
warning: e nlever lib64fm4-1.2.4-1.x86_64 "Requires: lib64fm4 = 1.2.4-1:2015.0" à partir des relations tsort.
warning: not removing lib64fm-extra4-1.2.4-1.x86_64 "Requires(auto): libfm-extra.so.4()(64bit)" from tsort relations.
warning: e nlever menu-cache-1.0.1-6.x86_64 "Requires: menu-cache >= 1.0.1-6" à partir des relations tsort.
warning: not removing lib64menu-cache3-1.0.1-6.x86_64 "Requires(auto): libmenu-cache.so.3()(64bit)" from tsort relations.
warning: e nlever libfm-1.2.4-1.x86_64 "Requires: libfm = 1.2.4-1" à partir des relations tsort.
Préparation...                   ################################################################
L'installation a échoué :       fichier /usr/share/locale/pl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pl-3.0-1.noarch
        fichier /usr/share/locale/nb/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nb-3.0-1.noarch
        fichier /usr/share/locale/ru/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-ru-3.0-1.noarch
        fichier /usr/share/locale/it/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-it-3.0-1.noarch
        fichier /usr/share/locale/fr/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-fr-3.0-1.noarch
        fichier /usr/share/locale/pt_BR/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pt_BR-3.0-1.noarch
        fichier /usr/share/locale/es/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-es-3.0-1.noarch
        fichier /usr/share/locale/de/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-de-3.0-1.noarch
        fichier /usr/share/locale/nl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nl-3.0-1.noarch
[root@localhost jjm]# 
l10n-nb-3.0-1.noarch
        fichier /usr/share/locale/ru/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-ru-3.0-1.noarch
        fichier /usr/share/locale/it/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-it-3.0-1.noarch
        fichier /usr/share/locale/fr/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-fr-3.0-1.noarch
        fichier /usr/share/locale/pt_BR/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pt_BR-3.0-1.noarch
        fichier /usr/share/locale/es/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-es-3.0-1.noarch
        fichier /usr/share/locale/de/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-de-3.0-1.noarch
        fichier /usr/share/locale/nl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nl-3.0-1.noarch
[root@localhost jjm]#

#2

Salut,
Et si tu procédais à une désinstallation de l’ancienne version avec ses bibliothèques puis à une installation de la nouvelle version ?


(Ben Bullard) #3

Pourriez-vous réessayer? L’un de nos développeurs, TPG, a déclaré cela comme étant fixe. Et s’il vous plaît laissez-nous savoir les résultats.


#4

Merci.
Avec plaisir.

Premier essai

warning: not removing lib64menu-cache3-1.0.1-6.x86_64 "Requires(auto): libmenu-cache.so.3()(64bit)" from tsort relations.
warning: not removing lib64fm-gtk4-1.2.4-1.x86_64 "Requires(auto): libfm-gtk.so.4()(64bit)" from tsort relations.
warning: BOUCLE:
warning: e nlever kpackage-5.29.0-1.x86_64 "Requires: kpackage = 5.29.0-1:2015.0" à partir des relations tsort.
warning: e nlever lib64KF5Package5-5.29.0-1.x86_64 "Requires: lib64KF5Package5 = 5.29.0-1:2015.0" à partir des relations tsort.
Préparation...                   ################################################################
L'installation a échoué :       fichier /usr/share/locale/pl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pl-3.0-1.noarch
    fichier /usr/share/locale/nb/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nb-3.0-1.noarch
    fichier /usr/share/locale/ru/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-ru-3.0-1.noarch
    fichier /usr/share/locale/it/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-it-3.0-1.noarch
    fichier /usr/share/locale/fr/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-fr-3.0-1.noarch
    fichier /usr/share/locale/pt_BR/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pt_BR-3.0-1.noarch
    fichier /usr/share/locale/es/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-es-3.0-1.noarch
    fichier /usr/share/locale/de/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-de-3.0-1.noarch
    fichier /usr/share/locale/nl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nl-3.0-1.noarch
[root@localhost jjm]# 

Deuxième essai

warning: BOUCLE:
warning: e nlever libfm-1.2.4-1.x86_64 "Requires: libfm = 1.2.4-1" à partir des relations tsort.
warning: e nlever lib64fm4-1.2.4-1.x86_64 "Requires: lib64fm4 = 1.2.4-1:2015.0" à partir des relations tsort.
warning: not removing lib64fm-extra4-1.2.4-1.x86_64 "Requires(auto): libfm-extra.so.4()(64bit)" from tsort relations.
warning: e nlever menu-cache-1.0.1-6.x86_64 "Requires: menu-cache >= 1.0.1-6" à partir des relations tsort.
warning: not removing lib64menu-cache3-1.0.1-6.x86_64 "Requires(auto): libmenu-cache.so.3()(64bit)" from tsort relations.
warning: not removing lib64fm-gtk4-1.2.4-1.x86_64 "Requires(auto): libfm-gtk.so.4()(64bit)" from tsort relations.
warning: BOUCLE:
warning: e nlever kpackage-5.29.0-1.x86_64 "Requires: kpackage = 5.29.0-1:2015.0" à partir des relations tsort.
warning: e nlever lib64KF5Package5-5.29.0-1.x86_64 "Requires: lib64KF5Package5 = 5.29.0-1:2015.0" à partir des relations tsort.
Préparation...                   ################################################################
L'installation a échoué :       fichier /usr/share/locale/pl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pl-3.0-1.noarch
        fichier /usr/share/locale/nb/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nb-3.0-1.noarch
        fichier /usr/share/locale/ru/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-ru-3.0-1.noarch
        fichier /usr/share/locale/it/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-it-3.0-1.noarch
        fichier /usr/share/locale/fr/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-fr-3.0-1.noarch
        fichier /usr/share/locale/pt_BR/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pt_BR-3.0-1.noarch
        fichier /usr/share/locale/es/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-es-3.0-1.noarch
        fichier /usr/share/locale/de/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-de-3.0-1.noarch
        fichier /usr/share/locale/nl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nl-3.0-1.noarch

    warning: BOUCLE:
warning: e nlever libfm-1.2.4-1.x86_64 "Requires: libfm = 1.2.4-1" à partir des relations tsort.
warning: e nlever lib64fm4-1.2.4-1.x86_64 "Requires: lib64fm4 = 1.2.4-1:2015.0" à partir des relations tsort.
warning: not removing lib64fm-extra4-1.2.4-1.x86_64 "Requires(auto): libfm-extra.so.4()(64bit)" from tsort relations.
warning: e nlever menu-cache-1.0.1-6.x86_64 "Requires: menu-cache >= 1.0.1-6" à partir des relations tsort.
warning: not removing lib64menu-cache3-1.0.1-6.x86_64 "Requires(auto): libmenu-cache.so.3()(64bit)" from tsort relations.
warning: not removing lib64fm-gtk4-1.2.4-1.x86_64 "Requires(auto): libfm-gtk.so.4()(64bit)" from tsort relations.
warning: BOUCLE:
warning: e nlever kpackage-5.29.0-1.x86_64 "Requires: kpackage = 5.29.0-1:2015.0" à partir des relations tsort.
warning: e nlever lib64KF5Package5-5.29.0-1.x86_64 "Requires: lib64KF5Package5 = 5.29.0-1:2015.0" à partir des relations tsort.
Préparation...                   ################################################################
L'installation a échoué :       fichier /usr/share/locale/pl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pl-3.0-1.noarch
        fichier /usr/share/locale/nb/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nb-3.0-1.noarch
        fichier /usr/share/locale/ru/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-ru-3.0-1.noarch
        fichier /usr/share/locale/it/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-it-3.0-1.noarch
        fichier /usr/share/locale/fr/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-fr-3.0-1.noarch
        fichier /usr/share/locale/pt_BR/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-pt_BR-3.0-1.noarch
        fichier /usr/share/locale/es/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-es-3.0-1.noarch
        fichier /usr/share/locale/de/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-de-3.0-1.noarch
        fichier /usr/share/locale/nl/LC_MESSAGES/krita.mo à partir de l'installation de krita-3.1.1-1.x86_64 est en conflit avec le fichier du package krita-l10n-nl-3.0-1.noarch

J’ai lu la réponse de jclvanier, mais je ne savais pas par où commencer.


Edit by rugyada
merci d’utilizer l’icone “code” svp.


#5

Tous les dépôts viennent d’être mis à jour via le CCM.
Le problème est toujours présent.


#6

Ce soir, vérification.
Premier essai avec 55 paquetages à installer.
Mais il a eu des désinstallations “x/83”.
A la fin, il reste 5 paquets à mettre à jour, mais c’est une boucle :slight_smile:

Pour satisfaire les dépendances, les paquetages suivants vont être installés :
 Paquetage                      Version      Révision      Dist  DEpoch Arch 
(média « main updates »)
 distro-plasma-config           0.6          0.6           omv   2015.0 noarch 
 kernel-firmware                20161225     1             omv   2015.0 noarch 
 krita                          3.1.1        1             omv   2015.0 x86_64 
 lib64xi6                       1.7.8        2             omv   2015.0 x86_64 
 openssh-askpass-common         7.4p1        2             omv   2015.0 x86_64 
un espace additionnel de 14Mo sera utilisé.
28Mo de paquets seront récupérés.
Procéder à l'installation des 5 paquetages ? (O/n)

rugyada,
Est-ce bien “< / >” le formatage Code.
Je l’utilise systématiquement ainsi que Citation sur plusieurs forums Linux.
Quelquefois, Citation est plus pratique car il permet de formater des caractères, gras par exemple.
Sur OMA, il est moins évident que sur d’autre forums où il s’affiche comme [Code] [:Code]
Je suis malvoyant.
Merci.


#7

Muni d’armes redoutables communiquées à moi par jcl :slight_smile:

rm -f /var/lib/rpm/_db*
rpm --rebuilddb 

Ensuite :slight_smile:

urpmi --auto-update

Mais avant de procéder à la reconstruction de la base rpm, j’ai essayé la mise à jour, et voici le résultat après 227 mises à jour(Hier das Erebnis ist) :slight_smile:

[root@localhost jjm]# urpmi --auto-update
le média « main » est à jour
le média « main updates » est à jour
le média « Main32 » est à jour
le média « Main32 Updates » est à jour
le média « contrib » est à jour
le média « contrib updates » est à jour
le média « contrib32 » est à jour
le média « contrib32 updates » est à jour
le média « non-free » est à jour
le média « non-free updates » est à jour
le média « Non-free32 » est à jour
le média « Non-free32 Updates » est à jour
le média « restricted » est à jour
le média « restricted updates » est à jour
Les paquetages sont à jour

Cela m’est vraiment agréable, car je ne me sentais PAS prêt à suivre la proposition de rugyada avec sa nouvelle image ISO!


#8

Frais… C’est vrai qu’on ne pense pas systématiquement à la reconstruction de la base de données.


#9

Là il n’a pas été nécessaire de reconstruire la base rpm. Ce soir aucune màj disponible.
Cela veut dire que les devs ont bien organisé les câbles, car ils devaient en avoir assez de se mélanger les pinceaux et de s’emmèler dans toute cette filasse.
Bravo et merci.


#10

Je viens d’arriver sur openmandriva, installation en dur. Est ce que pour les mises à jours , les depots 32 bits sont activés?


#11

Configuration des depots 32 bits et 64 bits en meme temps, pourquoi?
Waiting … Script adding 32bit repositories will support 64bit arch
Repositories 32 bits in 64bit arch successfully added

Je ne comprends la nature de ces deux messages.

Installation de firefox-fr, demande l’installation des autre langues, pourquoi?

Afin de poursuivre la mise à jour, le paquetage suivant doit être désinstallé :
lib64kpmcore3-2.2.1-1-omv2015.0.x86_64
(car kpmcore == 2.2.1-1:2015.0 est non satisfait)

Quand je valide par oui, il m’insulte avec plein d’injures du genre lib64…
Sorry, the following packages cannot be selected:

  • lib64qgsttools_p1-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimedia5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimediaquick_p5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimediawidgets5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • qt5-qtmultimedia-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)

Je suis obligé de faire Ok.

Quand je veux sélectionner tous les paquetages, il m’insulte encore.

Pour satisfaire les dépendances, le ou les paquetages suivants doivent aussi être installés :

  • firefox-nb_NO-51.0-1-omv2015.0.noarch
  • firefox-nn_NO-51.0-1-omv2015.0.noarch

Un espace additionnel de 111Mo sera utilisé.
Je valide par Ok, et de nouveau :
Sorry, the following packages cannot be selected:

  • lib64qgsttools_p1-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimedia5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimediaquick_p5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • lib64qt5multimediawidgets5-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)
  • qt5-qtmultimedia-5.8.0-2-omv2015.0.x86_64 (car libQt5Core.so.5(Qt_5.8)(64bit) est non satisfait)

Je valide par Ok.

Donc j’ai fait un urpmi --auto-select

Il m’a désinstallé plein de choses et installé plein de choses.
J’ai patienté …

J’ai un bug d’affichage dans la konsole, il y a un espace assez conséquent entre le curseur et l’invite de commande.

Ah, aussi la petite musique de bienvenue qui grésille au démarrage. Le bureau ne s’affiche pas. Je reste coincé sur l’écran de connexion. CTRL Atl F1 F2 pour remédier au problème.

C’est chaud patates.


(rugyada) #12

Certains programmes, par example wine, ont besoin de certains paquets 32bit.

Installation de firefox-fr, demande l’installation des autre langues, pourquoi?

Peut-être qu’il veut mettre à jour les autres langues aussi.
Si vous avez besoin du Français seulement:

# remove-unused-packages

(seulement “Unused localization” - Localisation inutilisée ? - coché)

PS> Il serait préférable de commencer une nouvelle discussion, parce que celui-ci a déjà été marquée comme résolue :wink:


#13

Merci pour la réponse.