Mise à l'heure par NTP sous lx 3


(ujl@orange.fr) #1

Bonjour,
J’ai remarqué que la mise à l’heure ne se faisait pas correctement via NTP alors que lorsque je teste d’autre distri sous virtualbox l’heure est correcte ???


(Raphaël) #2

Tu as un décalage d’une heure ou une heure complètement aléatoire?


(Ben Bullard) #3

Peut-être que cela aide.
Maybe this helps.

https://forum.openmandriva.org/t/how-to-correct-most-common-cause-of-incorrect-time-in-dual-boot-w-windows-systems/2037/4

Pourriez-vous mettre en vente sur:
Could you post out put of:

$ timedatectl

Post-edit:
Indiquez-nous également le fuseau horaire que vous souhaitez utiliser et indiquez si l’ordinateur est sous Linux uniquement ou à double démarrage avec Windows ou autre.
Also tell us which time zone you wish to use and whether computer is Linux only or Dual Boot with Windows or other.
:monkey:


(Ben Bullard) #4

Juste pour deviner, vous voudrez peut-être ce fuseau horaire:
Just on a guess you may want this time zone:

$ timedatectl set-timezone Europe/Paris


(ujl@orange.fr) #5

Non, je suis presque à l’heure, ça retarde régulièrement. si je remets à l’heure, quelques jours après il manque des secondes, quand j’ai posé cette question j’avais 2mn de retard. Si je lance virtualbox avec une distri quelconque, cette distri m’affiche la bonne heure ?


(ujl@orange.fr) #6

[jlu@linux ~]$ timedatectl
Local time: mer. 2019-01-23 08:09:46 CET
Universal time: mer. 2019-01-23 07:09:46 UTC
RTC time: mer. 2019-01-23 08:09:46
Time zone: Europe/Paris (CET, +0100)
System clock synchronized: no
systemd-timesyncd.service active: yes
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.


(Ben Bullard) #7

Vous devriez lire ceci et cela. Pourriez-vous mettre en vente sur:
You should read this and this. Could you post out put of:

$ systemctl status systemd-timesyncd.service

et:
and:

$ systemctl restart systemd-timesyncd.service


(ujl@orange.fr) #8
[jlu@linux ~]$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-01-23 11:06:07 CET; 7h ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 6462 (systemd-timesyn)
   Status: "Idle."
    Tasks: 2 (limit: 4915)
   Memory: 1.5M
   CGroup: /system.slice/systemd-timesyncd.service
           └─6462 /lib/systemd/systemd-timesyncd

La commande suivante ne fonctionne qu’en administrateur et ça donne ça :

 [root@linux jlu]# systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-01-23 18:46:12 CET; 1min 3s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 14821 (systemd-timesyn)
   Status: "Synchronized to time server 91.121.91.167:123 (0.openmandriva.pool.ntp.org)."
    Tasks: 2 (limit: 4915)
   Memory: 1.2M
   CGroup: /system.slice/systemd-timesyncd.service
           └─14821 /lib/systemd/systemd-timesyncd

janv. 23 18:46:12 linux.home systemd[1]: Starting Network Time Synchronization...
janv. 23 18:46:12 linux.home systemd[1]: Started Network Time Synchronization.
janv. 23 18:46:12 linux.home systemd-timesyncd[14821]: Synchronized to time server 91.121.91.167:123 (0.openmandriva.p>
lines 1-14/14 (END)

(Ben Bullard) #9

Je suis à court de suggestions. Si rien de tout cela ne vous aide ou si vous ne parvenez pas à comprendre les liens fournis, une aide professionnelle (développeur) est nécessaire.
I’m out of suggestions. If none of that helps or you can’t figure it out form the links provided then professional (developer) help is needed.


(ujl@orange.fr) #10

Merci de votre aide, je vais trouver la solution. A titre d’info je n’utilise pas windows et je n’ai pas de dual boot.


#11

Si tu n’as pas Windows alors suis le conseil de timedatectl:
timedatectl set-local-rtc 0
Après il reste la solution d’installer openntpd qui servira de serveur de temps secondaire.
Il est recommandé de modifier /etc/ntpd.conf ainsi:
servers fr.pool.ntp.org
Voir man ntpd.conf
On peut aussi choisir ou ajouter un serveur particulier proche.

Edit: ne pas oublier d’activer le service à l’aide du mcc ou avec la commande:
systemctl enable openntpd


(ujl@orange.fr) #12

Parfait, il semblerait que maintenant l’heure soit exacte.
Merci.