Mandragora chrashes when trying to launch it

  • OpenMandriva Lx version: 4:0

  • Desktop environment (KDE, LXQT…): KDE Default Plasma from clean install into physical PC

  • Description of the issue (screenshots if relevant): I get this error message in a popup and Mandragora closes
    g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)

I don’t know what is going on, in fact yesterday I noticed I the repository config from Mandragora in the options was different than the one you set in the New Config Panel, so I carefully read all the stuff Ben79 posted about it and chosed Rock, so I only set Rock repositories in both sections of the config (screenshots below, one can’t because of error)

I searched for the error message but lot of info in Ubuntu and honestly the problem didn’t seem to match with mine since they were trying to install something and I don’t, I simply can’t open it because insta crashes.

Also I can’t remmber getting an error and crash recently, I tried to install yesterday a 2gpaint or something like that and told me it wasn’t able to do it, but IIRC that happened few days ago as well and Mandragora continued to work, even yesterday it continued to work… and now I can’t open it. The Updater service is working tho, it even let me launch a Mandragora instance but then the error make Mandragora shut down

I didn’t install really much because… there is a lack of applications I am searchng for, I hope someone can give me advice on things to check or commands to gather useful information to fix this please.

  • Relevant informations (hardware involved, software version, logs or output…): > MOBO ASUS M5 A788L-M (USB3)

CPU AMD FX 6300 Vishera
RAM DDR3 x 8GB (2x4 GB)
VGA Integrated ATI Radeon™ HD 3000 GPU

In the meanwhile I’ve been testing and I get things like this…

[sogetsu@Mandriva-PC ~]$ sudo dnf check-update
advertencia:rpmdb: (null)
advertencia:rpmdb: (null)
advertencia:rpmdb: (null)
Violación de segmento
[sogetsu@Mandriva-PC ~]$ sudo dnf repolist
advertencia:rpmdb: (null)
advertencia:rpmdb: (null)
advertencia:rpmdb: (null)
Violación de segmento
[sogetsu@Mandriva-PC ~]$ 

Not really sure tho lol, but seems Mandragora has a problem for real, can’t even list he repos

Post-edit: This is for you first post your second one may be something different. Do this first and see if dnfdragora is working and we go from there.

Open SystemMonitor aka: KSysGuard and type dnf in quick search bar.

Your list may be different from mine as I’m not having any problem. Now right click on each line and select “Send Signal” and under that select “Kill”. Will probably require root password. You want to clear everything or “Kill” everything in that list. Then try again.

Explanation: Nothing harmful or dangerous being done. You are simply ending or “killing” any running or left over processes related to dnf.

I fund 3 process at the first time, killed them all and tried running Mandragora again…
Then I get the same error, and one process runs:


Then when I close the window the process finishes as well wit no other one running.

Then I don’t know. I do know dnfdragora and dnf are working in Rock at present just fine here. So something has happened on your computer.

The errors in your second post I’ve never seen before. See if this:

$ sudo LC_ALL=C rpm --rebuilddb

does anything. If there is any output post that here. Normally when it works there is no output.

Post-edit: Also post output of:

$ sudo LC_ALL=C dnf check-update

$ sudo LC_ALL=C dnf repolist

First command:
I could’t capture! I waited to run both and paste both but it got list in the list, BUT it was some sort of error like something didn’t exist.
After the second command which comes below I run it again and showed nothing so I am assuming it “worked” on whatever it should have to accomplish.

Second Command

Checked all repos it seems and I am kind of paranoid now since it is showing Rock, Rlling AND Cooker in the list, showed more than 1 thousand lines I think.

Third Command:

[sogetsu@Mandriva-PC ~]$ sudo LC_ALL=C dnf repolist
Last metadata expiration check: 0:08:56 ago on Wed Sep 18 23:33:21 2019.
repo id                                  repo name            status
cooker-x86_64                            OpenMandriva Cooker  15057
cooker-x86_64-non-free                   OpenMandriva Cooker     52
cooker-x86_64-restricted                 OpenMandriva Cooker     61
cooker-x86_64-source                     OpenMandriva Cooker   7104
release-updates-x86_64-non-free-source   OpenMandriva 4.0 - N     6
release-updates-x86_64-restricted-source OpenMandriva 4.0 - R     0
release-updates-x86_64-source            OpenMandriva 4.0 - x    57
release-x86_64-non-free-source           OpenMandriva 4.0 - N    95
release-x86_64-restricted-source         OpenMandriva 4.0 - R    27
release-x86_64-source                    OpenMandriva 4.0 - x  7322
rock-testing-x86_64                      OpenMandriva Rock -    551
rock-testing-x86_64-non-free             OpenMandriva Rock -      4
rock-testing-x86_64-restricted           OpenMandriva Rock -      0
rock-testing-x86_64-unsupported          OpenMandriva Rock -     40
rock-updates-x86_64                      OpenMandriva Rock -    479
rock-updates-x86_64-non-free             OpenMandriva Rock -     12
rock-updates-x86_64-restricted           OpenMandriva Rock -      0
rock-updates-x86_64-source               OpenMandriva Rock -     57
rock-updates-x86_64-unsupported          OpenMandriva Rock -     59
rock-x86_64                              OpenMandriva Rock -  15662
rock-x86_64-non-free                     OpenMandriva Rock -    155
rock-x86_64-restricted                   OpenMandriva Rock -    164
rock-x86_64-source                       OpenMandriva Rock -   7322
rock-x86_64-unsupported                  OpenMandriva Rock -  13281
rolling-x86_64                           OpenMandriva Rolling 15109
rolling-x86_64-non-free                  OpenMandriva Rolling    53
rolling-x86_64-non-free-source           OpenMandriva Rolling    99
rolling-x86_64-restricted                OpenMandriva Rolling    61
rolling-x86_64-restricted-source         OpenMandriva Rolling    27
rolling-x86_64-source                    OpenMandriva Rolling  7108
[sogetsu@Mandriva-PC ~]$ 

EDT: OMG Now Mandragora WORKS!! I am so happy, OMFG these days I invested more time with Mandriva than my whole month doing my own stuff at this point but I am glad it is now working, I hope nothing else happens, I basically let Windows behind until I need it again for something specific in the other PC.

Thanks a lot, cheers, and also super useful article the one you wrote about repos, I learned lot of things from there wich now I reading this give me a hunch and checked the Repos in Mandragora

I have marked basically lots of them, even when in the previous picture I showed of the Configuration it was set to Rock… is it something I could have done with those commands or other thing?

Now if I am not wrong, something is messed up with the repos, and if I got files from Rolling or Cooker I am done… I should reinstall from scratch since there is no way to go back and some files could have been updated since at this point I am not sure, one config shows me Rock and other shows me repos from almost everything.

'dnf repolist is supposed to show the enabled repositories. I don’t know why it would show all of those unless they are enabled.

I hope those are not all enabled. You only want one version and one version of OM Lx ONLY forever. The default and best choice for users especially new users is Rock.

So we need the output of:

$ sudo LC_ALL=C dnf check-update


$ sudo LC_ALL=C dnf upgrade

I have no idea what you have done.

The command:

$ sudo LC_ALL=C rpm --rebuilddb

should look like this if successful with no problems:

If there is any output then there is almost certainly something wrong. You need to get that output in a screen shot. Do one thing and finish it. Do this only and post the output.

On a healthy Rock system this is what ‘sudo LC_ALL=C dnf check-update’ should look like.

Notice the column at far right. This is telling you where the supposedly obsoleted packages come from and all come from Rock repos. You should always, always, always, see only one version of OM Lx in that list. If your system is Rock you should only see Rock in any list that lists things by repository.

So your results are telling you that you have a problem or problems with your system. And it is not a small problem.

Off Topic: That list of 9 packages that dnf is showing “Obsoleting Packages” is most likely an error or bug. The bug report is here. I know for a fact that Gwenview is not an obsolete package.

1 Like

Tried again, rebuild did fine, nothing to show, but the check-update gave me more than 1000 lines… so… time for a clean reinstall I think.

I remember now I tried at first using Discover, I saw it as suggestion somewhere, but then didn’t work and I read later it wasn’t working really well, so I forgot about it.
Maybe I screwed it up with Discover there on the repos checker, even tho they are shown as Rock in the other options as I posted at the beginning.

Any advice? I strongly think I should re-install, also I can no solve the previous problems if the appear again and I downloaded lot of stuff for customization testing and many of them doesn’t work, so I can re-install clean and download only the stuff I know that works and want installed in the OS.

Yes. Fresh install. I’m pleased and encouraged to see that you have presence of mind enough to realize that on your on.

Realize that OpenMandriva is not Windows or Ubuntu. In OpenMandriva there are some things that have to be done the OpenMandriva way. There are also things that are general to all Linux distributions. Wish our documentation were more complete. We are working on that and several other things as fast as dozen all volunteer/part time contributors can. There is more documentation type of “How To’s” here.

As far as the learning curve there most certainly was a learning curve for Windows and/or Ubuntu or whatever other OS anyone has used. You may not remember it or for some people you may have learned when you were very young but there was a learning curve.

Another great tool for finding answers to things is to copy and paste the exact error and use that as a search term for internet search. This may work better if the command output is in English. That is what LC_ALL=C option does.


14 posts were split to a new topic: General Discussion about state of OM Lx

dnfdragora is not crashing perhaps we can close this thread? We have determined beyond doubt that the problems were on OP’s system.

The off topic discussion, which I started so that’s on me, is worthwhile so perhaps we can continue it under a descriptive title so other people can find and take part in the discussion?


That’s a very good idea.

1 Like