Lutris refuses to start in 5.0 TP

Hello, I am sorry to bother you again so soon :see_no_evil:

  • OpenMandriva Lx version:

5.0 Technical Preview

  • Desktop environment (KDE, LXQT…):


  • Description of the issue (screenshots if relevant):

I have installed Lutris from the OM Welcome Window. The installation was successful but the program itself won’t run. I have also tried a reinstall through Dnfdrake with the same result.

  • Relevant informations (hardware involved, software version, logs or output…):

Starting through the terminal by using the lutris -d command gives this output:

$ lutris -d
Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3.11/site-packages/lutris/gui/", line 39, in <module>
    from import Game, export_game, import_game
  File "/usr/lib/python3.11/site-packages/lutris/", line 24, in <module>
    from lutris.runners import InvalidRunner, import_runner, wine
  File "/usr/lib/python3.11/site-packages/lutris/runners/", line 9, in <module>
    from import (  # noqa: F401 pylint: disable=unused-import
  File "/usr/lib/python3.11/site-packages/lutris/runners/commands/", line 16, in <module>
    from import WinePrefixManager
  File "/usr/lib/python3.11/site-packages/lutris/util/wine/", line 4, in <module>
    from lutris.util import joypad, system
  File "/usr/lib/python3.11/site-packages/lutris/util/", line 10, in <module>
    import evdev
  File "/usr/lib64/python3.11/site-packages/evdev/", line 5, in <module>
    from evdev.device import DeviceInfo, InputDevice, AbsInfo, EvdevError
  File "/usr/lib64/python3.11/site-packages/evdev/", line 12, in <module>
    from evdev.eventio_async import EventIO, EvdevError
  File "/usr/lib64/python3.11/site-packages/evdev/", line 63, in <module>
    class ReadIterator(object):
  File "/usr/lib64/python3.11/site-packages/evdev/", line 88, in ReadIterator
AttributeError: module 'asyncio' has no attribute 'coroutine'. Did you mean: 'coroutines'?

I am not sure how or if I could fix this by myself. Thank you in advance for any help. :slight_smile:

@Talera Hello,

I can confirm

No sorry. Feedbacks help :wink:
Thank you

Attached lutris installation log
install-lutris.txt (22,0 KB)

1 Like

This problem occurred after updating python to 3.11.
The culprit here is python-evdev. As of version 1.6.0, the problem has been fixed. I also reported the problem to lutris upstream and they fixed the problem in the master version in case when someone pair the lutris with evdev lower than 1.6.0.

Try to update the system and check again. It should be working by now.
Make sure the update has downloaded lutris- and python-evdev-1.6.0-1.

1 Like

@Talera works for me

Yes, thank you both :slight_smile: