Libreoffice-java impossible to install

Tags: #<Tag:0x00007fc0bb2a48f0>

Hello,

  • _OpenMandriva Lx version:_LX 4.0

  • _Desktop environment (KDE, LXQT…):_KDE, LXQT

$ sudo dnf --refresh install libreoffice-java
google-earth-pro                                                                              17 kB/s | 1.3 kB     00:00    
OpenMandriva Rock - x86_64                                                                   7.4 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - x86_64 - Updates                                                         8.0 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Unsupported - x86_64                                                     8.2 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Unsupported - x86_64 - Updates                                           7.9 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Restricted - x86_64                                                      9.3 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Restricted - x86_64 - Updates                                            8.0 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Non-free - x86_64                                                        7.1 kB/s | 1.5 kB     00:00    
OpenMandriva Rock - Non-free - x86_64 - Updates                                              9.6 kB/s | 1.5 kB     00:00    
Fehler: 
 Problem: package libreoffice-java-6.2.4-2.x86_64 requires pentaho-reporting-flow-engine, but none of the providers can be installed
  - package pentaho-reporting-flow-engine-1:0.9.4-8.3.noarch requires liblayout >= 0.2.10, but none of the providers can be installed
  - conflicting requests
  - nothing provides xml-commons-apis needed by liblayout-0.2.10-8.0.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

When are the missing packages available?

with regards
Ch. Hanisch

Hello,
the trial to install ‘libreoffice-java’ from Cooker with
$ sudo dnf install libreoffice-java --enablerepo=cooker-x86_64
has installed the whole LibreOffice 6.3 on my Rock-System.
Extensions LanguageTool-4.6.oxt and dict-de_DE-frami_2017-01-12.oxt works now fine.

It’s Ok?

with regards
Ch. Hanisch