LibreOffice can't find Java-JRE

My LibreOffice can’t find the Java-JRE.

$ java -version
openjdk version "11.0.1" 2018-10-16
OpenJDK Runtime Environment 18.9 (build 11.0.1+13)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.1+13, mixed mode, sharing)

$ libreoffice --version
LibreOffice 10(Build:3)

What can I do?

with regards
Ch. Hanisch

This is what I have in a Lx 4.2 VBox VM:

$ java -version
openjdk version "15-internal" 2020-09-15
OpenJDK Runtime Environment OpenMandriva-15.0.0-1 (build 15-internal+0-adhoc.mockbuild.openjdk)
OpenJDK 64-Bit Server VM OpenMandriva-15.0.0-1 (build 15-internal+0-adhoc.mockbuild.openjdk, mixed mode, sharing)

This is the package installed:

$ rpm -qa | grep java

So perhaps try removing java 11 and installing the java-15-openjdk package.

For libre-office there is a package libreoffice-java that is not installed by default. I am not sure what this package is for.

I have the following and see no warnings about java:

$ libreoffice --version
LibreOffice 10(Build:3)
$ rpm -qa | grep libreoffice

Ah, about libreoffice-java: Java dependent parts of LibreOffice. This package contains templates and other optional parts of LibreOffice that require a Java stack (such as OpenJDK) to be installed.

I suspect for LibreOffice 10 in OM Lx 4.2 you will need for java-15-openjdk to be installed.


Yes, it is Ok.
But now I have a problem with LibreOffice.
I have no Libreoffice-Writer and so on.
I trying to install libreoffice-writer and so on:
['\n Problem 1: package libreoffice-7.1.0-5.x86_64 requires libreoffice-calc = 7.1.0-5, but none of the providers can be installed\n - cannot install both libreoffice-calc-7.1.0-5.x86_64 and libreoffice-calc-7.1.0-3.x86_64\n - conflicting requests\n Problem 2: package libreoffice-writer-7.1.0-3.x86_64 requires libreoffice-common = 7.1.0-3, but none of the providers can be installed\n - cannot install both libreoffice-common-7.1.0-5.x86_64 and libreoffice-common-7.1.0-3.x86_64\n - package libreoffice-math-7.1.0-5.x86_64 requires libreoffice-common = 7.1.0-5, but none of the providers can be installed\n - conflicting requests']

What can I do?

I have solved the problem, but now I have a problem with LanguageTool 5.3
The spell verification don’t work.
What is the reason for that?

Only the LanguageTool 4.8 works well.

with regards
Ch. Hanisch

I don’t see any OpenMandriva package by that name. Is this is 3rd party software?