Konsole request for sudo password fails


Rome v. 24.01
KDE Plasma v. 5.27.9

Performed a fresh install of Rome from a previously successfully used many times USB thumb drive, completed normally.
Very first action was to open Falcon to the OM Rome release notes page, copy & paste:
sudo dnf clean all ; sudo dnf --allowerasing distro-sync
into konsole and perform system upgrade, which completed.

Next step was to copy & paste:
sudo dnf --refresh install firefox
into konsole.

Problem occurs:
konsole then wants my [sudo] password, but when I tried entering the same password I successfully entered to run the upgrade, no matter which keys I press, there is no character output to konsole screen (for security reasons), and after 3 attempts, it closes.

After that point, whichever I keys I enter to the command line appear as usual, but as soon as I attempt to run any command that requires my password, the problem repeats until 3 failed attempts… after closing, the keyboard entries then again appear as usual… as long as konsole isn’t requesting my password.

I then re-installed the same OS from scratch using the same USB drive, again erasing and re-writing the partition, with same result.

I have installed and upgraded this same software version from the same usb stick on this same machine multiple times and have never encountered this problem before.

Has anyone else encountered this?
Any ideas?

A solution would be great!


Any change if you run commands as root?

$ su

# dnf --refresh install firefox

  1. Users in wheel group have sudo permissions. To find out simply type as user groups user_name where you replace user_name with your actual user name. For example:
$ groups ben79
ben79 : ben79 lp wheel audio video users lpadmin network storage sambashare

For this issue you want to see wheel. If you are not in wheel group I think this is the command to add you to that group (do this as root):

# usermod -a -G wheel user_name

If you do not have root permissions that would be a another issue but fixable.

Note: The groups listed there should be added to first user created when you install any version of OMLx. I try to remember to add those to other users I create unless I do not want them to have sudo privilages. Then I add all but wheel.

  1. There is a file called sudoers you can open as root. We usually do this with the command visudo. This means you are using vim so you need to know a little about vim commands. The sudoers file tells the system what users have sudo privilages. The sudoers file does not need to be edited normally. You just add user to wheel group if you the admin want that user to have sudo privilages. (If you run visudo to close it type :q and hit enter key.)

That file in OMLx has:

## Allow root to run any commands anywhere
root    ALL=(ALL)       ALL


## Allows people in group wheel to run all commands
%wheel  ALL=(ALL)       ALL

I hope this is helpful, useful, and educational. I am feeling ambitious at the moment. :slightly_smiling_face:

su password authentication failure after update, so I can’t run as root.
(worked prior to update.)

I am the only user, created at installation, and am listed in the wheel group per the groups command shown above.
Now I cannot access the su or sudo command due to password authentication errors.

Internet search for how to replace a lost root password. This is easy to do. But to do this you need to get in to the broken system with root privilages which this article explains.

If that does not work you will need to be more specific about:

I had noticed some red warning comments scrolling past during the update, but afterward I could not scroll far enough back on the screen to see them, so I attempted to access them via KSystemLog, but this requires root access, and my root password entry also fails authentication.

Now also fails PolicyKit1 KDE Agent password authentication to mount drive.

Is it possible that you got this question/s at the end of upgrade process?

I did receive two (2) quesions similar to this, and chose to install the newer included version.
I will reinstall and choose keep current version of the files you listed.
Thank you.

See also the hints for GRUB and dnf.conf
You may want to watch that topic as we publish instructions and workarounds for ROME system upgrades :wink:

I reinstalled & updated, answered Y to /etc/default/grub, and N to /etc/shadow, and that resolved the problem.
Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.