Kio-mtp not working

Hello,

OMV LX 3.03

KDE 5

I’ve installed kio-mtp to access cell phone

Upon plugin the cell phone, notifier says " there is a device …", but clicking it to open with dolphin a popup error window is shown
Screenshot_20180210_143236
Translating,
“A file or folder udi=/org/. … does not exist”

Tried installing package

mtpfs

but it did not help (did not reboot yet).

I’ve found this reference,

Error with KIO while trying to open Lumia device on Plasma 5 : kde

there one says kio-extras has to be rebuild with patches …

Does anybody else has this problem? Do I report to bugzilla?

Thanks

Rebooting didn’t help.

Launching mtpfs on command line twice, two different messages:

$ LC_ALL=C mtpfs
Listing raw device(s)
Device 0 (VID=22b8 and PID=2e62) is a Motorola Moto X (XT1053).
   Found 1 device(s):
   Motorola: Moto X (XT1053) (22b8:2e62) @ bus 2, dev 122
Attempting to connect device
Android device detected, assigning default bug flags
Listing File Information on Device with name: (NULL)
fuse: missing mountpoint parameter

$ LC_ALL=C mtpfs
Listing raw device(s)
Device 0 (VID=22b8 and PID=2e62) is a Motorola Moto X (XT1053).
   Found 1 device(s):
   Motorola: Moto X (XT1053) (22b8:2e62) @ bus 2, dev 33
Attempting to connect device
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): No such device
outep: usb_get_endpoint_status(): No such device
libusb_open() failed!: No such device
LIBMTP PANIC: Could not init USB on second attempt
Unable to open raw device 0

Wouldn’t KDE Connect work maybe better and easier for this?

Edit: KDEConnect - KDE Community Wiki

KDE-connect doesn’t seem to work here. Does it work for you?

I’ve downloaded KDE-connect to my android, opened it, it said other devices connected to the same network would appear but nothing happened. Be it on OMV LX 3.03, be it on my cell phone, nothing.

At least PTP connections seems to work.

I used KDE Connect …I was able to download photos from my phone to my desktop one at a time using wi fi
but unable to transfer from my desktop to my phone , the root file listed what is suppose to be the home directory
as a series of question marks ie . owner , permissions , etc , think if you change the way the file system is set up on the phone anyone could access it , so I left it alone …I can still use a usb connect an transfer files between the two device’s but I think there is a different protocol used when you do it that way.

Do you mean using MTP protocol at OMV LX 3.03?

I think so …from what I was able to find out , if you install sshfs then files are transferable using dolphin . I have not tried that yet :slight_smile:

sshfs is installed here and I still cannot access cell phone using MTP protocol.

I tried again… the error code I get when using dolphin is " could not mount device file system "
I’m not sure if its a permission issue are not I will try it as root.

I tried as root but no other file reader can see the phone as a mounted file system not mc pcman or a terminal,
will keep trying and let you know if I have success.

I guess, as I said earlier, that this reference is correct, kio-extras must be rebuild with applied proper patches …

Filed a bug 2308 on this problem.

https://issues.openmandriva.org/show_bug.cgi?id=2308

I’m really new on this. Sorry. To work with KDE-connect one first must allow for this service in firewalld:

om-cc=>Network sharing

Now, KDE-connect works nice

I’ll take a look on this.

General note - kio-mtp is dead since 2012. Do not install and use it. Please use kio-extras or mtpfs.

Everything works ok except I can’t mount my phone’s file system onto my computer and view it in dolphin using wi fi , I still have to
connect a usb cable to do that . I’m pretty sure that the protocol for file transfer using wi fi is different than the protocol used for usb file transfer or I just have a really old phone …LOL
glad you got it to work.

It seemed not to work, I mean, the system did not “noticed” there was a cell phone plugged in without kio-mtp installed.

Well, I didn’t understand. You were trying to access your cell phone via wi-fi using KDE-connect and you did not succeed? You were able to access your cell phone using a usb cable instead?
I’m not able to access using the usb cable via a MTP protocol. I successfully accessed the cell phone using KDE-connect after configuring the firewalld to allow for the kde-connect service:

om-control-center=>security=>configure your firewall=>service

to set kde-connect service to work on your firewall.

I did this from the terminal to get past the firewalld

sudo firewall-cmd --zone=public --permanent --add-port=1714-1764/tcp

sudo firewall-cmd --zone=public --permanent --add-port=1714-1764/udp

sudo systemctl restart firewalld.service

kde connects works fine when I transfer files from my phone to my desk top , but I can’t transfer files from my
desktop to my phone unless I use a usb cable , when I do that the phone becomes another storage device
and gets mounted on the root file system of my desktop.
all in all I’m still happy to use the remote mouse and media control . The find your phone ping is cool too.

got it to work …I realized that if I wanted to transfer files from my desktop to my phone I had to use the file they share to do that …their " I/O area " which was my download file on my desk top I also did what you recommended here https://forum3.openmandriva.org/t/kio-mtp-not-working/1680/18?u=jimmyc
I think both using the command line from a terminal or the control center will work .