KDE won't start in LX4.3 live DVD


  • OpenMandriva Lx version: 4.3

  • Desktop environment (KDE, LXQT…): KDE

  • Description of the issue (screenshots if relevant):

OMA LX 4.3 DVD Live won’t start. After loading, it stucks on a black screen with the white mouse pointer and nothing can be done. I tried different troubleshooting options, but with no success.
To track down this issue, I tried and boot in CLI mode, logged in as root and started the X11 graphic server.
Unfortunately, also in this way X11 did not start and the following error messarges appeared:
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
Failed to create wl_display (no such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Could you please give me any hint to start this new version? Currently I am using the previous 4.2 version with no problem at all.

  • Relevant informations (hardware involved, software version, logs or output…):
    Asus ROG Strix Z490-F motherboard
    Intel I7-10700K CPU (3.8 GhZ)
    2 Corsair 8192MB DDR4 2133MhZ RAM
    NVIDIA GeForce GTX 1060 3GB graphic card
1 Like

First welcome back Marco.

We are currently trying to problem solve a similar or perhaps same issue with someone on IRC. This is a guess but could you please try the Option under Troubleshooting:

Start OpenMandriva Lx live mode (NVME APST=OFF)

Post-edit: Project leader @bero tells us that this would not have anything to do with booting a DVD. And sure enough after I burned a DVD to test, booting with this option worked the same as booting with the default entry. Boots to black screen with mouse cursor and I have to open VT and run sudo systemctl restart sddm. @ben79 apologizes for any confusion this post may cause.

Ahh, I think, this could be another problem too. I once had a similar issue and then I found, that ther is a starting process that is waiting for three minutes.

I didn’t stumbled across it again. so, if you do have this black screen, try to wait around 4 minutes. If nothing happens, then this shouldn’t be this problem.

1 Like

When you boot and see black screen, can you try press ctrl+alt+t to open konsole and then run command: plasmashell

I burned a DVD and tried to boot on old ASUS notebook. It does not boot the normal way here, does as @Marco says and boots to black screen and mouse cursor. (And I waited a full 10 min.)

@Marco If @AngryPenguin suggestion does not work try this. When you get to the black screen with mouse cursor:

Open virtual terminal (VT) by pressing Ctrl>Alt>F3 keys.

Type live then hit enter key, then type sudo systemctl restart sddm and hit enter key.

That works here.

Note: Here the DVD booting is MEGA slow. It takes literally multiple minutes for each step.

Hi, this solution works for me. I tried on different pc’s and always I got the slow black screen, all with hard disks, not ssd.
Supposing a problem on the image I tried with different downloads, but with the same results.
Quite an oddity.

I have not tested this yet, someone else on IRC reports this works.

Perhaps a better, quicker workaround is:

Boot DVD using:

Troubleshooting>Boot OM Lx LIve to CLI

When you get to cli enter live to login and type:

$ startplasma-wayland

Edit (2022-02-14): This was tested and works_for_me.

There are people looking at this issue. No promises. Using DVD for this now a days is a bit odd. USB Flash Drives are faster and much more commonly used.

I am hoping this helps people trying to boot our ISOs using DVD.

Hi Ben, thank you so much for your help.
The workaround you have suggested to boot from DVD is great. I just found a little issue with the pointer movement; it appears stuttering and not smooth at all.
Anyway, I think the OM official page should make clearer that booting from DVD is deprecated. Personally, I would appreciate an official guide to make a USB pen bootable with the LX4.3 image. I don’t think I am the only person who follows an old-fashoned booting approach…

Agreed, this is being discussed.

Look under “Booting from USB” in OM Lx 4.3 Release Notes.

That should be enough explanation, if not let us know.

With ROSA image writer you don’t need to format the flash drive just pop it in and select the .iso file to copy and the flash drive to copy to and select OK.

thank you, really.
I think Release Notes are very clear and useful also for managing MBR vs. GPT partition schemes.