KDE Wayland mouse cursor glitches


  • OpenMandriva Lx version: Rome

  • Desktop environment (KDE, LXQT…): KDE Wayland

  • Description of the issue (screenshots if relevant):

The mouse cursor changes when hovering over different types of targets as it should, but sometimes the cursor position is off-set and appears to jump. For example, moving over a text field (Firefox URL / Search box as an example) the cursor jumps out of position. Selecting text in Konsole is also not accurate, as the cursor icon doesn’t represent where the mouse actually is, and you select text off position of the pointer. The cursor will also become ‘stuck’ after moving over an element, for example it will sometimes continue to be a re-size cursor, long after you’ve moved over the corner / edge of a window. Changing the cursor icons from KDE Settings is also buggy, as it seems to retain the Breeze Light theme over the desktop, and switch to the selected cursor theme over windows.

This isn’t a KDE or Wayland bug, as this behaviour doesn’t happen on Fedora 37 KDE Spin with a Wayland desktop. This also doesn’t happen with an OM Rome KDE X11 desktop session, the cursor behaves as expected there. I noticed this happening in the Live USB environment also, so it shouldn’t be an issue with other software that I have installed.

  • Relevant informations (hardware involved, software version, logs or output…):

Asus ROG Flow X13 Laptop, Ryzen 5900HS CPU, using integrated Vega8 iGPU. OM Rome, fresh install yesterday, updated.

The problem seems to be a mesa bug. I found this in the Mesa Bugtracker :

For those interested, the process that Mesa glthread needs excluding for is kwin_wayland. I’m assuming that Mesa will add it in but until then you can resolve this manually by creating a file labelled .drirc, with the following info, and place it in ~/ (home folder):

<device driver="radeonsi">
   <application name="kwin_wayland" executable="kwin_wayland">
      <option name="mesa_glthread" value="false" />

Thank you! :slight_smile:

I’ll give that a try.

That works, thank you very much - I can now go back to wayland. :slight_smile: