KDE plasma logoff does not end user sessions

When a user logoff from a KDE plasma session many related processes keep on running even if another user log in.
As a result, the new user has no access to system resources like sound and others.

To stop former user’s processes, I have to kill their pid one by one.

This happens in OMV LX 3.0. Don’t know if it happens in other distributions of KDE.

Does anyone know how to change this (undesirable) feature so that logoff really means logoff?


I checked yesterday and I can login to other user accounts and listen to music and watch videos.

You mean after some other user has just logoff before?

I log our of user-A and log in to user-B, test, and log out and log in to user-C, test, and in each instance everything I tried worked.

Thanks Ben79,

Looking for an explanation.

I’ll post here if (and as soon as) I find one …

Thought it could be related to the way users were created. I used to create new users via MCC but, after problems with authentication, I was told in this forum to use Kuser. Then I created another user with Kuser and tested. The test showed that it is not related to the way I created users.


1- Turn on computer,
2- Login with the new (Kuser created) user and accessed some audio Youtube. It was OK;
3- Logoff the new user;
4- Login with my own user => No sound in Youtube videos;
5- Turn off computer and turn on again
6- Login with my user and sound was back again.

Still investigating although with no clue at the moment.

I should say that I do recall having seen what you are reporting or something similar at times. I’ll keep an eye on this and when time allows try some more testing myself.

My normal procedure is to create 1st user during install with same password for root/admin and user and select autologin. After 1st boot I add additional users (several) from cli thus:

# useradd -c "Bud Weiser" -u 1000 budw
# passwd budw

and also install ‘xguest’. And that’s all I’m doing currently.

Here, two different installations of OMV LX 3.0 (fresh install), desktop and laptop, different sound cards, different processors, different video cards. Both installations show this problem. Always.