Je n'ai pas les permissions de modifier mes fichiers (partition de données commune)

forum
Tags: #<Tag:0x00007ff2b56afe00>

(bluc) #1

Bonjour,
J’ai installé OMA sur mon ordi a coté de Ubuntu et j’ai une partition de données commune , j’ai donc fait des liens vers cette partition pour mes dossiers Images , Documents, Vidéos, etc…
mais apparemment je ne doit pas avoir les droits depuis OMA , puiise-que je ne peux les modifer

Habituellement avec une distro basée sur Debian , je lance le navigateur de fichiers en administrateur pour modifier les permissions , mais là sur OMA , je ne sais pas comment lancer Dolphin en root
J’ai essayé su su - Alt+F2 kdesu mais le terminal me repond que ce n’est pas possible

Je compte sur vous pour m’aider

Merci

PS: je trouve curieux l’user dans le terminal , est ce normal ?

Screenshot_20180110_143750


(Raphaël) #2

Fais-tu partie de la liste des sudoers? (qui peuvent lancer des commandes admin avec sudo)


(Raphaël) #3

Qu’est-ce qui te choque?


#4

Il est possible que l’uid et le gid de l’utilisateur Ubuntu ne soient pas les mêmes que ceux de l’utilisateur OMLx. Voir cette réponse de @luca qui pourrait régler ce problème de façon satisfaisante.

Dans Plasma5 un certain nombre de programmes ne peuvent plus être lancés en tant que root comme dolphin, krwite et kate mais pour les éditeurs il y a une solution de contournement officielle. Par exemple, pour kwrite :
SUDO_EDITOR=kwrite sudoedit <file>
Personellement, j’utilise konqueror, qui marche moins bien qu’avant, (ou mc) et gedit qui peuvent être lancés en tant que root. Il y a bien d’autres solutions, comme krusader pour le gestionnaire de fichiers.
Il est bien difficile de comprendre le choix des devs de plasma5.

Tout est normal. En particulier, pour root, tu peux avoir deux invites :
su
root@<hostname> <dossier de l'utilisateur qui lance la commande>

su -
root@<hostname> <home de root (par défaut)>
Le tiret est pratiquement équivalent à l’option --login qui ouvre une session avec l’environnement du nouvel utilisateur. Sans le tiret, on reste dans l’environnement de l’utilisateur qui lance la commande.

EDIT : le format exact de l’invite dépend de la variable d’environnement PS1. On peut la personnaliser.


(bluc) #5

Je cherche la petite bête là, je voyais deux fois mon user alors que j’ai l’habitude de root@luc et du fait que je ne pouvais pas lancer Dolphin en root je me suis dit que ça pouvait venir de ça .
Bon… je comprends, c’est un peu comme avec Wayland on ne peut plus ni Nautilus en admin, ni Gparted etc…

J’ai regardé en gros le lien sur le topic de Luca , mais ça ne me parle pas beaucoup, je vais y regarder de plus près

je ne comprend pas non plus , certains peuvent ,d’autres ne peuvent pas faire ça ?..

j’ai d’autres petits problèmes je pense qu’il vaut mieux lancer un topic par question

Pas facile quand on est habitué a un tout autre systeme
Sinon je suis vraiment surpris de Kde en bien ,c’est joli et bien pensé ,deux ou trois petits trucs que je n’aime pas trop comme ce qui est l’équivalent de Synaptic par exemple

Merci a vous deux


(bluc) #6

j’ai lancé la commande

sudo chown -R $USER /media/fichiers

puisse que la partition commune s’appelle fichiers et ça fonctionne :sunglasses:

Je vous remercie

Je n’ai pas trouvé la manière de mettre résolu dans le titre