Is there something wrong with the openmandriva kernel?

OMV Lx 3.0 + all updates

The question is, do newer openmandriva kernels lack support to start when more than one OS coexist, do these kernels have difficulties to start in a MSDOS partitioned disc?

Here is the story,

I had OMV LX 3.0 installed in a MSDOS partitioned SSD disk in dual boot with windows 8 (it does not support GPT). I’ve struggled to install grub2 in MBR and managed to config grub to see the windows partition. No /boot/efi partition was needed to set the system to work at that time.

I’ve updated this system with relatively no problems until packages for 3.02 arrived. Suddenly, many booting problems arised and, with newer updates, the system no longer boot.

For other reasons, I had suspicious about my SSD device integrity and decided to buy another one. Tried to install 3.02, 3.03, all with grub at MBR as before, but none of them boot as older kernels did.

The only way OMV LX 3.03 kernel worked was without the windows system and with a GPT partitioning of the disc.


You may check kernel log with journalctl -kxa. Also you may try to installGRUB2 again with grub2-install (look at the manpage for further details).

I had no problems to install grub2 in MBR indeed. Did it in live mode. Next step would be configuring grub2 which I wasn’t able to do in live mode. As described in

the next to do was booting the OMV LX installation straight from a grub prompt. This used to work in older kernels but no longer works in newer ones in the configurations I had in the computer:

Two disks, a SSD and a HDD. The former with a MSDOS partition table (SO’s OMV and Windows + MBR), the latter with a GPT (/home + Windows D)

Hi @adelson.oliveira,
as you know, though they are linked, grub and linux (kernel) are different things.
I used to install OMLx beside other OS, and I always was able to, at least, launch the kernel from the grub’s choice screen. However, I never did it on a computer with W8 but I doubt there is a specific issue here since you succeeded to install 2014.2.
So, in order to understand myself what exactly happens, I suggest to answer the questions one by one.

  • have you installed 3.0 above 2014 (or beside 2014, that I would recommend) or have you tried to make an upgrade from 2014 (by changing the repos)?
  • did you reformatted some partitions including swap? (1)
  • did you try to keep the old grub.cfg? (1)
  • can you get the grub’s choice screen?
  • can you launch W8?
  • can you, at least, get the kernel 3.0 starting?

(1) the idea, here, is to verify if there is a wrong partition UUID in grub.cfg (the UUID changes when reformatting with default options).

On your “base” system, ie. the system you boot from post the output of:

$ grep initrd /boot/grub2/grub.cfg*

and also for good measure could you also attach your entire ‘/boot/grub2/grub.cfg’ file?

No not by design. I think any developer would tell you that kernel in OS is not and can not be affected by any other operating system. When the OS begins to boot the kernel doesn’t ‘know’ about any other kernel or OS’s.

Now this is just a ‘hunch’ or ‘guess’ on my part but:
What packaged that fundamentally changed things in booting many Linux systems was introduced about the same time you started to see these problems?

Edit: I think means just that like “as I understand it” but I could be wrong. Could be wrong about everything… :confounded:

Hi Jclvanier,

I’ve installed 3.0 over 2014 via a fresh install (no update). At that time I eventually managed to install grub2 at MBR as described in the reference. After then, I updated the system regularly, 3.0 to 3.01 to 3.02. Although I cannot be precise, I would say that booting problems (not severe) begun with some kernel and systemd updates by the time of 3.02. The problem became critical with the last 3.03 systemd package update when the system no longer boot. Then I tried another fresh install with OMV LX 3.03 iso following the steps described in the reference link but it no longer worked.

Hi Ben79,

Not sure if I understood the question. I have to say that there was only one Linux system and W8. As I described above, the problems arose along with recent updates of kernel and systemd.

Now, with the new kernel (and new systemd), It is not possible to boot the kernel in the followin environment:
1- grub2 at MBR in MSDOS partition SSD with OMV LX 3.03 and W8 system files;
2- /home at another 3.6 TB HDD with also with some W8 users data files.

Unfortunately, I cannot provide grub.cfg files from the old installation anymore.

Thank you all.

Just to be clear, to have OMV LX 3.03 installed, I reformatted the SSD in a GPT partition and removed W8.

So you have only one system (OMLx3) on your computer, right?

Hi Jclvanier,

I’ve installed successfully OMV LX 3.03 after giving up having a MSDOS partition with W8 and OMV. As it is now, I can launch the system with no problems but I no longer have any MSDOS partition to install W8.

I’ve open this topic just to know more ad report my experience.

Just to clarify, the steps to have OMV LX 3.0 and W8 in a MSDOS partition was:

1-Make partitions, install W8.
2-Install OMV LX 3.0 (no grub installation because the installer do not allow to install at MBR)
3-In live mode install grub at MBR, see how at
4-Upon rebooting grub is installed but not configured; Boot OMV LX 3.0 in grub commands as in the reference above. This step used to work with older kernels but no longer works.
5-If boot is successful, finally configure grub.

Since newer kernels (systemds?) no longer pass step 4 above, I can no longer finalize the installation as before.

Was referring to microcode which OpenMandriva calls it’s latest package ‘microcode-intel’. My experience is only with UEFI booting. It does change how Linux systems boot by completely changing how initrd’s are labeled and where they are stored. What I don’t know is if or how it might affect booting in BIOS mode or booting Windows. So this may or may not have anything to do with your issue. Just threw it out there as something to investigate.

Your issue is looking more and more like a serious bug not uncovered in ISO beta testing.

Your not trying to use a /home partition from 2014 without reformatting are you? That would cause problems. To many to try to solve.

Also it seems odd to have an SSD formatted with MBR and a HDD formatted with GPT. Why? If you are stuck with BIOS boot due to hardware the BIOS might be having problems booting GPT partitions, I’m pretty sure this is a bad practice. You may want to google “BIOS mode and GPT” and do some reading.

Here’s is a screen shot of Calamares installer on Partitions window:

See where in upper right by “Select storage device” it has an arrow pointing to “BIOS”. If you want to BIOS boot you must see this on Partitions window. If you don’t see BIOS do not install. Stop and ask questions. If you do see BIOS and it is also telling you to install a ‘/boot/efi’ partition do not install. Stop and ask questions. That is a red flag telling us something is wrong. You do not need or want a /boot/efi partition for BIOS booting.

We know that Windows 8 does support and prefer GPT so where did you get an SSD that does not support GPT. That does not seem possible? What are you basing this on?

Edit: OK, re-read post and see where you reformatted SSD to GPT. So somehow you are thinking Windows 8 has to be installed in MSDOS partition table? That is just wrong. Windows 8 is designed for UEFI boot which requires GPT partition table. Windows 8 most certainly can be installed on a GPT partition.

Edit-2: But you probably have to UEFI boot the Windows installer to install to GPT? This I don’t know. But this has to be a solvable problem. Google it and solve it. (Easy for me to say!)

Edit-3: Suggestion: First be sure you motherboard firmware is fully up to date. Then if you are certain motherboard will not support UEFI boot (since 2011 most do support UEFI or EFI): Reset both SSD and HDD to MBR and start over.

No, there was a EFI somewhere …Even being the disk (I’m sure) the MSDOS partitioned one.

Is this possibly a kind of bug in the installer? If so, would it be caused by the duplicity: MSDOS and GPT partitions even in different disks?

Sorry not being precise about that, I didn’t intend to spend much money at W8 launching time so I’ve bought a update to W8, not the “full system”. Well, I used to have WXP in a MSDOS partition and I intended to update to W8. Anyway, I’ve tried,

1-first install old WXP, then update to W8, but WXP was 32 and I would like to use W8 64bits disk;
2-Install directly from W8 64 bits disk and, if requested, pass WXP disk for certification. But even installing W8 (update) first it refused to install in a GPT partition (?);
3-Install W8 64 bits directly in a MSDOS partition and procede the steps I’ve done with OMV LX 3.0.0.

Well we can be sure that won’t work if you are trying to BIOS boot.

No, at least not in my opinion. In my opinion you are trying to go beyond the capabilities of the installer.

If you can install Windows (whichever one) on MSDOS partition table then that would be good if you intend to BIOS boot. I would just ensure that both drives are MSDOS partition table.

Also bear in mind that it is technically possible to mix MSDOS and GPT partition tables. That does not mean it is easy or a good idea. If you google and read about this you will soon see what I’m talking about.