Installation VIBER impossible


#1

bonjour,
je viens d’installer openmandriva derniere version mais je n’arrive pas à installer viber car j’ai ce message d’erreur: certains paquetages demandés ne peuvent pas être installés : viber 6.0.1.5-2X86-64 ( car libcrypto .so.10()(64bit) est non satisfait.
j’utilise beaucoup viber et j’aimerai bien pouvoir l’installer s’il existe une solution…
je vous remercie de l’aide que vous pourrez m’apporter.


#2

Je n’ai pas encore pu installer la Lx 3, mais as tu essayé

urpmf libcrypto.so.10

Qui devrait permettre de trouver quels paquets ont cette bibliothèque.


#3

bonjour et merci pour votre aide.
j’ai lancé la commande dans le terminal et essayé d’installer VIBER apres mais j’ai le même probleme. Je dois avouer que je debute sous linux depuis environs 3 mois et je ne suis pas tres familiarisé avec cet environnement.
Je vous remercie pour votre suivi
Cordialement


#4

Pas de problème :slight_smile:

Que t’a donné comme résultat la commande ci-dessus?


#5

bonjour, voilà ce que donne la commande :slight_smile:

[openmandriva@openmandriva-pc ~]$ urpmf libcrypto.so.10
[openmandriva@openmandriva-pc ~]$

merci pour votre parience


#6
[root@omlx3GA ruru]# urpmi viber --test
No package named viber
[ruru@omlx3GA ~]$ urpmf libcrypto.so.10
[ruru@omlx3GA ~]$ 
[ruru@omlx3GA ~]$ urpmf libcrypto
lib64cryptopp-devel-5.6.3:/usr/lib64/libcryptopp.so
lib64openssl-devel-1.0.2h:/usr/lib64/libcrypto.so
lib64openssl-devel-1.0.2h:/usr/lib64/pkgconfig/libcrypto.pc
lib64crypto1.0.0-1.0.2h:/lib64/libcrypto.so.1.0.0
kernel-rc-source-4.6.0-0.rc7.1omv-1:/usr/src/linux-4.6.0-0.rc7.1omv/tools/build/feature/test-libcrypto.c
lib64cryptopp6-5.6.3:/usr/lib64/libcryptopp.so.6
lib64cryptopp6-5.6.3:/usr/lib64/libcryptopp.so.6.0.0
lib64openssl-static-devel-1.0.2h:/usr/lib64/libcrypto.a
kernel-release-source-4.6.5-2omv-1:/usr/src/linux-4.6.5-2omv/tools/build/feature/test-libcrypto.c
cryptominisat-libs-2.9.8:/usr/lib64/libcryptominisat-2.9.8.so
cryptominisat-devel-2.9.8:/usr/lib64/libcryptominisat.so
abi-compliance-checker-1.98.5:/usr/share/abi-compliance-checker/modules/Targets/unix/descriptors/libcrypto.xml
abi-compliance-checker-1.98.5:/usr/share/abi-compliance-checker/modules/Targets/unix/descriptors/libcrypto1.xml
[ruru@omlx3GA ~]$ 

Je ne peux pas vous en dire plus… :smirk:


#7

bonjour, urpmf libcrypto à fonctionné mais j’ai le meme message d’erreur si je veux installer VIBER…


#8

Pas la peine d’essayer, le rpm que tu as est pour fedora. J’ai forcé l’installation sur mon pc mais cela ne fonctionne pas, trop de dépendances ne sont pas installées ou pas reconnues


#9

bonsoir,
merci pour le suivi et l’info; je ne vais pas insister
merci à tous


#10

Par contre on peut faire une demande de package si tu veux…


#11

hum tu peux tenter :slight_smile:

mais c’est pas libre, y’a pas de tar.gz …


#12

Fedya utilisait une technique avec docker pour skype, peut être que ça pourrait marcher de manière similaire…


#13

bonsoir, c’est quoi cette technique?


#14

Oops, pardon @openmandriva, j’ai loupé cette réponse. Je vais me renseigner, car pour être franc je ne le sais pas dans les détails, mais je me doute qu’il s’agit d’embarquer une conf marchant à la perfection - avec toute les bibliotHèques nécessaires -à l’intérieur même d’un container. Donc en théorie, n’importe quelle version de Linux, voire n’importe quel OS pouvant faire tourner docker, peut utiliser le version «dockerisée» du logiciel.


#15

d’accord, merci


#16

Bon on m’a demandé si tu pouvais ouvrir un ticket sur le bugzilla (severity=enhancement). Mais comme c’est en anglais, est-ce que ça te pose problème?


#17

bonjour, j’arrive à lire et à comprendre l’anglais qant à ecrire c’est autre chosede plus je ne sais meme pas ce que c’est qu’ouvir un ticket
merci


#18

Je vais essayer de voir si je peux le mettre dans un container docker ou rkt. Tu es toujours intéressé @openmandriva?


#19

Il y a une base de travail ici :