Installation OMLx 4.0 not possible (HP Probook)


  • OpenMandriva Lx version:

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):
    I install using Calamares, choose to erase disk and create partition with swap and hibernation.
    During install stage, it fails with this error:

  • Relevant informations (hardware involved, software version, logs or output…):
    I attach here the output of

journalctl.txt (171.9 KB)

inxi -F -c 0
inxi.txt (2.2 KB)

LC_ALL=C pkexec /usr/bin/calamares -d
calamares.txt (24.0 KB)

Additional information: may not be relevant, but wifi is not working in live mode.

Just a guess because in theory I believe we should be able to pick either MBR or GPT. Maybe it wants a GPT partition table?

1 Like

Note for all users: This command will erase whatever disk is selected. It works well and fast. So be careful that you select the correct drive.

Since you are going to erase the disk anyway you can “blank” it first with dd command (replace X with the letter for drive to be erased.):

$ sudo dd if=/dev/zero of=/dev/sdX bs=1k count=2048

and try installation again. That usually corrects any partitioning errors not as sure about creating a partition table. Also you could blank the drive and then set up partitions with KDE Partition Manager and then use ‘Use existing partitions’ on the Calamares installer.

1 Like

Oh stoopid me I did not think about this, is there a way to check this? Out of changing boot options…

If you used erase disk it should automatically create the correct partition table. So something is wrong, maybe something is wrong with the disk itself. But to set which type of partition table is:

We both know that @abucodonosor would know this better than I do.

1 Like

you should before use gparted to create partitions and then mount manual with mounpoint
after , be careful temp for your radeon video card

1 Like

I tried the solution with Calamares which failed. I couldn’t try with gparted as the wifi doesn’t seem to work and I have no other mean to access the Internet to install it.
However I tried with the KDE alternative PartitionManager and I could suppress the existing partitions, create GPT table and install OM Lx.
However the boot device is not detected (though I played with the options is BIOS secureboot and CSM options)

I retried with a GPT partition and I’ve got the same error…

1 Like

So we are going to need @abucodonosor for this one.


@raphael Found this in logs:

15:39:08 [6]: Required  storage B: 9126805504 "(8GB)" 
15:39:08 [6]: Storage capacity  B: 2654720 "(0GB)" for "/dev/sda"    length: 5185

Can you please run lsblk and provide output here ?

I guess the 8GB device was the USB drive I used to transfer documents between my computer and my installing OMLx (where there is no working wifi)

loop0    7:0    0   2.4G  1 loop /run/initramfs/image
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0 457.6G  0 part 
└─sda2   8:2    0   8.2G  0 part 
sdb      8:16   1  28.9G  0 disk /run/initramfs/omdv
├─sdb1   8:17   1   2.4G  0 part 
└─sdb2   8:18   1   6.6M  0 part 
sdc      8:32   1   7.3G  0 disk /media/live/F9BB-4089
sr0     11:0    1  1024M  0 rom

edit: or the swap partition?

I think I found the solution.

The USB drive started in CSM mode, I could make it start in UEFI mode.

I still had to clean the disk with KDE Partitions Manager as Calamares failed to do it, but then automatic partition created the needed boot partition.

Then the system boots correctly :grinning:

Aside: the wifi issue seems to be common to this hardware, I’ve seen some tutorials (for Ubuntu only) here and there to install the drivers. I’ll try to apply them to OM Lx.