Installation Failed: File Exists error

I am having issues installing Open Mandriva Rome.
Calamares gives me an error saying that a file exists. This is something that I know has cropped up before. I think it might be because I am installing to /dev/sdc1 and I have Ubuntu installed on /dev/sda1 and it might be trying to do something with grub on that drive and can’t.

Using F8 I have the option to select the Mandriva drive and boot into Grub for Open Mandriva but if I do all I get is the Grub command line and that is way beyond my abilities to sort out.

I am keen to try Mandriva Rome properly as I have been looking for a rolling release distro that is new user friendly ( Rhino and Peppermint did not cut it for me )

  • OpenMandriva Lx version:
    23.08 ROME

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):
    Calamares on finishing installation says “File Exists” - I am unable to copy the info in the window but I gather from a web search ( which provided no solution for me ) that it doesn’t give much information away anyway.

  • Relevant informations (hardware involved, software version, logs or output…):
    i7-7700, rx6700xt, 32gb ram.

Welcome @Peppermint

You should be able to take a screenshot and post it here ?

I have run the installer again and I am getting the same error.
Installation failed:

Boost.Python error in job “bootloader”.

<div><strong>&lt;class 'FileExistsError'&gt;</strong></div><div>[Errno 17] File exists: '/tmp/calamares-root-3rry5u1n/boot/efi/EFI/BOOT/bootx64.efi'</div><div><br/>Traceback:</div><div><pre>File &quot;/usr/lib64/calamares/modules/bootloader/;, line 777, in run

  File &quot;/usr/lib64/calamares/modules/bootloader/;, line 748, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File &quot;/usr/lib64/calamares/modules/bootloader/;, line 657, in install_grub
    shutil.copy2(efi_file_source, efi_file_target)

  File &quot;/usr/lib64/python3.11/;, line 436, in copy2
    copyfile(src, dst, follow_symlinks=follow_symlinks)

  File &quot;/usr/lib64/python3.11/;, line 258, in copyfile
    with open(dst, 'wb') as fdst:

That is the information in the box. I am currently in the live disk environment.

1 Like

1 Like

While waiting for anyone who is better knowledged, please tell also:
if you verified your iso file (checksums)
how you transferred the image to the pendrive, assuming that you used a pendrive, otherwise if you used a DVD.

I did not verify the file. I don’t know how to verify an iso.

I have tried images from both the sourceforge link and via torrent.

I had trouble writing the ISO to USB.
I had to unmount the the filesystem on the USB stick ( it had a blank ext4 partition on it ) before the KDE Image Writer would write the ISO.

I did use KDI Image writer as recommended ( UnetBootin would not even recognise the .iso as valid )

Just having a look at the first line of the error: FileExists is a check to see if a file exists.
it’s looking for the following file:


When I go into Dolphin and to /tmp/calamares-root-3rry5u1n/boot/efi/EFI/BOOT/

the filename boot64.efi requested by the script is actualy capitalised to BOOTX64.EFI in the folder. So is that why it’s failing to find the file?

I shall try renaming the file to lower case and run the installer again.

click the “i” (info) little icon near the file you downloaded

take note of the 2 checksums SHA1 and MD5

In the directory where is the iso file you downloaded open konsole and type

md5sum openmandriva.rome-23.08-plasma.x86_64.iso
sha1sum openmandriva.rome-23.08-plasma.x86_64.iso

compare the konsole outputs with those you noted earlier, they must match.

(see also

1 Like

Downloading the ISO image again. md5sum did not match.
Will try again if I can get an image that verifies.

The image verified this time and the installer looks different and just got to “All done”. So in theory I have a working installation now. I must have had a bad image originally.

Thanks for the support.

Glad that you sorted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.