Install OMLx.4.1-beta on ssd/nvme

Tags: #<Tag:0x00007f8cce90ee00> #<Tag:0x00007f8cce90ec48>

when installing mandriva I wanted to manual partitition ssd I could make the partitions but installing system failed only auto install would work for me

[grumpy@ron-tobefilledbyoem ~]$ inxi -F
System:
  Host: ron-tobefilledbyoem 
  Kernel: 5.5.0-desktop-1omv4001 x86_64 bits: 64 
  Desktop: KDE Plasma 5.17.5 
  Distro: OpenMandrivaLinux 4.1 Mercury 
Machine:
  Type: Desktop Mobo: ASRock model: X570 Taichi 
  serial: <root required> UEFI: American Megatrends v: P2.00 
  date: 08/21/2019 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 
  type: MT MCP L2 cache: 4096 KiB 
  Speed: 4091 MHz min/max: 2200/3700 MHz Core speeds (MHz): 
  1: 3673 2: 4065 3: 4072 4: 4097 5: 4071 6: 4075 7: 4070 
  8: 4084 9: 4084 10: 4083 11: 4093 12: 4085 13: 4135 14: 4076 
  15: 3432 16: 4077 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 
  470/480/570/570X/580/580X/590] 
  driver: amdgpu v: kernel 
  Display: x11 server: OpenMandriva X.org 1.20.7 driver: amdgpu 
  FAILED: ati unloaded: fbdev,modesetting,vesa 
  resolution: 2560x1080~60Hz 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.36.0 
  5.5.0-desktop-1omv4001 LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.3 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 
  570/580/590] 
  driver: snd_hda_intel 
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
  Device-3: Logitech Logitech BRIO type: USB 
  driver: hid-generic,snd-usb-audio,usbhid,uvcvideo 
  Sound Server: ALSA v: k5.5.0-desktop-1omv4001 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
  IF: wlp6s0 state: up mac: 3c:f0:11:da:f7:dc 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full 
  mac: 70:85:c2:d6:78:6c 
Drives:
  Local Storage: total: 1.58 TiB used: 7.10 GiB (0.4%) 
  ID-1: /dev/nvme0n1 vendor: Gigabyte model: GP-ASACNE2512GTTDR 
  size: 476.94 GiB 
  ID-2: /dev/sda vendor: Intel model: SSDSC2BW240A4 
  size: 223.57 GiB 
  ID-3: /dev/sdb vendor: Intel model: SSDSC2BW240A4 
  size: 223.57 GiB 
  ID-4: /dev/sdc vendor: Samsung model: SSD 840 EVO 250GB 
  size: 232.89 GiB 
  ID-5: /dev/sdd vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB 
  ID-6: /dev/sde vendor: Kingston model: SA400S37240G 
  size: 223.57 GiB 
Partition:
  ID-1: / size: 218.77 GiB used: 7.10 GiB (3.2%) fs: ext4 
  dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 46.8 C mobo: N/A gpu: amdgpu 
  temp: 37 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 925 
Info:
  Processes: 297 Uptime: 40m Memory: 62.75 GiB 
  used: 1.25 GiB (2.0%) Shell: bash
1 Like

Hi @rbrick49.

While the inxi -F output is helpful we need to know a bit more to get to bottom of this.

What ISO were you trying to install? The OM Lx 4.0 from SourceForge or other? Or for instance OM Lx 4.1 Beta or RC?

We can probably get to what is going wrong if you run installer from Konsole and copy and paste entire output in a .txt file and post that file here. To run installer in Konsole:

$ pkexec calamares -d

Also if you could post screen shots of exactly what you are trying to do and any error messages that would be helpful.

Is this that nvme drive? Are you trying to install to that drive? nvme drives are new and some don’t yet have firmware in Linux kernel. My Samsung 970 EVO Plus did not when I first installed OM Lx on it. On the ISO’s under “Troubleshooting” you will see 2 options to start OM Lx live mode with:

  1. (PCIE ASPM=OFF)
  2. (NVME APST=OFF)

I had to use PCIE ASPM=OFF until the firmware for my Samsung got to Linux kernel about a month after I got it. I do not know if either of these would work in your case but something to try. Those options were put there because of user reported issue with nvme ssd’s.

its ok its installed I wasnt installing it on the nvme I was installing it on a ssd when I partitioned the ssd the installer wouldnt install it but erasing and letting the installer do its automatic install it worked fine,I manually partitition all my drives this way and they dont give me any problem.
first partition 512 mb fat 32
second root 50000mb
third home bance of drive
no swap I have 64 gig of onboard memory
the iso i have installed is OpenMandrivaLx.4.1-beta-plasma.x86_64.iso

1 Like

@ben79 Hi Ben just letting you know I thought I would try installling on the nvme pcie card it worked perfect and fast to,I manually partititioned 3 partitions uefi,root and home the only thing different I did was made uefi fat 16 instead of fat 32
regards Ron

1 Like

@rbrick49 I edited the topic title to be more specific.

2 Likes