Install from source (standard Linux app installation)


  • OpenMandriva Lx 23.03 (ROME) Rolling with kernel 6.2.6 desktop.
  • KDE Plasma

I am unable to run standard Linux “install from source” commands, such as “./configure” or “make” when installing software from original source code. Is there something else that OpenMandriva requires as a dependency before doing this?


P.s. the ONLY reason that I am trying to install Terminator this way, is because the one in the OpenMandriva repos does not launch

I believe the easy way to build an OMLx package from our GH sources is:

$ git clone

$ cd <name of package>

In this directory you can make any changes or add patches is you wish. Or just build with:

$ abb build

terminator will install in Cooker so if it does not install in ROME it probably just needs a rebuild for some dependency. Edit: I am looking in to this and will probably start a rebuild soon.

Note: An alternative build command using abf is:

$ abf rpmbuild

ABF=Automated Build Farm There are docs for ABF here and here. As far as I know abb build and abf rpmbuild do the same thing.

All the contributors and developers here are unpaid volunteers.

You are welcome to talk to our developers at OpenMandriva Chat.

OpenMandriva wiki and Forum Resources guide.

The original problem:

$ terminator
Traceback (most recent call last):
  File "/usr/bin/terminator", line 48, in <module>
    import terminatorlib.optionparse
  File "/usr/lib/python3.11/site-packages/terminatorlib/", line 22, in <module>
    from terminatorlib.terminator import Terminator
  File "/usr/lib/python3.11/site-packages/terminatorlib/", line 8, in <module>
    gi.require_version('Vte', '2.91')
  File "/usr/lib64/python3.11/site-packages/gi/", line 126, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Vte not available

Question what does terminator do that opening Konsole in another tab or window or cloning a tab does not do? I ask because I have never used terminator before.

1 Like

Hi @PlaidRadish

terminator is a python code so there is not configure && make && sudo make install (please note you shoud not use sudo with ./configure and make!!) but something like

python3 build

Please report the error you got in this case or it will bu hard to help you.

BTW it this case there is a missing dependency wil be fixed in next update, meanwhile you may install by hand by using the following command:

sudo dnf install lib64vte-gir2.91

Install that and terminator does open. Thanks @mandian.

Um, I posted last post to quickly. terminator does open but it also outputs the following:

$ terminator
Unable to open ‘/home/ben79/.config/kdedefaults/terminator/config’ for reading and/or writing.
([Errno 2] No such file or directory: '/home/ben79/.config/kdedefaults/terminator/config')
ConfigBase::load: Unable to open /home/ben79/.config/kdedefaults/terminator/config ([Errno 2] No such file or directory: '/home/ben79/.config/kdedefaults/terminator/config')
Unable to load Keybinder module. This means the hide_window shortcut will be unavailable
Unable to bind hide_window key, another instance/window has it.
<window.Window object at 0x7fcc66189880 (terminatorlib+window+Window at 0x563317f0b900)> is not in registered window lis

Don’t know if any of that indicates any loss of function but it reads that way to me. But I do not know this software.

I’ve been using Terminator for it’s customization options. It far outweighs any stock terminal app, regardless of distro.

Thanks. I use the app on over a dozen different VMs and physical machines, so that would be helpful.

Oops, yeah, I just realized the screenshot was from an attempt to see if the devs for Terminator elevated privilege requirements for source install. I don’t use sudo for installs and definitely not unless it’s a known dev. I worked with the Terminator devs back in the mid 2000’s, and they were super, so my trust level is obviously high. :wink:


I’ll give that a try.

I suppose these are optional features: you may activate them by installing a couple of additional packages

sudo dnf install lib64notify-gir0.7 lib64keybinder-gir3.0

I added these packages as suggested but I expect the build system add automatically any *-gir requires. Maybe @AngryPenguin knows this better.

The package terminator-2.1.3-3 (actually in unsupported/testing repo) should fix everything.

I had already run the suggested dependency installs in the replies above, so I did not want to uninstall every dependency just to try the testing repo version. I did uninstall the application (v 2.1.3-1), though, and installed the latest tersting version (v 2.1.3-3), which also works but still throws the same errors that @ben79 mentioned above regarding home folder config files and this one:
Gtk-Message: 15:14:30.744: Failed to load module "appmenu-gtk-module"

BUT, @ben79 also had an error for the Keybinder module, hide_window key, and window.Window object, and I am not getting ANY of those errors.
So, perhaps … progress?

(pardon all the edits my copy/paste fingers keep falling asleep) :smiley:

Thanks to everyone for the help, here. I will do my best to keep this thread alive until a functional version of the app (without errors) is in the repos.

Full disclosure: The devs of the original Terminator application wrote and continue to develop the app specifically for Gnome, so I imagine that is a significant part of the problem. I assume secondary devs are making changes to the versions that get uploaded to repos for other DE’s?

In fact is is. IT wokrs well under GNOME or Mate. You may try to install lib64appindicator2-gir0.1 or lib64ayatana-appindicator3-gir0.1 or switch to GNOME/MATE directly.

Indeed it does. I run at least a dozen Linux distros, and all the GNOME-based OSes work well with Terminator - no extra work or fidgeting. :wink:

OpenMandriva has both in unsupported repo:

sudo dnf install task-gnome


sudo dnf install task-mate
1 Like

If you already have unsupported repo enabled. Else:

sudo dnf install --enablerepo=rolling-x86_64-unsupported task-gnome
sudo dnf install --enablerepo=rolling-x86_64-unsupported task-mate

(change arch value if needed)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.