Impossibile montare directory di rete via nfs

da quando ho installato OMVLx3.0 non riesco a «montare» via nfs le directory del NAS della mia rete.
il comando è una riga in «/etc/fstab» per il montaggio al boot.
Se avvio il notebook con RosaR8, che ha la stessa riga in «/etc/fstab», tutto funziona.
facendo alcune prove ho notato che non mi funziona nessun tipo di collegamento via «nfs».
deve essere problema solo mio perché non ho visto discussioni in merito: c’è qualcuno in grado di aiutarmi a scoprire l’arcano?

Premetto che non uso nfs e non ho neanche la Lx3.0.

Cosa succede se provi il mount manualmente?

# mount il_tuo_mount_point

anzitutto grazie per l’attenzione, meglio di un help desk,
copio e incollo:

mount /mnt/Bru

mount.nfs: an incorrect mount option was specified

che è impossibile perché l’unica opzione è: defaults
ecco la riga in fstab

nas:/Bruno/ /mnt/Bru nfs defaults 0 0

con systemctl status mnt-Bru.mount ottengo:

mnt-Bru.mount - /mnt/Bru
Loaded: loaded (/etc/fstab; generated; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2016-11-19 07:34:45 CET; 10h ago
Where: /mnt/Bru
What: nas:/Bruno/
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 5529 ExecMount=/bin/mount nas:/Bruno/ /mnt/Bru -t nfs (code=exited, status=32)

e con perror ho:

perror 32

OS error code 32: Broken pipe

di più non riesco a cavare.

Comunicazione di servizio:
Usare il code (icona </>) per pubblicare parti di codice, in modo da evitare che l’editor interpreti il cancelletto # simbolo di root come:

grassetto enorme

:smile:

PS> parti di codice e/o comandi, ovviamente :wink:

grazie per l’avviso, sto facendo delle prove e ho capito che mi ci vorrà un po’ per imparare a usare quelle piccole icone.

vediamo se riusciamo ad ottenere più informazioni da:

# mount -vvv /mnt/Bru

nas dovrebbe essere l’indirizzo ip. sei sicuro che venga ben risolto?

$ ping nas

ti risponde?

# mount -vv /mnt/Bru
mount.nfs: timeout set for Sat Nov 19 21:07:30 2016
mount.nfs: trying text-based options ‘vers=4.2,addr=192.168.1.100,clientaddr=192.168.1.14’
mount.nfs: mount(2): Invalid argument
mount.nfs: an incorrect mount option was specified

ping nas
PING nas (192.168.1.100) 56(84) bytes of data.
64 bytes from nas (192.168.1.100): icmp_seq=1 ttl=64 time=0.291 ms
64 bytes from nas (192.168.1.100): icmp_seq=2 ttl=64 time=0.346 ms
64 bytes from nas (192.168.1.100): icmp_seq=3 ttl=64 time=0.396 ms
^C
— nas ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2070ms
rtt min/avg/max/mdev = 0.291/0.344/0.396/0.045 ms

ping risponde.
aggiungo che per accedere alla mia directory sono dovuto passare a smb/cifs con le paturnie dovute alla compatibilità M$
quindi la riga in fstab (innestata su altro punto di montaggio) è:
//nas/Bruno/ /mnt/Bruno-SMB cifs credentials=/home/bruno/.olme,uid=bruno,rw 0 0
e funziona.

prova a vedere se questo aiuta:
https://bbs.archlinux.org/viewtopic.php?id=193834

potrebbe anche essere un problema di firewall e che qualche porta vada aperta.
però quel “invalid argument” mi fa pensare che la riga indicata in fstab non è corretta, almeno per la versione di mount.nfs installato

eseguendo:

# lsmod | grep nfs
nfsv4 339968 0
nfs 229376 1 nfsv4
fscache 65536 2 nfsv4,nfs
nfsd 286720 1
auth_rpcgss 53248 1 nfsd
nfs_acl 16384 1 nfsd
lockd 81920 2 nfsd,nfs
grace 16384 2 nfsd,lockd
sunrpc 307200 8 auth_rpcgss,nfsd,nfsv4,nfs_acl,lockd,nfs

# ps -A|grep rpcbind
5348 ? 00:00:00 rpcbind

# mount -t nfs4 192.168.1.100:/Bruno /mnt/Bru
mount.nfs4: an incorrect mount option was specified

# systemctl status rpcbind.service
● rpcbind.service - RPC bind service
Loaded: loaded (/lib/systemd/system/rpcbind.service; indirect; vendor preset: disabled)
Active: active (running) since Sat 2016-11-19 07:34:35 CET; 13h ago
Process: 5248 ExecStart=/sbin/rpcbind -w ${RPCBIND_ARGS} (code=exited, status=0/SUCCESS)
Main PID: 5348 (rpcbind)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/rpcbind.service
└─5348 /sbin/rpcbind -w

nov 19 07:34:35 rpcbind[5348]: Cannot open ‘/var/lib/rpcbind/rpcbind.xdr’ file for reading, errno 13 (Permission denied)
nov 19 07:34:35 rpcbind[5348]: Cannot unlink ‘/var/lib/rpcbind/rpcbind.xdr’, errno 13 (Permission denied)
nov 19 07:34:35 rpcbind[5348]: Cannot open ‘/var/lib/rpcbind/portmap.xdr’ file for reading, errno 13 (Permission denied)
nov 19 07:34:35 rpcbind[5348]: Cannot unlink ‘/var/lib/rpcbind/portmap.xdr’, errno 13 (Permission denied)

questo non me l’aspettavo

# systemctl status nfs-server.service
● nfs-server.service - NFS Server
Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2016-11-19 07:34:43 CET; 13h ago
Process: 5458 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=1/FAILURE)
Process: 5445 ExecStartPre=/usr/lib/nfs-utils/scripts/nfs-server.preconfig (code=exited, status=0/SUCCESS)

nov 19 07:34:43 exportfs[5458]: exportfs: Failed to stat /mnt/Public/Giornali: No such file or directory
nov 19 07:34:43 systemd[1]: Failed to start NFS Server.

dando un occhio

# ls -l /var/lib/rpcbind/
totale 0
-rw------- 1 root root 0 ago 12 01:17 portmap.xdr
-rw------- 1 root root 0 ago 12 01:17 rpcbind.xdr

non dovrebbe essere accessibile?

hai confrontato i file presenti su Rosa?

questo l’hai provato:

Try with ‘mount -t nfs4 -o vers=4.1’ or ‘mount -t nfs4 -o vers=4’ is the first one doesn’t work.

provato

# mount -vvv -t nfs4 -o vers=4 nas:/Bruno /mnt/Bru
mount.nfs4: timeout set for Sat Nov 19 22:00:56 2016
mount.nfs4: trying text-based options ‘addr=192.168.1.100,clientaddr=192.168.1.14’
mount.nfs4: mount(2): Protocol not supported
mount.nfs4: Protocol not supported

provato

# mount -vvv -t nfs4 -o vers=4.1 nas:/Bruno /mnt/Bru
mount.nfs4: timeout set for Sat Nov 19 22:01:13 2016
mount.nfs4: trying text-based options ‘vers=4.1,addr=192.168.1.100,clientaddr=192.168.1.14’
mount.nfs4: mount(2): Invalid argument
mount.nfs4: an incorrect mount option was specified

provato a cambiare i permessi /var/lib/rpcbind , da così

drwx------ 2 root root 4096 mar 20 2016 rpcbind

a così
drwxr-xr-x 2 root root 4096 mar 20 2016 rpcbind

con
# systemctl reload-or-restart rpcbind.service
il servizio è partito ma

● rpcbind.service - RPC bind service
Loaded: loaded (/lib/systemd/system/rpcbind.service; indirect; vendor preset: disabled)
Active: active (running) since Sat 2016-11-19 22:31:27 CET; 2min 36s ago
Process: 15354 ExecStart=/sbin/rpcbind -w ${RPCBIND_ARGS} (code=exited, status=0/SUCCESS)
Main PID: 15356 (rpcbind)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/rpcbind.service
└─15356 /sbin/rpcbind -w

nov 19 22:31:27 tosh64.fromgold rpcbind[15356]: Cannot unlink ‘/var/lib/rpcbind/rpcbind.xdr’, errno 13 (Permission denied)
nov 19 22:31:27 tosh64.fromgold rpcbind[15356]: Cannot unlink ‘/var/lib/rpcbind/portmap.xdr’, errno 13 (Permission denied)

… ora confronto i files su Rosa

su Rosa i permessi della directory sono come quelli originali in OMV

drwx------ 2 493 493 4096 nov 14 15:14 rpcbind

ma i files non sono vuoti

# ls -l /var/lib/rpcbind/

-rw------- 1 493 493 284 nov 14 15:14 portmap.xdr
-rw------- 1 493 493 1500 nov 14 15:14 rpcbind.xdr

reinstallare qualcosa?

ultime cose che mi vengono in mente:

  • che versione gira sul server nfs?
  • prova a disabilitare il firewall

per stasera ho esaurito le cartucce.

così è sulla 2014.2:

[root@ilprof4 ilprof]# systemctl status rpcbind.service
rpcbind.service - RPC bind service
Loaded: loaded (/lib/systemd/system/rpcbind.service; enabled)
Active: active (running) since sab 2016-11-19 07:07:21 CET; 15h ago
Process: 1955 ExecStart=/sbin/rpcbind -w ${RPCBIND_OPTIONS} (code=exited, status=0/SUCCESS)
Main PID: 3751 (rpcbind)
CGroup: /system.slice/rpcbind.service
└─3751 /sbin/rpcbind -w -i

nov 19 07:07:21 ilprof4 rpcbind[3751]: Cannot open ‘/var/lib/rpcbind/rpcbind.xdr’ file for reading, errno 13 (Permission denied)
nov 19 07:07:21 ilprof4 rpcbind[3751]: Cannot unlink ‘/var/lib/rpcbind/rpcbind.xdr’, errno 13 (Permission denied)
nov 19 07:07:21 ilprof4 rpcbind[3751]: Cannot open ‘/var/lib/rpcbind/portmap.xdr’ file for reading, errno 13 (Permission denied)
nov 19 07:07:21 ilprof4 rpcbind[3751]: Cannot unlink ‘/var/lib/rpcbind/portmap.xdr’, errno 13 (Permission denied)
nov 19 07:07:21 ilprof4 systemd[1]: Started RPC bind service.
[root@ilprof4 ilprof]# cd /var/lib/rpcbind
[root@ilprof4 rpcbind]# ls -al
totale 8
drwx------ 2 root root 4096 lug 31 2015 .
drwxr-xr-x 52 root root 4096 nov 19 11:02 …
-rw------- 1 root root 0 lug 31 2015 portmap.xdr
-rw------- 1 root root 0 lug 31 2015 rpcbind.xdr

però non l’ho mai provato

ok segna pure una birra a tuo credito
speriamo nella mente sveglia di domani
'notte

:wink:
prova a vedere se nel journal, al momento del mount, c’è qualche indicazione in più sull’errore

e casomai se sul nas hai una versione vecchia

mount -t nfs -o nfsvers=3

# mount -t nfs -o nfsvers=3 192.168.1.100:/Bruno /mnt/Bru
Failed to start rpc-statd.service: Unit rpc-statd.service not found.

sembra più interessante il log

# journalctl | grep nfs
nov 20 09:09:15 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=494 cmdline="/sbin/modprobe -q – fs-nfsd"
nov 20 09:09:16 kernel: Installing knfsd (copyright © 1996 okir@monad.swb.de).
nov 20 09:09:42 blkmapd[5058]: open pipe file /var/lib/nfs/rpc_pipefs/nfs/blocklayout failed: No such file or directory
nov 20 09:09:50 systemd[5270]: nfs-secure-server.service: Failed at step EXEC spawning /usr/sbin/rpc.svcgssd: No such file or directory
nov 20 09:09:53 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=5403 cmdline="/sbin/modprobe -q – fs-nfs"
nov 20 09:09:53 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=5402 cmdline="/sbin/modprobe -q – fs-nfs"
nov 20 09:09:54 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=5402 cmdline="/sbin/modprobe -q – fs-nfs"
nov 20 09:09:54 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=5403 cmdline="/sbin/modprobe -q – fs-nfs"
nov 20 09:09:54 kernel: FS-Cache: Netfs ‘nfs’ registered for caching
nov 20 09:09:54 kernel: LoadPin: kernel-module old-api-pinning-ignored obj= pid=5452 cmdline="/sbin/modprobe -q – nfsv4"

ma come si concilia con:

# lsmod |grep nfs
nfsv4 339968 0
nfs 229376 1 nfsv4
fscache 65536 2 nfsv4,nfs
nfsd 286720 13
auth_rpcgss 53248 1 nfsd
nfs_acl 16384 1 nfsd
lockd 81920 2 nfsd,nfs
grace 16384 2 nfsd,lockd
sunrpc 307200 20 auth_rpcgss,nfsd,nfsv4,nfs_acl,lockd,nfs

è festa; meglio riposare!

Può anche darsi che ci troviamo di fronte ad un bug.
Io chiederei lumi anche nella sezione inglese, almeno per sapere se altri montano partizioni nfs senza problemi, …fregandomene del crossposting :wink:

# mount -vvv -t nfs4 -o vers=4 192.168.0.101:/tmp /mnt/tmp
mount.nfs4: timeout set for Sun Nov 20 16:48:06 2016
mount.nfs4: trying text-based options ‘addr=192.168.0.101,clientaddr=192.168.0.145’
mount.nfs4: mount(2): Connection refused

Questo esempio da una Lx3(che per default userebbe vers=4.2) verso una macchina che supporta vers=4.
Il problema dell’“invalid argoument” è superato. Il connection refused ci sta tutto perchè su quella macchina di nfs non gira niente :wink:

# mount -vvv -t nfs -o vers=4 192.168.0.147:/srv/testnfs /mnt/tmp
mount.nfs: timeout set for Sun Nov 20 18:05:32 2016
mount.nfs: trying text-based options ‘addr=192.168.0.147,clientaddr=192.168.0.145’
192.168.0.147:/srv/testnfs on /mnt/tmp type nfs (rw,vers=4)

ho attivato il server nfs dall’altra parte(su una 2014.2) e funziona.
Per me è un problema di versioni.