I cannot get Falkon to play amazon prime movies

I cannot get Falkon to play amazon prime movies, I get this pop up,
To watch protected content, in the top right of Chrome, click the three dots icon, and then tap Settings > Site settings > Protected content. Under Blocked, tap Amazon.com > Clear and Reset. Refresh or reload the video’s detail page, and then tap Watch Now.
Cannot find anything about protected content in tools or preferences settings.
Its gotta be something simple I’m overlooking.

Operating System: OpenMandriva Lx 4.0
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.3
Kernel Version: 5.1.12-desktop-1omv4000
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8259U CPU @ 2.30GHz
Memory: 15.5 GiB of RAM

System is updated.

Also spell check does not work.
If this is the default browser for this distro one would expect these to functions to work.

1 Like

I’m not sure if Falkon browser supports the proprietary DRM widevine module by default.
That’s why such options are missing from the menu.
However, Falkon uses the chromium code, so perhaps it can be possible to run widevine.

I can not check it now, but I see reddit posts about the fact that widevine works. Here’s how to do: https://www.reddit.com/r/linux/comments/9lwarg/psa_falkon_qt5_successor_to_qupzilla_supports/e7az8je/

1 Like

To me Falkon looks and feels a lot like Qupzilla, in that it looks and feels like people started developing a web browser and just never finished the job. For instance spell checking not working in a web browser is pretty dog gone basic. And in the US a least watching Amazon Prime videos is also very basic gotta have it type of stuff. (Not “having to make it work” should just work.)

Personally I also get irritated at having to zoom the same page over and over because Falkon can’t remember anything. There’s more. But for me using Falkon slows me down.

Welcome @Tommy to OpenMandriva forum and OM the distro. Hope you enjoy your time with both.

After spending to much time reading about widevine and spell check I have come to the conclusion that Falkon is not worth the trouble, why, why would you make this your default browser and it does not peform basic functions.
If you can’t fix it why should I?
Spell check does not work and I doubt most newbies would be able to fix it.

The best solution to the Falkon problem would be to use Firefox or Chromium as your default browser. Since Falcon is kde it will be there for anyone that wants to try it, and figure out how to get it to work properly.

1 Like

Falkon is much better than its reputation (which doesn’t mean it can’t use a few improvements, but it’s being improved rather quickly).

Spell check does work, it just requires dictionaries to be packaged properly, which we currently don’t do - but fixing that is a matter of minutes. Either this “not working” was never reported or I missed it, or it would have been fixed before release time. I’m currently updating the toolchain in Cooker, but nevertheless expect to see a fix for spell checking in Falkon in Cooker today or tomorrow.

Last time I checked, Widevine was not Open Source, so we can’t distribute it regardless of browser. The article @AngryPenguin linked to shows it does work if the binary is grabbed from a non-free browser and copied in place – same thing you’d have to do with any other browser.

There’s a few nice things about Falkon that neither Firefox nor Chromium can deliver:

  • Good, readable and maintainable code
  • Small memory and diskspace footprint (also by not dragging in 1000 extra libraries)
  • Much more easily extensible
  • Makes it really easy to support new filetypes and protocols

While it isn’t perfect yet, at least to me Falkon is less bad than any of the others.

1 Like

I edited the topic title title,
“Falkon” is not very meaningful.

Good to see spell check will be fixed very soon.
I am using Firefox now instead of Falkon and widevine does work in openmandriva with Firefox. I’m not a developer and have no idea how Firefox makes that happen if widevine is not supplied by openmandriva but they do.
Not being a developer the things you mention are not relevant to me the end user, I was enjoying the Falcon browser but those 2 issues stopped my cold in my tracts.
I either have to figure out how to fix them or just download Firefox or Chromium and be done with it, one way is a lot easier than the other.

1 Like

Mozilla has a license to provide widevine with its browser. That why it is possible. When you install Firefox - drm widevine is disabled (or should be disabled by default). You need enable it in options and then browser download all needed component automatically. In this way, various Linux distributions can provide Firefox without having to wonder what to do with proprietary widevine. Readhere

Not all browsers are able to do this. An example is Opera, which indicates that to use widevine on Linux, you must have Google Chrome installed or pull the library itself out of the package and copy it to the appropriate folder.
Why is it so complicated if Opera itself is a proprietary browser? Certainly it is a license that costs, and it seems a lot, that’s why even Opera for Linux not provide widevine.

I understand, which is why Falkon should not be your default browser.

1 Like