HPLIP and RSS widgets dont not working

  1. HPLIP also cannot install. Pakiet python-sip-4.19.17-2-omv4000.x86_64.rpm no signed

  2. qt5-xmlpatterns - cannot install

error in RSS plasma widgets
CompactRepresentation.qml:55:5: Type FullRepresentation unavailable

file:///home/radek/.local/share/plasma/plasmoids/rss_indicator/contents/ui/FullRepresentation.qml:5:1: module “QtQuick.XmlListModel” is not installed

Started resigning process. Should be soon on mirrors

Looks like our qt5-xmlpatterns is hit by that bug https://bugreports.qt.io/browse/QTBUG-71656

For HP Photosmart 6520 printer here is what I did. Open Konsole and run this:

$ sudo dnf install --nogpgcheck task-printer-hp

Then I rebooted with printer off. When reboot finished and desktop was up for about 2 min. I turned my printer on. Window pops up saying something like “Printer is being configured”. When that finished I printed test page. So automatic configuration in this case. Worked like magic.

Since I am a QA-Team person I did check what driver was “configured” and it was the correct one.

python-qt5-xmlpatterns-5.12.2-3-omv4000.x86_64.rpm have not been signed
cant install

there is also problme with google-earth. lsb does not meet reqruiments. Cant install.
I have enabled 32 bit repo all

Try this in Konsole:

$ sudo dnf install --nogpgcheck python-qt5-xmlpatterns

The package signing issue is known to developers and they are working on resolving this.

This one I don’t understand? Here is what dnf search shows.

$ dnf search qt5-xmlpatterns
Last metadata expiration check: 0:00:27 ago on Mon 17 Jun 2019 08:57:37 AM CDT.
=============================================================================== Name Matched: qt5-xmlpatterns ===============================================================================
python-qt5-xmlpatterns.x86_64 : PyQt 5 xmlpatterns
python-qt5-xmlpatterns.x86_64 : PyQt 5 xmlpatterns
python2-qt5-xmlpatterns.x86_64 : PyQt 5 xmlpatterns

Please stop. Test before you post some suggestions to users.
qt5-xmlpatterns is broken and it does not provide QtQuick.XmlListModel because of missing buildrequires.

i installed both python and python2-qt5-xmlpatterns
RSS widgets does not work

Test what or test how? Edit: Not meaning to be snarky, sorry if sounded that way. But if there is a better way to test something like this I would appreciate being taught how to do so. That is what I mean here.

I installed the package with the command I posted.That is all I was posting.

i have installed via command line sudo dnf install --nogpgcheck python-qt5-xmlpatterns but i have installed both file python and python2

That will most likely turn out to be the bug @TPG posted about.

Just for your and other peoples information @TPG is an OM developer. I am not. My knowledge level is that of a user. People should know that.

You suggest user to install python-qt5-xmlpatterns which is completely unrelated to his issue with plasma “RSS indicator” plasmoid.

RSS indicator does not work because our qt5-xmlpatterns is compiled without needed buildrequires. Hope this is now clear.

I’m trying to build qt5-xmlpatters with added buildrequires, but now it whines for missing qml-network :open_mouth:

ok thnaks - i will wait for info from development. what about install lsb? and google-earth?

dnf install lsb
OpenMandriva Rock - i686 - Updates 60 B/s | 350 B 00:05
Failed to synchronize cache for repo ‘rock-updates-i686’
Ignorowanie repozytoriów: rock-updates-i686
Ostatnio sprawdzono ważność metadanych: 0:24:04 temu w dniu pon, 17 cze 2019, 15:47:03.
Błąd:
Problem: cannot install the best candidate for the job

  • nothing provides qt4-common >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
  • nothing provides lib64qtnetwork4 >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
  • nothing provides lib64qtopengl4 >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
  • nothing provides lib64qtsql4 >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
  • nothing provides lib64qtsvg4 >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
  • nothing provides lib64qtxml4 >= 4.2.3 needed by lsb-lib64-5.0-0.alpha.5.x86_64
    (dodanie „–skip-broken” pominie pakiety, których nie można zainstalować lub „–nobest” spowoduje użycie nie tylko najlepszych kandydatów)

-skip-broken and --nobest hekp nothing

OK, I get that, and appreciate it. And appreciate your work on the “add missing br” patch.

What I was trying to do to be specific was answering a specific question:

With what I thought an appropriate answer to that question only. Post-Edit: My thought process was that if user installs that package we have that out of the way and can move on to deeper issues requiring developer knowledge. Hope that makes sense because that is part of my overall process in this forum.

I did not say anything about RSS or anything else working/not working.

Previously you suggested to user https://forum3.openmandriva.org/t/hplip-and-rss-widgets-dont-not-working/2814/7

dnf search qt5-xmlpatterns

rpm -ivh --nodeps google-earth-pro-stable-current.x86_64.rpm
google-earth works

sory i made 3 topic in one

We clearly are not understanding one another. I just reread all my posts and I don’t see HPLIP and RSS widgets dont not working in any of my posts.

I don’t understand how using dnf search to show a new user the package name he wrote does not exist, can be in any way interpreted to mean I’m suggesting anything else what so ever. User wrote “qt5-xmlpatterns” we don’t have a package with that exact name.

cha ha naver mind. HPLIP works, google earth works, gsmartcontrol and geany installed works, compilation works, wine32 works, rss widgets not work but will wait,
I did almost everything to make 4.0 works as 3.03 was.
Thank you very much