How can I download MuseScore?

This morning downloaded and installed OpenMandriva version Lx.3.01.1
After downloading GParted, Inkscape and Gimp I also wanted to download
my favourate music notation software program MuseScore 2.1 but OpenMandriva
could not find it. Can somebody help me in which repository I have to look for it?

you should activate the repository called “contrib”. The version of the package (2.03) is not the latest (2.1), however.
You can apply for an update in our bugzilla or directly download the the appimage from the official site.

Thanks jclvanier for your quick response, but I looked for that repository “contrib” and cannot find it when
logged in. There is only one repository to see. Or did I overlook it?

Open OpenMandriva Control Center (Configure Your Computer)
Install & Remove Software
Find: musescore

Please note dropdown menu set to “All”

Or, in a root console:
urpmi musescore

What is the list of your configured media (active and inactive)?
urpmq --list-media
You should see:

main updates
Main32 Updates
contrib updates
contrib32 updates
non-free updates
Non-free32 Updates
restricted updates
Restricted32 Updates
main testing
contrib testing

The active ones are given by:
urpmq --list-media active

You can also use:

@ rugyada:

tried it with “configure your computer”
Found “musescore”
tried to down load it but at a certain moment a little black window popped up " Distribution upgrade"
that window stayed for a while and then disappeared.
I discovered that nothing had happend, nothing was installed (yes, I clicked on “Apply”).
Tried it a second time : same result.
Then I tried to down load musescore using terminal and that seemed to work,because after the
installation procedure the “musescore icon” was there.
Double-clicked on it but, appart from that little jumping icon NOTHING happened.
Moreover I could do nothing more, impossible to turnoff the system and I was left with a hard reset to
get my computer off.
It gave me the creeps sorry for this.

[ruru@omlx-993 ~]$ rpm -qa|grep musescore

Now I have no clue on what to do with this program :grin:
but it’s there.

Please launch it from console (as user)

to see if it will show any error.

Right, but probably was just matter of revealing All instead of default Packages with GUI.
I suspect… :slight_smile:

You suspected right. It isn’t intuitive that musescore isn’t a “package with GUI” …

Well I know one thing for certain : MuseScore is package with GUI !!
But, I cannot answer the rest of your questions because, after that disaster OM refuses to boot.
Black screen with a lot of (for me)crazy text and it is hanging there. Had again to perform a brute force power shut down to get my pc working again (OM is in triple boot with PCLinuxOS and LinuxMint where I chainload OM).
Completely removed OM and will reinstall it but now with the version I checked using Oracle VBox, thus
version Lx.3.02-Plasma.
Then I will again try to install MuseScore. Keep you informed.

I see our developers are working on it. Maybe in a few day it will work fine.

Hint: Anyone multi-booting with other Linux systems will be well served to use ext4 fs. f2fs introduces to many issues, weird things happen. This is based on a good bit of testing here. One man’s opinion. YMMV.

But, ben79, I did that : used ext4 to format partitions and made two partitions, one for “/” and the other for “/home” both ext4. Because there is already a swap partition available, I did not make this also for OM.
Everything seems to work fine until I wanted to download and install MuseScore which is absolutely necessary
for me to have.

To add this:
I just downloaded and installed MuseScore on the Oracle VBox OM version Lx.3.02 without facing
any problem. And this in triple boot with PCLinuxOS, KDE-Neon and OpenMandriva on that Oracle VBox machine.
Yes, I use the procedure rugyada gave before : Configure your computer etc…

OK, just wanted to be sure that wasn’t involved here. Not meaning to run down f2fs just that I do Linux (and Windows 10) multi-boot and it’s a headache in that context. That’s all I have at the moment.

1 Like

This morning I did a new attempt to install OM, but this time I used the Lx.3.02-Plasma.x86_64.iso version.
After the successful install I first made a Distribution Upgrade (didn’t do this the first time) before doing anything else.
After this completed, I did a reboot and then I started to install MuseScore without facing any problem.
Again, I did a reboot and then started to investigate MuseScore. Until now no strange things found.
So far so good.


Awesome news, glad you got it sorted. Sorry you had problems.

1 Like


Well, here is an example of a score which I made with MuseScore.
Plays this piece on my classical Guitar.

And the default midi sound is quite good :slight_smile: