G'day guys, how do I enable auto mount of external USB drives?

Tags: #<Tag:0x00007f250e1def18>

Hello,
G’day guys, having just recently turned back to my fave distro after several years of flying the other colour with Ubuntu MATE on all of my old "redundant Intel machines’, I’m trying to get a grip on KDE & Plasma etc. I’m using an old Core 2 Duo 1.5MHz laptop to store and play my music. The issue I’m having is that my music is stored on a USB HDD and every time I use Clementime or other music apps, I have to reset my library folder to that USB HDD again every time I restart my laptop. One thing I’ve noticed is Plasma seems to not auto-mount USB HDD drives. Is this true? I have a massive music library on that USB HDD drive and it takes forever for Plasma to refresh its library again before i can use it. Is there something I’m doing wrong or a quick fix for my troubles? Thanks in advance. Troy

  • OpenMandriva Lx version:

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):

  • Relevant informations (hardware involved, software version, logs or output…):

1 Like

Welcome @dodgiebros.

Post-edit: The following would apply to Plasma desktop only.

See what this does.

This is a WD Elements 1 TB usb device I used to test if this is working. It has nothing on it. I had to format it as MSDOS/MBR partition table but it does seem to be automatically mounting.

Post-edit: I’m not sure but this seems to be a desktop dependent setting. So don’t know if there is a command that would do this for all desktops. You could add a line for the drive to ‘/etc/fstab’ that should work for any desktop.

Thanks Ben, I’ll give it go when I can and let you know how I went :+1:t3:

1 Like

finally got back to this issue… Thanks for your clear and easy to follow instructions. I checked the ‘auto mount on login’ and ‘auto mount on attach’ but my machine hung on boot. I had to uncheck the ‘automount on login’ then all went well. Thanks for help!

1 Like

Sure, glad to help.

Closing thread.