Gambas3 non si avvia

Tags: #<Tag:0x00007fb45635f748>

Ciao, c’è qualcuno che ha installato Gambas 3 in OMA4.2 e riesce ad avviarlo io riscontro questo errore:

gbr3: unable to load component: gb.form.editor

A presto.

@astragalo hanno letto la tua segnalazione e ci stanno lavorando. Probabilmente mancano delle dipendenze.
Grazie.

Ciao, non so se serve ma questo è l’elenco dei pacchetti installati su Rosa:

gambas3-gb-form-editor-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-mdi-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-terminal-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-dialog-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-print-3.14.3-1-rosa2016.1.x86_64
gambas3-gb-form-stock-3.14.3-1-rosa2016.1.x86_64

e questi in OMA:

gambas3-gb-form-3.15.2-2.x86_64
gambas3-gb-form-dialog-3.15.2-2.x86_64
gambas3-gb-form-mdi-3.15.2-2.x86_64
gambas3-gb-form-print-3.15.2-2.x86_64
gambas3-gb-form-stock-3.15.2-2.x86_64

Sorry, ho scritto prima di aggiornare…

Aggiunti con l’update gambas3-gb-form-editor e gambas3-gb-form-terminal.

Tuttavia ora viene fuori un altro errore:

gb.jit: error: unable to compile JIT code of 'gb.form.terminal':

In file included from /tmp/gambas.1001/9779/jit/jit.h:35,
                 from /tmp/gambas.1001/9779/jit/gb.form.terminal.c:1:
/usr/lib64/gcc/x86_64-openmandriva-linux-gnu/10.2.1/include/stdint.h:9:16: fatal error: stdint.h: File o directory non esistente
    9 | # include_next <stdint.h>
      |                ^~~~~~~~~~
compilation terminated.


** 
** OOPS! INTERNAL ERROR. Program aborting, sorry! :-(
** Unable to compile JIT source file
** 
** Please send a bug report to the gambas bugtracker [1] or to the gambas mailing-list [2].
** [1] http://gambaswiki.org/bugtracker
** [2] https://lists.gambas-basic.org/listinfo/user

Aggiornamento/non-aggiornamento in realtà, solo per far sapere che qualcuno ci sta lavorando.
@astragalo tu hai scoperto niente da suggerire?

Come non detto, dovremmo esserci.
Ti aggiorno.

Ciao, io avevo fatto un po’ di esperimenti senza arrivare alla soluzione…
Aspetto l’aggiornamento e lo provo subito.

A presto.

P.S. Ringrazia chi ci sta lavorando.

1 Like

Nel frattempo prova

sudo dnf clean all;dnf clean all;dnf repolist
sudo dnf install task-devel

E’ Bero.

Ciao, ho inizialmente aggiornato il sistema e riavviato e l’errore si è ripresentato, poi ho installato il task-devel ed il problema è stato risolto.

Probabilmente per la compilazione di gb.jit serve qualche libreria di sviluppo ( devel ).

Chissà se bastava installare le devel anche con i vecchi pacchetti?

A questo punto penso sia utile aggiungere il task-devel alle dipendenze di Gambas.

Anche questo bug può considerarsi risolto.

Thankyou very much Bero!

1 Like

Si perchè non era ancora stato fatto il rebuild per 4.2. Credo che sarà disponibile tra poco, lo vedo in abf.

Riferisco :wink: