Failed to start Switch Root

How to troubleshoot the installation of OMV Lx 4.2
Failed to start Switch Root

1 Like

Hello, my friend @miron2011. I am a new member here just like you. I also use Lx 4.2 but it went successfully without any error like yours. From my experience, I suggest you to verify the checksum of your ISO image file copy and redo the installation with a valid ISO image.

1 Like

I have downloaded the iso from various websites and it is the same.
This is a problem with grub. I don’t know how to edit it and what the record should be.

1 Like

I tried to deal with it.

If it were true you used the valid image file,

  1. what was the program you use to make OpenMandriva bootable? (I used GNOME Disks to a USB flash drive and it worked)

  2. did you enable updates while installing? (I disabled it and installation went successfully)

There is a hint from an Indonesian CentOS user (click here) you can learn the command lines if Terminal is not a barrier to you.

Good luck,


Sorry to hear you are having troubles @miron2011 getting OM Lx started. You may get a faster answer on IRC. Traditional way is to connect to #openmandriva @ Freenode IRC. Also we have this. IRC is where developers are. They are more likey to be able to resolve your issue.

1 Like

Some additional thoughts that may help get to a cause. There is this which does more to address installation issues as opposed to boot issues.

Do you boot to emergency mode or does the boot process stop at Failed to start Switch Root?

It might be a problem with grub2 but more likely some kernel parameter needs to be added or removed from grub2.

It will be helpful to have some hardware information on the computer where the failure occurs. If that computer has a system that uses inxi the command inxi -F would provide a good bit of detailed information. Any really new hardware could be a problem or graphics possibly could be, especially nVidia graphics. It is is a graphics problem you can try booting in “Basic Graphics Mode” under “Troubleshooting” on the ISO’s grub2 menu.

Another possible problem is with nvme ssd’s sometimes needing a special parameter. These are also under “Troubleshooting” they are the (PCIE ASPM=OFF) and (NVME APST=OFF) options. Also under “Troubleshooting” there is an option to boot the ISO in cli mode that may be useful for problem solving.

Also you could try this ISO and see if it will boot:

OM Lx Rolling x86_64 ISO

Rolling is as the name implies a Rolling release. Not yet publicly announced but internally we have been using this since OM Lx 4.0 and it generally is very well working. Public release is to be soon. The current hold up is problems with our main QA tool. There are folks working on these problems.

Note: Seems we need to add some documentation or “How To” about ISO boot issues to this.

1 Like

I install via the USB port in the normal way, starting booting on this port
Kubuntu installs without problems.
With Mandriva 2011 we do not have any problems.

@miron2011 please answer.

Rufus program

I download Rolling ISO

Here : OpenMandriva Lx 4.2 Release Notes | OpenMandriva wiki

Please do not use other usb-writing tools as some Windows tools (e.g. Rufus) truncate the volume name. This breaks the boot process.

1 Like

I wolud like to thank you all, for your help. The problem was Rufus.