Experiencing 3.02


Experiencing 3.02.

I recently bought a new All-In-One PC with Windows10, “UEFI” and “Secure Boot”, and had to read a lot, to try understanding, how would I be able to install a Linux distribution on it.

Well, this is not the subject of my post, but this was the occasion to try OpenMandriva 3.02 amongst a few others…
Of course, I first tried the potential selected distribution, on my old desktop machine, just in case…

Coming back to OpenMandriva 3.02 and this forum, I just didn’t know where (QA, Support, Coffee…) to post my experience, so I decided to post here …in the hope no grumpy admin would shout at me. …Also, because I think my relation of how I solved some problems would bring an interest to some …and at least, because I would like some help
for the remaining problems.

After 1 year, away from Plasma5, I hated at first glance, and swore never install, I must admit that …it has not changed !!! Always as ugly as possible…
Well, changing :

  • windows frames for “DARK TRANSLUCENT”
  • graphics for “QTCURVE”
  • theme for “DIAMOND”
  • Colours for “KRITA DARK”
  • Cursors for “WONDERLAND”
  • icons for “OXYGEN”
  • menu
  • desktop background
  • and more…
    …OpenMandriva 3.02 is, at least, bearable for my old eyes…

Concerning the most annoying bug of this distribution -I hereby designate the internet connexion not working- I had to remove all connexions, remove NETWORK MANAGER, and let the system create a plain direct ethernet cabled connexion.

Another bloody battle was, with installing NVIDIA proprietary driver, as NOUVEAU is still a pure shit here…

When entering the MCC/configure graphic server (excuse me, all is in french here and I don’t know how to traduce the exact terms) I was requested to install (proprietary 381.22), what I did… Of course(!) after a correct download, build, make and installation, no Nvidia graphic screen but NOUVEAU.
I launched then “XFdrake” but -as well known- it tried to install 304 version of the driver which is obsolete with my card…
Besides, XFdrake tried to install the kernel-devel and all the stuff to compile, but failed in this ! (Remember, the failed installation of 381.22 had “already” installed all what necessary…)
There, I came to this forum, and read COLIN explaining that NOUVEAU is blocking in GRUB2; so at a new launch, I edited GRUB2 and added option “rd.driver.blacklist=nouveau” (as recommended by COLIN) => This time, XFdrake could install all the stuff for 304 version, it had tried negatively previously.
NOTE THIS : For long, I know, on my machine, XFdrake has to be launched 2 times consecutively to be capable of writing the xorg.conf …what I did… and checked in /etc/X11.
But, at the next boot, I encountered in front of me a black screen, as two versions of the proprietary driver were installed. I removed (in TTY) 304 version …and after a last reboot the proprietary driver version 381.22 was working. No more artefacts in my windows deco and menus! Great !

My claims now, are for the absence of some packages, I cannot dispense with : PYSOLFC
…and the impossibility to install CONKY, though the packages are in the repositories.

From this experience I confess, I will not install OM 3.02 on my new All-In-One, but I will go on using it for some time on my old machine. The reason is, that I have always had a good feeling for this distribution (still working on my wife’s machine -previous version-); I admire the efforts and the insistence of COLIN and some other guys, and at last, hope my interest for this distribution will bring some comfort to all those who dedicate their time for us.



Merci pour le feedback.

Is “windows frames” the windows decoration? I have no luck with search in store.kde.org for “DARK TRANSLUCENT”

It would be useful if you add also the build ID number of the ISO you are testing, or a mention about it’s the official 3.02 release, just for more clarity :wink:

Hi Rugyada,

Official 3.02 release.

Windows frames = windows decoration …Just pressing the above right button in the window and typing “Dark translucent” in the small search-window which appears.

Here menu with Diamond:


1 Like

Unfortunately no way to add stuff from there because of bug

btw if I even try to type anything, the app segfaults

So need to go searching at store.kde :slight_smile:

Agree, Diamond is a very nice theme, for those who like transparency.


I can confirm this. Please file a but report on bugzilla.

I don’t know this software. Please ask for new package on bugzilla or it will never be added.

Hello Mandian,

Sorry but, Bugzilla is enemy territory for me!
…Spare me my (good) reasons for this…

I know…

Thank you anyway