Error Keyring Brave Update


  • OpenMandriva Lx version:

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):
    Greetings, I have an error when updating brave regarding the keyring. Any idea how to proceed?

  • Relevant informations (hardware involved, software version, logs or output…):

I have Brave installed and haven’t seen the problem yet. I am using the Cooker.
Can you paste the error message?

@danieldelarosa welcome to the OpenMandriva forum.

Of course, with pleasure.
This is the error at issue
Problem: cannot install the best update candidate for package brave-keyring-1.3-1.fc28.noarch

  • nothing provides /usr/bin/sh needed by brave-keyring-1.9-1.noarch

1 Like

Thanks, you’re a great distro


Try first running:

$ sudo dnf clean all

Then run:

$ sudo dnf up

A mention for all OMLx 4.3/Rock users: This is the recommended update procedure from OMLx 4.3 Release Notes:

Recommended update procedure

While we do provide Discover and dnfdragora gui’s for package mangement we find it best if users update their OM Lx 4.3/Rock system from Konsole (or other terminal). This is very easy, just copy and paste this command:

$ sudo dnf clean all ; sudo dnf upgrade

Then press Enter key and when prompted enter your root (superuser) password. We recommend this because we see a lot of problem reports that begin with “I updated my system with Discover updater” or “I updated my system with dnfdragora”.

Thanks for your response, I did that cleanup and subsequent update but the error persists. shared evidence

That is an unusual error. In OMLx we have /bin/sh not /usr/bin/sh. (Also /bin/bash and some other terminal shells.) From that stand point the error would be correct, on a normal OMLx 4.3 system there is no /usr/bin/sh.

I can not imagine any reason an OpenMandriva built package would be calling for /usr/bin/sh. But I am not a developer, just user knowledge level.

Also I have tested installing brave-browser in my OMLx 4.3 test systems and there is no error here.

Ah, your repolist. OpenMandriva Rolling is not OpenMandriva Lx 4.3. Still my comment about /usr/bin/sh applies.

To verify which version of OMLx you have:

$ cat /etc/release

For Rock it should show:

OpenMandriva Lx release 4.3 (Dysprosium) Official for x86_64

Rolling will show:

OpenMandriva Lx release 4.50 (Rome) Rolling for x86_64

If by some chance you install OMLx 4.3 and tried to upgrade to Rolling there is more to that than just changing the repositories. For one thing if you are using Rolling the upgrade command needs to be different. You need to be using sudo dnf dsync like this copy and paste command string:

$ sudo dnf clean all ; sudo dnf dsync

I have not done any testing of upgrading OMLx 4.3 to Rolling. Perhaps it is time for that. This has to be tested because it may require more than just sudo dnf dsync.

Yes it is an unusual error, I wonder if there is something wrong with the omlx software repository, since I installed it from there and not from the official website. I also changed the update channel from rock to rolling release thinking there might be some change but no. My only question is, would the brave package be frozen? would not receive more updates?, the rest of the programs are updated normally

I tried this suggestion, but the problem persists, it’s very stubborn hehe

[quote=“danieldelarosa, post:11, topic:4469”]
I also changed the update channel from rock to rolling release thinking there might be some change but no.[/quote]

Changing upgrade channels in not trivial. The Software Repository Selector does pop up a window:


dnf --refresh distro-sync is similar to dnf clean all ; dnf distro-sync. dsync is an abbreviation of distro-sync. dnf clean all does (or cleans) more than the --refresh option. Either of them will force the enabled repositories to update to latest metadata. That is the important part. clean all also cleans any old .rpm files from the dnf cache. This can be important if user is changing upgrade channels.

I have tested installing brave-browser in Rolling, and Rock versions and there is no problem shown. Whether upgrading or installing you are installing new software. I do not see any reason to freeze brave packages. To do that you would add --exclude=brave* to the upgrade command.

The repos for brave, google-chrome, team, and vscode are not OpenMandriva repositories, they are as the Software Repository Selector indicates third party repositories. What is in the Brave repo comes from Brave.


Which you can see here under " Fedora 28+, CentOS/RHEL 8+" or " OpenSUSE 15+". (Those are the most widely used Linux distros using rpm.)

Now to get your system sorted. The first thing I would suggest is to decide whether you want to be using Rock or Rolling and get that set with Software Repository Selector. I would suggest for now to do that using the --exclude=brave* option to any upgrade commands you run.

Whether you choose Rock or Rolling first run this:

$ sudo dnf clean all ; sudo dnf dsync --exclude=brave*

If that works then we can deal with whatever is causing the error with brave-keyring.

Note: If you choose to go with Rolling there may be other issues we have to deal with. That would be expected. Usually these are easy to figure for someone that is familiar with the peculiarities of OpenMandriva Lx. And OpenMandriva Lx is indeed unique.

Note-2: I believe this is all rather confusing to any new OMLx users. I have no answer for that other than for users to learn. OMLx is a small group of all part-time, unpaid volunteers. Current resources for new user to learn are here and here.

ben79 and the entire oma community thank you very much for your great kindness and willingness to help. I’ve been going through those resources and they’ve done a wonderful job considering how small a group they are as you mention. For me it is gratifying to be part of such a dynamic and defined community. At the time when I made the switch I also ran the
dnf --refresh distro-sync
command and it did overhaul a large number of packages with no problem. The sudo dnf clean all command; sudo dnf dsync does not give me a problem even if I add the exception, it worked like this
sudo dnf clean all ; sudo dnf dsync --exclude=brave-browser

1 Like

Good to hear danieldelarosa. If I am interpreting that screen-shot correctly you have brave-browser installed and and are able to run sudo dnf clean all ; sudo dnf dsync with no error. That suggests this problem is solved. Or that I missed something.

Recommended to always use that command to update your Rolling system. Suggestion to enable the Unsupported repo for Rolling. You will find a lot of useful software in that repo.There are packages in that repo that are ancient and no longer maintained but also stuff that is well maintained by @AngryPenguin, @mandian, and others.