Error after Nvidia driver install

Fresh install of Open Mandriva Lx 3.0 on UEFI boot. All my hardware was detected fine but my new Nvidia GTX 1060 which has to use the newest driver from there webpage. Got it installed then rebooted got to log in screen and after login i get this Error. “could not start kdeinit5” How do I fix this?

First I don’t have nvidia hardware.

https://wiki.openmandriva.org/en/3.0/Release_Notes

Under “Changes to Hardware Support”. The latest nVidia drivers just got published to
Non-Free-Updates repo like minutes ago.

Wish I could do more to help.

Dadgummit!:flushed: My post was incomplete. You probably already know this but to be thorough and for other users (from Release Notes):

"To access XFDrake, the DrakX video configuration tool go to Om-Welcome>Configure>Configure video drivers or go to Configure your Computer>Hardware>Set up the graphical server. "

We do need users/testers to help us with our video driver support especially regarding nVidia and other Proprietary drivers.

1 Like

I am going to remove the drivers installed from Nvidia website and use the drivers from the repo. Ill post back on the status. It will take a while because I am just going to reinstall because its was a fresh install and I always have a hard time removing proprietary drivers not installed through the repos. Thank you

1 Like

reinstalled and configured repos then updated system and used OM welcome wizard>configure>configure the video driver. It found the latest Nvidia driver but I got an Unstatisfied dependency error it wants libGLdispatch.so.0(64) I think I am missing a lib package but I dont know which one?

Please file a bug report.

https://issues.openmandriva.org/

Hi

The bug is arriving because of incompatibility between Nvidia drivers and last version of xorg server (1.18.4).

A message explains that we have to,

  • or, run Nvidia with “-ignoreABI option”,
  • or “downgrade to a previous xorg version”.

I tried both solutions but failed to have the graphics working.

Rosa R8 with a previous version of xorg server (1.17.4) works perfectly.

To be noted the bad behavior of “Nouveau” :

  • Artefacts when opening images,
  • Incompatibility with GoogleEarth,
  • Doesn’t show thumbnails in Dolphin or allow opening some .png images with Gimp or Gwenview (?)!
  • And certainly more…

Thank you.

Developers don’t tend to hang out in forums. If no one files a bug report they may not know this needs to be fixed. And bug report needs to be filed by someone with nVidia hardware.

I filed a bug report yesterday 8-19-16 sorry I did not post back.

Yesterday NVIDIA released newer driver package 367.44. Is there still problem “could not start kdeinit5”?

Hi,
The package comes in .run and the installation fails after accepting the Licence. => The message is that “Nouveau” has to be removed “before” Nvidia driver installation.
Of course, in trying to do so, xorg server and a lot of other stuff would be removed.

It is also said that if “Nouveau” is included in "initramfs …we have to see with our distribution devs… (…!) the way to uninstall this shit! (my personal opinion not the divine truth!)

However, on Nvidia site, when reading the changes with this driver version, it is specified that ABI is now supported (problem with openGL normally solved).

A+

I have receipt how to get rid of nouveau driver. This I used in 2014.2, as well as in LX3.0 and now in ROSA R8:

  1. Create new file “/etc/dracut.conf.d/dracut-disable-nouveau.conf”. Put in it: omit_drivers+=" nouveau "
  2. Run “dracut --force”.
  3. Create new file “/etc/modprobe.d/disable-nouveau.conf”. Put in it:
    blacklist nouveau
    options nouveau modeset=0
  4. Reboot PC.
  5. In console type: “systemctl isolate runlevel3.target”
  6. sh ./NVIDIA_installer.run
  7. reboot PC

This I managed with LX3.0 and NVIDIA 367.35. But after reboot I got error “could not start kdeini5”. Now I don’t have LX3.0, so I can’t try 367.44.

Where did you find on nvidia web site info about ABI?

Hi,

Concerning Nouveau removal :

  • Your message till line 5) OK;
    When rebooting I noticed Nouveau was absent. OK;

  • Line 6) Your command didn’t work, I had to change to directory I downloaded the driver file and run :
    sh ./NVIDIA-Linux-x86-367.44.run;

  • The License could this time be accepted and the installation started;

  • The diver was apparently installed (100%), but then, I was asked to chose Installation through DKMS or not;

  • At first I chose “With DKMS”, but failure => Message: “Unable to find the developpement tool CC in your path.” “Check GCC is installed.” => but GCC is installed.

  • Then I chose “without DKMS”, but failure again => An initial message read : “Driver file installation complete …Adding DKMS” … but then => “Failed to run /usr/sbin/dkmsbuild -m nvidia -v 367.44 -k 4.6.5-desktop-2omv.”

Concerning ABI (your last message)

  • I found the message concerning conflict between ABI and xorg.server last version on the net, after failing to install previous versions of the driver.

  • Yesterday, when downloading 367.44, I also downloaded new version of 340.96 and it is explained in the changes :
    “Support de X.org xserver ABI 20 (xorg-server 1.18).”
    http://www.nvidia.fr/download/driverResults.aspx/95378/fr
    Which confirms in my opinion, that the use of xorg server 1.18 version, like in OpenMandriva, needed a correction.

A+

To Ben79,

[quote=“ben79, post:8, topic:640”]
Developers don’t tend to hang out in forums. If no one files a bug report they may not know this needs to be fixed.[/quote]

Read messages above…

Do you understand why, when you’re not a pro or advanced user, declaring a bug is all an adventure?

Last time I did …(10 years ago or so)… the dev I was dealing with, requested me so many operations I was absolutely unable to do, I finished feeling like an idiot… For sure I was one, when declaring!

Hope your leg is OK!

Yes, I was not precise enough. I was lazy to write the long NVIDIA installer name, so I used placeholder “installer”. Of course in that step you should run NVIDIA installer downloaded from web.

Yes. I forgot I faced to this problem too with LX3.0. Don’t know why, but in 2014.2 there was symlink /usr/bin/cc but in LX3.0 it is missing. Solution is to make symlink “ln -s /usr/bin/gcc /usr/bin/cc” .

Regarding questions in nvidia installer process: For all of them I always choose “Yes”, except the one for registering with DKMS, there I always choose “No”. I always upgrade kernel manually and then after reboot I see only console, where I run NVIDIA installer manually.

340.96 has been released in 2015.11.16, so nearly one year ago. In changes for 367.44 http://www.nvidia.com/Download/driverResults.aspx/106780/en-us I don’t see anything about ABI. So since 367.35 wasn’t working, I doubt 367.44 will be.

Could you post URL for the bug you posted?

For info, related bugzilla ticket.

my ticket# 1852 was removed due to it was a duplicate of 1843 and 1860 reports of the same issue.