DSL connection is not working


DSL (pppoe) connection is not working. Also does not work with the rp-pppoe program. And in the old Mandriva 2010 everything works.

Hello @Luser248,

OK, we know “It’s broke” however there is nothing here to work on. To help us help you please read this.

By the way, DSL works in Fedora distribution.

@ben79 stop whining!
in the old Mandriva 2010 everything works’ and ‘works in Fedora distribution’ is all you need to know. What you want more??

:rofl: :crazy_face: :roll_eyes:

Can you please help us resolve that issue ?
We need from you all the details how you create that DSL connection, because not everybody uses these days DSL. I can’t reproduce this because im on WIFI and line is FTTH here so i do not have direct acces to ONT and do not know any login or password to create DSL connection.

I enter my username and password, select the Ethernet interface (enp0s20) and save. Then I press Connect, but the connection does not work. Writes a PPP failure. I’ve tried NetworkManager and rp-pppoe.

Please provide logs after that you set your DSL connection and you try to start it.

You can gather needed data by running omv-bug-report

Okay, sorry. I downloaded the latest OM 4.2 distribution and the DSL connection works on it. But I can’t get to some sites. Writes that there is no connection and “NS_ERROR_NOT_IMPLEMENTED”. And there seems to be no connection with the repositories. I can’t even install “make” and “gcc”.

@Luser248 just for information @TPG is OM developer who does by far the most work with systemd among many other things. So you want to take advantage of his help. To do that we need you to attach to your next post your omv-bug-report.log.zst. We make this very easy for users to do.

The following is for anyone having a technical problem with anOM Lx system.

Open OM-Welcome and navigate to OM-Features page and find ‘Bug report tool’:

Select that and enter your root password in the dialog window. This will create:

You can then attacht that file to your next post with the upload arrow. It is zst compressed file as there is a lot of information and logs for problem solving. If you want to see what is in the file you can uncompress it with the command unzst:

$ unzstd omv-bug-report.log.zst
omv-bug-report.log.zst: 243166 bytes

Then you can read yurself to sleep reading system logs, ect. :grinning:

The problem is, I can’t get to these sites:


Something is blocking them. Other sites are working. Disabling Firewall doesn’t help.

1 Like

Domain ORG does not work. Here is the log.

omv-bug-report.log.zst (72.6 КБ)

1 Like

The ORG domain is working. The repositories are working. It’s strange. Here’s a new log.

omv-bug-report.log.zst (64.5 КБ)

1 Like

I am user knowledge level and am not the ideal person to trouble shoot something like this. I posted something about your issue on IRC. You can go there yourself for possibly faster results and talking directly to devs. #openmandriva @ Freenode IRC. Or go here and select Chat (matrix type).

Have you tried removing systemd-resolved? It would be wise to download the systemd-resolved .rpm to have it handy in case there is any problem.

$ sudo rpm -e --nodeps systemd-resolved

Post-edit: Another possibility is to install the systemd package stack from Cooker. I have tested this in VBox and it works there. This file shows how I do that in such a way that I have the old systemd packages to reinstall if the Cooker ones do not work.

systemd-upgrade-to-cooker.txt (2.3 KB)

1 Like

Okay, thanks Ben. Everything is working now. Perhaps the provider has some problem.

I also noticed a bug. If you go to the Firewall settings, and then close the settings, then SystemSettings5 continues to be in processes. The settings cannot be started again until you kill this process.

Again, I can not go to the sites. Possibly after installing a system update.


But I can go to these sites:


Everything works in Live mode. The problem is in the installed system.

Found out a strangeness. Live has “systemd-resolved” installed, and in the installed system, it disappeared. I reinstalled the system and so far everything works.

1 Like