Display in Virtual Machine (Qemu/KVM)

Tags: #<Tag:0x00007fc0c1662220>

Hello,

  • OpenMandriva Lx version:
    4.0

  • Desktop environment (KDE, LXQT…):
    KDE Plasma

  • Description of the issue (screenshots if relevant):
    Cannot set the display resolution to 1600x900

  • Relevant informations (hardware involved, software version, logs or output…):

I have installed additionally spice-vdagent.
Display is spice-server, video is Virtio, 3D acceleration enabled.

If I set the resolution to 1600x900 in Systemsettings -> Display and Monitor, it always stalls at 1024x768. Hardware is a Sony Vaio E series notebook with 17’ screen. It works well with other distros e.g. Mageia and Fedora.

Btw. I am a bit jealous that you have made the transitions I want to see in Mageia: dnf and NetworkManager.

Best regards,
Bequimão

Welcome @Bequimao to OpenMandriva forum and the OM distro. We hope you enjoy your time spent here and with OM Lx.

Post-edit: Unfortunatly I’m not much help for your issue. OM officially supports running OM Lx in VirtualBox only. We do have developers that use Qemu and I suspect we will hear from one when they get some time and see this. Being a small group and all volunteer we do the best we can at helping users.

Hi @bequimao

maybe this will help you
https://stafwag.github.io/blog/blog/2018/04/22/high-screen-resolution-on-a-kvm-virtual-machine-with-qxl/

Hi Tomasz,

Thanks for the link. I tested QXL video and didn’t see any difference. The default memory of 16 MB should be sufficient - my own calculation. 1600 x 900 isn’t exactly high resolution. The default memory is not shown, host is Virt-Manager on openSUSE 15.1.

I found another one (German)
https://linux-blog.anracom.com/2017/04/06/kvm-video-qxl-und-video-virtio-video-aufloesung-eines-debian-8-gastes-mit-gnome-desktop-einstellen/
I modified /etc/default/grub

# GRUB_GFXPAYLOAD_LINUX=keep
...
GRUB_GFXMODE=1600x900

The resolution of the virtual console is now at 1600x900, but the display still stucks as if hardcoded.

Btw.
The cursor gets caught. Message is "Press Ctrl_L and Alt_L to release … That is quite annoying. This shortcut locks the screen under System settings -> Desktop behaviour -> Screen locking. After disabling it is still valid in other applications, e.g. konsole.

Kind greetings,
Bequimão

QXL: driver, kernel module qxl
Virtio : driver, kernel module virtio-pc

xrandr --output Virtual-1 --mode 1600x900
both cases: Configure crtc 0 failed.

My findings so far

spice-vdagent was installed, but not running.
In order to start it, I had to do the following steps:

# systemctl enable spice-vdagentd.service

Modify /etc/systemd/system/spice-vdagentd.target.wants/spice-vdagentd.service

...
# PIDFile=/var/run/spice-vdagentd/spice-vdagentd.pid
PIDFile=/run/spice-vdagentd/spice-vdagentd.pid
...

Modifiy /usr/lib/tmpfiles.d/spice-vdagentd.conf

...
d /run/spice-vdagentd 0755 root root -

Add 2 devices in Virt-Manager

  1. Channel spice
  2. Channel qemu-ga

It helps a lot to have spice-vdagentd running. But unfortunately the screen resolution problem is not yet solved.

spice-vdagent-0.12.0-9 is a tad outdated. As Openmandriva 4.0 is a fresh release, I would have expected version 0.19. It might be a security issue, too.

Greetings
Bequimão