Disable RST to install OM Lx (Acer Nitro 5 and others)

How to install Linux on Acer Nitro 5

Looks like Acer NItro 5 not come with legacy support because it use UEFI class 3 and thats why Linux instalation is a bit more complicated.

Here is blog post about installing Linux on your acer nitro 5 Is Linux installation alongside Windows - Nightmare in Acer Nitro 5?

Thanks ,
I read this link and I understand problems of this man. So after 2 days I was quit and I am tired to tried installing linux ubuntu and other distroes.
I am going to read link to the end and see if is he solve a problem.

Where I can change RST with optane mode to AHCI and how. I was trayed to download intel RST and disable it but it doesn’t work. I need help if somebody have time.

Are you trying to install OpenMandriva Lx or other Linux?

Looks like a BIOS setting. They may call that UEFI Firmware settings on newer computers. See this and this.

Welcome @leonski

@leonski I asked a question of our developers where they hang out on IRC. Here is what I asked:

< ben79> Question developers: User having a problem installing Linux on UEFI class 3 machine and I would like to know a bit more about this also.
< ben79> For Linux users are there any real differences with installing and using Linux, and OMLinux in particular with EFI class 3 machines?
< ben79> In my reading so far it looks as if there might be some differences in UEFI Firmware settings (what we tend to call BIOS) but other wise seems like it would be the same.

Edit: Our user channel on IRC is #openmandriva @ Freenode. You are welcome to go there and ask and eventually someone will reply. I say eventually because we are a small all volunteer group of contributors. So we all do what we can when we can but things like day jobs and family, well you know.

Thank you very much for the information, I am grateful for your effort and time. Now I’m going to try to do it.
Thanks again and best regards

Please let us know how you get on. And if you discover any tips or secrets please post here so it can help other users.

If you are trying to install OM Lx 4.1 (or any version) and run in to problems lets us know and we will do all we can to help.

No I just quit and, start to using windows on this machine
There is no support AHCI on bios, I try everything what I found on net but it doesn’t go so I just quit.
And i am looking for some other solution.


čet, 2. srp 2020. u 16:44 Ben Bullard via Forum OMA <discourse@openmandriva.org> napisao je:

There has to be a setting for SATA devices for Selecting at least either Raid or ACHI. If there is not you should return that computer. Not to have ACHI for SATA would be very, very, odd.

It is usually listed under something like SATA controller or SATA storage or Storage Devices or something like that.

I haven’t been active for a long time, but if I’m going to help someone with installing dual boot, linux and windows10 on Acer Nitro5 515-54

I want to share a link that shows how to exit the RAID array and switch to AHCI mode. After which linux can be installed and a dual boot can be made with windows10

Thanks for tip @leonski .

The OM Lx ISO’s have some options under “Troublshooting”

I wonder if we should discuss whether to add a “Turn of RST” option if that is possible.

Edit: Reading some more about this, it requires changing settings in BIOS and I do not know if any Linux installer could do that.

Note: As far as we know this has not been tried with any version of OM Lx yet, but it should work. If anyone knows about this we would really love to hear from you.

Moderator: Changed thread title in hopes that users with this issue will have an easier time finding this. Also moved to English/Support.