Central topic for users having troubles with latest updates

Had to manually remove gstreamer1-plugins-bad to get all updates installed.

1 Like

No problem, sorry you and others had to force update.

1 Like

Also that forced update did not work for me. After a huge amount of for me crazy text, it ended with those dependenc questions (had to choose between “yes” or “no” a lot of times if I wanted to ignore them).
Because I then could understand what I was doing, I stopped.
Will wait till some permanent solution comes up.

1 Like

Ok, let me try once more too… :slight_smile: Thanks for the efforts guys!!

urpmi --auto-update --test

LOG NL (packages removed): https://paste.ee/p/4HlNm
LOG ENG (packages removed): https://paste.ee/p/YMOFW
LOG ENG (answered defaults, NO to package removall): Paste.ee - OpenMandriva Fresh install not updating 201705 201706 (ENGLISH logs) (no package removal)

Have others posted success with this? I will do a test run for this… See what it gives :slight_smile:

Update: I guess not :confused: https://paste.ee/p/AbWZq (no idea why it isn’t colouring syntax here)

Also tested…

[root@OpenMandriva3Lx dev]# LC_ALL=C urpme gstreamer1-plugins --test unknown package: gstreamer1-plugins [root@OpenMandriva3Lx dev]#

You did not finish the process. You have to do all the steps:

urpmi task-plasma
urpme kdepim-addons
urpmi --auto-update
urpmi kdepim-addons

the last one is adding back latest version of packages that were removed. Y’all are letting the error message scare you to much. Again it is only telling that it is removing older 16.08 package versions which will be replaced with new 17.04 versions.

Y’all do understand that if you do either:

OR

# urpmi --allow-force --auto-update

Y’all can still install any package that was removed if you really need it.

I’m going to push few updates for this issue.

1 Like

Better to follow TPG’s lead on this issue than mine. He has superior knowledge on these issues.

1 Like

I was thinking the same thing… I really feel you underestimate the problem… :slight_smile:

Peace!

devnullius

I am clueless as of how you are gonna fix it, but… thanks and god speed! :slight_smile:

Devvie

Latest log: Paste.ee - latest log [root@OpenMandriva3Lx dev]# urpmi --auto-update --test

Any progress? : )

I am not 100% sure, but I believe those were the errors I was seeing. I would try the following.

urpme kdepim-addons
urpmi task-plasma
urpmi --auto-update
urpmi kdepim-addons
urpmi --auto-update

I think this fixes the issue.

1 Like

I wouldn’t dare to do it… Last time I tried stuff like this, I fully fubared the GUI and was left with a command prompt… I’d rather have the OK-TO-GO from maintenance team : )

If others dare to try… Do let us know pretty please?

Devvie

Maybe you could send a personal message (via this forum ) to TPG. TPG is developer extraordinare and OpenMandriva Lx 3.02 Release Manager.

I have the same problem. Tried the icon, and tried in configure your computer, and nothing happens

Tried this and it made no difference, here are my specs.
dipstick-pc ~]$ inxi -F
System: Host: dipstick-pc Kernel: 4.6.5-desktop-2omv x86_64 (64 bit)
Desktop: KDE Plasma 5.6.5
Distro: OpenMandrivaLinux 3.0 Einsteinium
Machine: Mobo: MSI model: 970A-G46 (MS-7693) v: 2.0
Bios: American Megatrends v: V2.6 date: 10/08/2013
CPU: Quad core AMD FX-8120 Eight-Core (-HT-MCP-) cache: 8192 KB
clock speeds: max: 3100 MHz 1: 1400 MHz 2: 1400 MHz
3: 1400 MHz 4: 1400 MHz 5: 1400 MHz 6: 1400 MHz
7: 1400 MHz 8: 1400 MHz
Graphics: Card: NVIDIA GT218 [GeForce 210]
Display Server: OpenMandriva X.org 118.4 driver: N/A
Resolution: 1280x768@59.87hz
GLX Renderer: Gallium 0.4 on NVA8
GLX Version: 3.0 Mesa 12.0.1
Audio: Card-1 NVIDIA High Definition Audio Controller
driver: snd_hda_intel
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel
Sound: ALSA v: k4.6.5-desktop-2omv
Network: Card-1: ADMtek NC100 Network Everywhere Fast Ethernet 10/100
driver: tulip
IF: enp3s6 state: down mac: 00:04:5a:74:44:04
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
IF: enp4s0 state: up speed: 1000 Mbps duplex: full
mac: 44:8a:5b:5d:99:89
Drives: HDD Total Size: 500.1GB (3.8% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB
ID-1: / size: 147G used: 6.2G (5%) fs: ext4 dev: /dev/sda7
ID-2: swap-1 size: 12.83GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 22.0C mobo: N/A gpu: 48.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 250 Uptime: 33 min Memory: 1222.3/11968.8MB
Client: Shell (bash) inxi: 2.2.27
[dipstick@dipstick-pc ~]$

Are you getting this error?

The following packages have to be removed for others to be upgraded:
kdepim-addons-16.04.3-1-omv2015.0.x86_64
(due to conflicts with messagelib-17.04.0-3-omv2015.0.x86_64)

The steps are to fix things when you are getting the above.

Having same problem with what? What did you install? If you install latest release here I suspect you won’t have problems with updating.

Edit: Lx 3.02 was released on June 21, 2017.

If you can’t install Lx 3.02 (by far fastest and easiest solution to update issue) could you provide more specific information? Please post output of each of the commands you have tried that don’t work. Posting only the commands with no output isn’t enough information for anyone to help.

Edit: If your computer is not English language for instance do like this"

# LC_ALL=C urpme kdepim-addons
# LC_ALL=C urpmi task-plasma
# LC_ALL=C urpmi --auto-update
# LC_ALL=C urpmi kdepim-addons
# LC_ALL=C urpmi --auto-update

but do post all output. If output is to much for a forum post (more than say 20 lines) then please use pastebin, paste.ee, or similar.