Can't install rgdal, undefined symbol: PrintGifError

Greetings to all OpenMandriva users, has anyone tried and succeeded to install rgdal in OMLX 2014.2? I really need that package to work and apparently the gdal package is the one which needs an update, is there any plan to provide the new version of gdal in the OMLX repositories?
I found a patch which is supposed to fix the problem, but I have not been able to aplly it correctly, since I keep getting the same erros when I try to install rgdal package in R.

Any help will be appreciated! Thanks in advance.

I don’t use R and I’m not sure I can help you efficiently.
The OmLx R packages seem to be rather old.
I suggest you to open a report in our bugzilla. Put “request” in the title and set the severity as trivial/enhancement.

I tried to compile R-3.2.4 from the sources. The result was fine except for the creation of pdf manuals (error Missing \begin{document}). I didn’t try to fix this issue.
I also tried to compile gdal 2.0.2 without the support of xml2 which breaks the configure tool. Result: ok.

Where did you find rgdal and the patch? All what I have found leads to broken links.

Thank you very much for the reply, I found the folloaing patch for my version of gdal: PrintGifError_renamed_to_GifErrorString_4.2.1.patch

I’ll try the bugzilla report and hopefully we will have an updated gdal package soon. I thought I might update with cooker but I know that will be harsh and my OMLX system actually is supporting all my work so it’s a big step!

Thank you very much again.

J. Manuel Islas

This patch seems related to the imlib library. Did you install it?

You might also try to install the rgdal package from rosa (x86_64) if there is no dependencies issue.

Ok!, thank you very much, I’ll try the Rosa gdal package. And no I could not install the patch. The whole issue is that by some reason the PrintGifError changed to GifPrintError, and this where the installation of rgdal stops.

I’ll try the package from rosa.

J. Manuel Islas

I meant: did you have to install imlib?

I had imlib already installed.
J. Manuel Islas