Can't create isolinux bootable isos on LX3

I suspect there is something broken with the binaries from LX3’s syslinux-6.03-2-omv2015.0.x86_64.
A bootable image gets stuck on the message

ISOLINUX 6.03 OpenMandriva Copyright © 1994-2014 H. Peter Anvin et al"

Using isolinux-debug.bin instead of isolinux.bin it prints the following:

ISOLINUX 6.03 OpenMandriva Copyright © 1994-2014 H. Peter Anvin et al
isolinux: Starting up, DL = E0
isolinux: Loaded spec packet OK, drive = E0
isolinux: Main image LBA = 00000026
isolinux: Image read, jumping to main code…

If I use binaries from omv 2014 syslinux-4.06-6-omv2014.0.x86_64 and keep everything else the same, the image boots normally. I have also tried using the isolinux binaries from Fedora 25’s syslinux-6.04-0.1.fc25.x86_64 and had no problems, so that’s why I thought something could be broken in this version of the package.

Below is a sequence of steps to create a dummy image and reproduce (or not) the issue:

mkdir -p live/boot/isolinux
echo -e "DEFAULT vesamenu.c32\nTIMEOUT 50\nPROMPT 0\n\nLABEL test\n    MENU LABEL \"Hello world\"" > live/boot/isolinux/isolinux.cfg

cp /usr/lib/syslinux/{vesamenu.c32,isolinux.bin} live/boot/isolinux/

cd live/; sudo mkisofs -b boot/isolinux/isolinux.bin -c boot/isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -V 'test' -cache-inodes -R -J -o ../test.iso .; cd -

I’ve tested the image on kvm and also real hardware. Of course you need to use isohybrid if you want to test this with a USB drive.

Like I said, repeating the same steps but taking the files from omv 2014 instead of lx3-syslinux results on a working image.

Please let me know if you can reproduce this problem or if there is something I can do to output more error messages. Thanks.

Thanks for reporting. A bug report would be more likely to get results.

I did that Ben, thanks.

https://issues.openmandriva.org/show_bug.cgi?id=2095

Solved. 2095 – Can't create isolinux bootable isos on LX3