Cannot connect to internet in openmandiva lx 3.01

Dear friends,

Today I tried openmandriva lx 3.01 64 bit from my usb flashdrive. I am really impressed with the distro. Its user-friendly and flexible but I could not connect to the internet no matter how many times I tried.

My internet connection is broadband internet (lan wire connected to my desktop pc lan port) which requires username and password. I input the username and password provided by the isp in DSL section in Network Centre but cannot connect.

Could you please give me a solution for this problem. Let me know where are my mistakes. Thanks in advance.

In OpenMandriva internet access is controlled by ‘NetworkManager’. There is an icon in ‘system tray’ in the Menu Panel at bottom of screen on right side. If I remember correctly that icon is greyed out and not visible if you don’t have a connection so it will be the blank spot in ‘system tray’. Find that and click on it and see if your connection is listed. If so select ‘connect’ and see if it asks for your user name and password. If that doesn’t work in the upper right corner of the dialog window is an icon for ‘Configure Network Connections’.

Please do let us know how get along with this. This is a new problem as far as I know and I need to know the solution myself.

Welcome to OpenMandriva tantrik.

I followed your instructions but to no avail. The following notifications appear after I try to connect the internet.

A firewall is active in openmandriva lx 3.01. Is there a way to close the firewall? Is the firewall creating the problem? If not, I absolutely have no idea what is going on. Do I need to disable the wired interface (enp3s0) and make a new connection? If so, how to disable it?

Thanks in advance.

Thanks. Highly appreciated.


please do NOT use Network Center, as it is obsoleted. Based on your description i’m guessing that your router or any other access device is running on PPoE. Please set up your connection by using plasma applet in your tray.

At this point you may need to consider filing a bug report here. I also posted request for help on this on our Cooker (developer) mailing list and IRC channel. You are welcome to ask there yourself. For more on that the wiki is here. Just look for Cooker under ‘Contributors’.

One developer on IRC suggests that, if possible, you use DHCP while all the PPPoE stuff is handled by your router? Our developers aren’t familiar with direct pppoe connection, in fact they/we’re wondering where you live?

Disabling (deleting) current connection and setting up a new one may do the trick. To disable current connection you do that in the applet in system tray by selecting the icon in upper right corner that opens ‘Connections - System Settings Module’ then select current connection right click and select delete. Then find the + sign click on it and set up connection there.

To try without firewall you’ll need to open Konsole and become root (su) and run:

# systemctl status firewalld.service
# systemctl stop firewalld.service
# systemctl status firewalld.service

Reason for doing it that way is so you can see what output looks like when it is working so you can confirm that it is stopped.

I live in bangladesh in south asia. In my area, broadband internet connection is provied by isp through lan wire connected in the lan port (situated in the motherboard, at the back of the cpu). I do not have a router. For that reason I need username and password, provided by the isp to connect to the internet. I could successfully connect to the internet in windows 7 sp1 (which I am currently using) and other linux distros (which I am testing) by choosing DSL internet type (in linux distro) from network centre and entering the login and password provided by the isp.

I disabled the firewall and tried again but to no avail. I noticed in the network centre that the wired (ethernet) - enp3s0 is disabled. It never activates no matter how much I click on the connect button. The following screenshot will help.

Every suggestion to solve this issue will be highly appreciated. Thanks

Okay I can see how this can be confusing because in OpenMandriva there are 2 tools provided to configure internet. (And I hope this all makes sense).

  1. Network Center - real name - drakx-net - this is strictly a Mandrake/Mandriva/OpenMandriva tool. It is also old, deprecated, written in Perl, and most important is not working for you.

  2. NetworkManager - real name - I don’t know what other LInux distros call it I only know NetworkManager. It is the more modern tool and is used by most (not all) modern Linux distros.

First thing to do is stop using Network Center and use NetworkManager. (I wish we didn’t have both but we do for now.) You’ve seen NetworkManager in other Linux distros. Again it is the icon or applet in system tray I’ve told about in earlier post. It looks like this:

Now select the Plus icon or sign and what do we see?

And there DSL is at the top of the list. In fact this is probably exactly what you’re used to in some other Linux distros. Hope this works.

Asking about where you live was for my education in how network access is handled in other locations. FWIW: I’m in Louisiana, United States and it does seem as if there is some difference in how 'net access is done here vs. Bangladesh.

tantrik see also here.

I discovered this thanks to you reporting this issue. If this is what happened to you I’m sorry it happened.

Dear ben79,

I tried to connect the internet using the same instructions, with pictures, that you provided in post#9. I tried this many times using the Networks icon in the system tray after I first installed openmandriva lx 3.01 in my usb but no result. I am always getting the notifications that I uploaded in post#4.

I also, downloaded and tried to install oma-welcome-2.0.8-1-omv2015.0.noarch.rpm from the link you provied in post#10 but showed the following notification instead:

After I clicked Ok, there was no indication of the package being installed.

Every suggestion to solve this issue will be highly appreciated. Thanks

tantrik for me and anyone else that tries to help could you (In OM Lx 3.01) open Konsole and run the command:

$ inxi -Fx

and post all of the output of that command here? That will give us some detailed hardware information.

Then I’m running out of suggestions. Here’s my last suggestions:

  1. You’re trying to test OpenMandriva Lx 3.01 off of a flash or pen drive correct? Instead install VirtualBox on an existing system on your computer and install Lx 3.01 there to try it out.

  2. There is a newer version of OM Lx 3 (3.02) in development. You could try the latest ISO of that. It will have a ton of updated packages including updated NetworkManager. (It does not have the latest version of OM-Welcome).

  3. If suggestion 2 doesn’t work then there needs to be a bug report. If you file a bug report please include the omv-bug-report-log as described here.

How are you trying to install? htmlscript error is unusual I don’t recall ever seeing. Instead open Konsole and go to directory where you downloaded package and become root (su) and run:

# urpmi oma-welcome-2.0.8-1-omv2015.0.noarch.rpm